<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<style type="text/css" style="display:none;"><!-- P {margin-top:0;margin-bottom:0;} --></style>
</head>
<body dir="ltr">
<div id="divtagdefaultwrapper" style="font-size:12pt;color:#000000;font-family:Calibri,Helvetica,sans-serif;" dir="ltr">
<p>I get a set_tx_gain error running a basic signal generator through RFNoC Radio:
<br>
<br>
Signal Source -> DMA FIFO -> DUC -> Radio  (See image below)</p>
<p><br>
</p>
<p></p>
<div>
<p>This is equivalent to:</p>
Signal Source --> USRP Sink    (Works fine)</div>
<br>
<br>
<a href="https://kb.ettus.com/File:dma_fifo_v02.png" class="OWAAutoLink" id="LPlnk387264" previewremoved="true">https://kb.ettus.com/File:dma_fifo_v02.png</a>
<p></p>
<p><a href="https://kb.ettus.com/File:dma_fifo_v02.png" class="OWAAutoLink" id="LPlnk387264" previewremoved="true"><br>
</a></p>
<p></p>
<div>Traceback (most recent call last):<br>
  File "/home/nvd/Documents/top_block.py", line 169, in <module><br>
    main()<br>
  File "/home/nvd/Documents/top_block.py", line 157, in main<br>
    tb = top_block_cls()<br>
  File "/home/nvd/Documents/top_block.py", line 84, in __init__<br>
    self.uhd_rfnoc_streamer_radio_0.set_tx_gain(0, 0)<br>
  File "/usr/local/lib/python2.7/dist-packages/ettus/ettus_swig.py", line 3235, in set_tx_gain<br>
    return _ettus_swig.rfnoc_radio_sptr_set_tx_gain(self, gain, chan)<br>
RuntimeError: _Map_base::at<br>
<br>
</div>
<p></p>
<p><br>
</p>
<p>I am using 3.15.LTS.</p>
<p><br>
</p>
Any ideas?
<p><br>
Thanks,<br>
</p>
<p><br>
</p>
<p>Jeff<br>
</p>
<br>
<p></p>
</div>
</body>
</html>