<div dir="ltr">Hi there,<div><p class="MsoNormal" align="center" style="text-align:center;margin:0in 0in 8pt;line-height:107%;font-size:11pt;font-family:Calibri,sans-serif"><br></p>

<p class="gmail-MsoListParagraphCxSpFirst" style="margin:0in 0in 0.0001pt 0.5in;line-height:107%;font-size:11pt;font-family:Calibri,sans-serif"><span style="font-size:12pt;line-height:107%;font-family:Symbol">·<span style="font-variant-numeric:normal;font-variant-east-asian:normal;font-stretch:normal;font-size:7pt;line-height:normal;font-family:"Times New Roman"">        
</span></span><span style="font-size:12pt;line-height:107%">I
have installed GNU Radio using PyBombs from </span><a href="http://ecee.colorado.edu/~mathys/ecen4652/SDRsoftware/GNURadioInstall.html" style="color:blue"><span style="font-size:12pt;line-height:107%">http://ecee.colorado.edu/~mathys/ecen4652/SDRsoftware/GNURadioInstall.html</span></a><span style="font-size:12pt;line-height:107%"></span></p>

<p class="gmail-MsoListParagraphCxSpMiddle" style="margin:0in 0in 0.0001pt 0.5in;line-height:107%;font-size:11pt;font-family:Calibri,sans-serif"><span style="font-size:12pt;line-height:107%"> </span></p>

<p class="gmail-MsoListParagraphCxSpMiddle" style="margin:0in 0in 0.0001pt 0.5in;line-height:107%;font-size:11pt;font-family:Calibri,sans-serif"><span style="font-size:12pt;line-height:107%;font-family:Symbol">·<span style="font-variant-numeric:normal;font-variant-east-asian:normal;font-stretch:normal;font-size:7pt;line-height:normal;font-family:"Times New Roman"">        
</span></span><span style="font-size:12pt;line-height:107%">UHD
was installed from </span><a href="https://kb.ettus.com/Building_and_Installing_the_USRP_Open-Source_Toolchain_(UHD_and_GNU_Radio)_on_Linux" style="color:blue"><span style="font-size:12pt;line-height:107%">https://kb.ettus.com/Building_and_Installing_the_USRP_Open-Source_Toolchain_(UHD_and_GNU_Radio)_on_Linux</span></a><span style="font-size:12pt;line-height:107%"></span></p>

<p class="gmail-MsoListParagraphCxSpMiddle" style="margin:0in 0in 0.0001pt 0.5in;line-height:107%;font-size:11pt;font-family:Calibri,sans-serif"><span style="font-size:12pt;line-height:107%"> </span></p>

<p class="gmail-MsoListParagraphCxSpMiddle" style="margin:0in 0in 0.0001pt 0.5in;line-height:107%;font-size:11pt;font-family:Calibri,sans-serif"><span style="font-size:12pt;line-height:107%;font-family:Symbol">·<span style="font-variant-numeric:normal;font-variant-east-asian:normal;font-stretch:normal;font-size:7pt;line-height:normal;font-family:"Times New Roman"">        
</span></span><span style="font-size:12pt;line-height:107%">GNU
Radio works fine. I’ve created an FM Radio application on it.  USRP E320 is also detected on the system.
However, when the flowgraph is executed on GNU Radio, following error shows up:</span></p>

<p class="gmail-MsoListParagraphCxSpMiddle" style="margin:0in 0in 0.0001pt 0.5in;line-height:107%;font-size:11pt;font-family:Calibri,sans-serif"><span style="font-size:12pt;line-height:107%"> </span></p>

<p class="gmail-MsoListParagraphCxSpLast" style="margin:0in 0in 8pt 0.5in;line-height:107%;font-size:11pt;font-family:Calibri,sans-serif"><i><span style="font-size:12pt;line-height:107%;color:red">RuntimeError: FPGA
component ‘noc_shell’ is revision 2 and UHD supports revision 3. Please either
upgrade the FPGA image (Recommended) or downgrade UHD.</span></i></p>

<p class="MsoNormal" style="text-align:justify;margin:0in 0in 8pt;line-height:107%;font-size:11pt;font-family:Calibri,sans-serif"><b><span style="font-size:12pt;line-height:107%">Troubleshooting:</span></b></p>

<p class="gmail-MsoListParagraphCxSpFirst" style="text-align:justify;margin:0in 0in 0.0001pt 0.5in;line-height:107%;font-size:11pt;font-family:Calibri,sans-serif"><span style="font-size:12pt;line-height:107%;font-family:Symbol">·</span><span style="font-size:12pt;line-height:107%">As
indicated by few web sources, Pybombs could’ve created issues during GNU Radio
installation. So, I re-installed GNU radio and UHD without using pybombs (from </span><a href="https://kb.ettus.com/Building_and_Installing_the_USRP_Open-Source_Toolchain_(UHD_and_GNU_Radio)_on_Linux)" style="color:blue">https://kb.ettus.com/Building_and_Installing_the_USRP_Open-Source_Toolchain_(UHD_and_GNU_Radio)_on_Linux)</a><span style="font-size:12pt;line-height:107%">.<b></b></span></p>

<p class="gmail-MsoListParagraphCxSpMiddle" style="text-align:justify;margin:0in 0in 0.0001pt 0.5in;line-height:107%;font-size:11pt;font-family:Calibri,sans-serif"><span style="font-size:12pt;line-height:107%"> But the error still persists.<b></b></span></p>

<p class="gmail-MsoListParagraphCxSpMiddle" style="text-align:justify;margin:0in 0in 0.0001pt 0.5in;line-height:107%;font-size:11pt;font-family:Calibri,sans-serif"><b><span style="font-size:12pt;line-height:107%"> </span></b></p>

<p class="gmail-MsoListParagraphCxSpMiddle" style="margin:0in 0in 0.0001pt 0.5in;line-height:107%;font-size:11pt;font-family:Calibri,sans-serif"><i><span style="font-size:12pt;line-height:107%;color:red">RuntimeError: FPGA
component ‘noc_shell’ is revision 2 and UHD supports revision 6. Please either
upgrade the FPGA image (Recommended) or downgrade UHD.</span></i></p>

<p class="gmail-MsoListParagraphCxSpMiddle" style="text-align:justify;margin:0in 0in 0.0001pt 0.5in;line-height:107%;font-size:11pt;font-family:Calibri,sans-serif"><b><span style="font-size:12pt;line-height:107%"> </span></b></p>

<p class="gmail-MsoListParagraphCxSpMiddle" style="text-align:justify;margin:0in 0in 0.0001pt 0.5in;line-height:107%;font-size:11pt;font-family:Calibri,sans-serif"><b><span style="font-size:12pt;line-height:107%"> </span></b></p>

<p class="gmail-MsoListParagraphCxSpLast" style="text-align:justify;margin:0in 0in 8pt 0.5in;line-height:107%;font-size:11pt;font-family:Calibri,sans-serif"><span style="font-size:12pt;line-height:107%;font-family:Symbol">·</span><span style="font-size:12pt;line-height:107%">Moreover,
the required installation libraries for UHD are supported for Ubuntu version
18.10 or less. Whereas, our system has Ubuntu version 19.0. Could this be the
possible reason for this issue? Should I downgrade Ubuntu to 18.10?<b></b></span></p></div></div>