<html>
  <head>
    <meta content="text/html; charset=windows-1252"
      http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    <div class="moz-cite-prefix">On 03/21/2019 04:06 PM, Xingjian Chen
      via USRP-users wrote:<br>
    </div>
    <blockquote cite="mid:884a909797444e189d36ac4d4578d398@umass.edu"
      type="cite">
      <meta http-equiv="Content-Type" content="text/html;
        charset=windows-1252">
      <style type="text/css" style="display:none;"><!-- P {margin-top:0;margin-bottom:0;} --></style>
      <div id="divtagdefaultwrapper"
style="font-size:12pt;color:#000000;font-family:Calibri,Helvetica,sans-serif;"
        dir="ltr">
        Dear all,
        <div><span style="font-size: 12pt;">I am trying to use two tx
            channels and one rx channel at the same time. Now, I can
            do 1 tx and 1 rx work at the same time no matter which tx
            channel I use. However, I cannot make 2 tx channels working <span
              style="font-family: Calibri, Helvetica, sans-serif,
              EmojiFont, "Apple Color Emoji", "Segoe UI
              Emoji", NotoColorEmoji, "Segoe UI Symbol",
              "Android Emoji", EmojiSymbols; font-size: 16px;">with

              1 rx</span> properly. I narrow down to a point that in my
            cpp control file in host computer. As long as I set both tx
            channel for the streamer to true, the received signal
            becomes 1/4 cycle. Please check the pictures below or in the
            attachment.</span></div>
        <div><span style="font-size: 12pt;"><span></span></span></div>
        <div><span style="font-size: 12pt;"><br>
          </span>
          <div>
            <div>    tx_radio_ctrl->set_tx_streamer(true, tx_chan);</div>
            <div>    tx_radio_ctrl->set_tx_streamer(true, tx_chan_1);</div>
            <div>    rx_radio_ctrl->set_rx_streamer(true, rx_chan);</div>
            <div><br>
            </div>
            <div>
              <div style="font-family: Calibri, Helvetica, sans-serif,
                EmojiFont, "Apple Color Emoji", "Segoe UI
                Emoji", NotoColorEmoji, "Segoe UI
                Symbol", "Android Emoji", EmojiSymbols;
                font-size: 16px;">
                <span style="font-size: 12pt;">When I check in the FPGA
                  code in the receiving chain, I see that the
                  <b>m_axis_data_tvalid</b> is switching between high
                  and low. I am wondering if there is any way to set up
                  in cpp or host computer such that forcing the rx radio
                  to keep streaming without any break when using 2 tx
                  channels? I tried uhd::stream_cmd_t
                  stream_cmd(uhd::stream_cmd_t::STREAM_MODE_START_CONTINUOUS); </span></div>
              <div style="font-family: Calibri, Helvetica, sans-serif,
                EmojiFont, "Apple Color Emoji", "Segoe UI
                Emoji", NotoColorEmoji, "Segoe UI
                Symbol", "Android Emoji", EmojiSymbols;
                font-size: 16px;">
                <span style="font-size: 12pt;">but no luck. Thank you in
                  advance!</span></div>
              <br>
            </div>
          </div>
        </div>
      </div>
    </blockquote>
    As far as I know, 2 x 1 MIMO is not supported on the E31x series. 
    If you're using 2 TX channels, you MUST also configure for two RX
    channels.<br>
      You can simply ignore the data from one channel in your
    flow-graph.<br>
    <br>
    <br>
    <blockquote cite="mid:884a909797444e189d36ac4d4578d398@umass.edu"
      type="cite">
      <div id="divtagdefaultwrapper"
style="font-size:12pt;color:#000000;font-family:Calibri,Helvetica,sans-serif;"
        dir="ltr">
        <div>
          <div>
            <div>
            </div>
            <img size="67306" contenttype="image/png" id="img269641"
              contextid="img831077" tabindex="0" style="max-width:
              99.9%; user-select: none;"
              src="cid:part1.07070204.07010206@gmail.com"><br>
          </div>
        </div>
        <div><img size="69120" contenttype="image/png" id="img4"
            contextid="img569340" tabindex="0" style="max-width: 99.9%;
            user-select: none;"
            src="cid:part2.09070303.00020304@gmail.com"><br>
        </div>
        <div><img size="69609" contenttype="image/png" id="img338907"
            contextid="img217049" tabindex="0" style="max-width: 99.9%;
            user-select: none;"
            src="cid:part3.00020404.02020903@gmail.com"><br>
        </div>
        <div><br>
        </div>
      </div>
      <br>
      <fieldset class="mimeAttachmentHeader"></fieldset>
      <br>
      <pre wrap="">_______________________________________________
USRP-users mailing list
<a class="moz-txt-link-abbreviated" href="mailto:USRP-users@lists.ettus.com">USRP-users@lists.ettus.com</a>
<a class="moz-txt-link-freetext" href="http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com">http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com</a>
</pre>
    </blockquote>
    <br>
  </body>
</html>