<div dir="ltr"><div dir="ltr"><div dir="ltr"><div dir="ltr">Hi Ayaz,<div>Can you try to run the command <i>uhd_usrp_probe</i> and check that opens the USRP with USB3 and not USB2?</div><div><br></div><div><div><font face="monospace, monospace">linux; GNU C++ version 7.3.0; Boost_106501; UHD_003.009.007-5-ge8202128</font></div><div><br></div><div><font face="monospace, monospace">-- Detected Device: B210</font></div><div><b><font face="monospace, monospace">-- Operating over USB 3.</font></b></div><div><font face="monospace, monospace">-- Initialize CODEC control...</font></div><div><font face="monospace, monospace">-- Initialize Radio control...</font></div><div><font face="monospace, monospace">-- Performing register loopback test... pass</font></div><div><font face="monospace, monospace">-- Performing register loopback test... pass</font></div><div><font face="monospace, monospace">-- Performing CODEC loopback test... pass</font></div><div><font face="monospace, monospace">-- Performing CODEC loopback test... pass</font></div></div><div><br></div><div>Also, I recommend you to benchmark your system: </div><div><a href="https://kb.ettus.com/Verifying_the_Operation_of_the_USRP_Using_UHD_and_GNU_Radio#Benchmarking_your_system">https://kb.ettus.com/Verifying_the_Operation_of_the_USRP_Using_UHD_and_GNU_Radio#Benchmarking_your_system</a><br></div><div><br></div><div>Regards,</div><div>Xavier</div><div><br></div></div></div></div></div><br><div class="gmail_quote"><div dir="ltr" class="gmail_attr">On Sun, 10 Mar 2019 at 18:59, Ayaz Mahmud via USRP-users <<a href="mailto:usrp-users@lists.ettus.com">usrp-users@lists.ettus.com</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">





<div lang="EN-US">
<div class="gmail-m_-7772697849081466223WordSection1">
<p class="MsoNormal">Trying to develop 802.11n (a 2 by 2 MIMO) standard by using two B210s. Initially started with the existing flow of GnuRadio/examples/digital/OFDM/tx.ofdm.grc. Lets take only the transmitter side for this question.</p>
<p class="MsoNormal"><u></u> <u></u></p>
<p class="MsoNormal">Things that are changed in OFDM.grc:</p>
<ol style="margin-top:0in" start="1" type="1">
<li class="gmail-m_-7772697849081466223MsoListParagraph" style="margin-left:0in">The OFDM allocator block: The sync word. It is changed as per the rule of 802.11n. That is, we use preambles (STF/LTF…)</li><li class="gmail-m_-7772697849081466223MsoListParagraph" style="margin-left:0in">Made two exact same chains (just copying one flow), which previously was one, and fed into USRP-2 input ports.</li><li class="gmail-m_-7772697849081466223MsoListParagraph" style="margin-left:0in">Sampling rate : 20 MSPS</li></ol>
<p class="MsoNormal"><u></u> <u></u></p>
<p class="MsoNormal">Problem : </p>
<ol style="margin-top:0in" start="1" type="1">
<li class="gmail-m_-7772697849081466223MsoListParagraph" style="margin-left:0in">Overflow occurs. (I am using USB 3.0 interface, on MAC). Two of the interfaces connected with this same laptop. Max sample rate it can handle is about 4MSPS.</li></ol>
<p class="MsoNormal"><u></u> <u></u></p>
<p class="MsoNormal">I have tried saving the files in the RAM and then transmit. Does not improve the situation much.</p>
<p class="MsoNormal"><u></u> <u></u></p>
<p class="MsoNormal">Need suggestions on where should I look for the fix. <u></u><u></u></p>
<p class="MsoNormal"><u></u> <u></u></p>
<p class="MsoNormal">Thanks.<u></u><u></u></p>
</div>
</div>

_______________________________________________<br>
USRP-users mailing list<br>
<a href="mailto:USRP-users@lists.ettus.com" target="_blank">USRP-users@lists.ettus.com</a><br>
<a href="http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com" rel="noreferrer" target="_blank">http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com</a><br>
</blockquote></div>