<html><head><meta http-equiv="Content-Type" content="text/html; charset=utf-8"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; line-break: after-white-space;" class="">Hi Thomas, <div class=""><br class=""></div><div class="">I also am new to USRP so if I tell you something that is not correct perhaps someone more knowledgeable will weigh in and correct me for both our benefits.  </div><div class=""><br class=""></div><div class="">The error you received indicates (I think) that the FPGA firmware version and the UHD version you have installed are incompatible.  I obtained this same type of error when first bringing up my x310.  To cure it, I had to find a pair of versions of firmware and software that are compatible.  In my case I found that X300 firmware version 36.0 works with UHD version 3.14.0 so that’s what I am currently using.  </div><div class=""><br class=""></div><div class="">It wasn’t clear to me (and still isn’t) how one determines which firmware and software versions are compatible.  If there is a way to do that I’ll be interested in learning about how to do it.  I simply used a trial and error method until I found a pair that worked together.  Basically, I installed the latest UHD version of software and found that X300 XG FPGA v36.0 firmware worked with it on my USRP.  </div><div class=""><br class=""></div><div class="">Good luck, I know it can be frustrating when you don’t know all that you need to know to make things work smoothly, but things do get better in terms of your understanding if you hammer on the issues long enough.  </div><div class=""><br class=""></div><div class="">Maybe this is enough of a hint to allow you to make progress on it for your USRP?  </div><div class=""><br class=""></div><div class="">Joe<br class=""><div><br class=""><blockquote type="cite" class=""><div class="">On Mar 9, 2019, at 12:00 PM, Thomas Lavarenne via USRP-users <<a href="mailto:usrp-users@lists.ettus.com" class="">usrp-users@lists.ettus.com</a>> wrote:</div><br class="Apple-interchange-newline"><div class=""><div dir="ltr" class=""><div dir="ltr" class=""><div class="">Yes, it worked, but the script were on  /usr/lib/uhd/utils/ and same error...<br class=""></div><div class=""><br class=""></div><div class="">sudo /usr/lib/uhd/utils/uhd_images_downloader.py<br class="">[sudo] Mot de passe de user :         <br class="">[INFO] Images destination: /usr/share/uhd/images<br class="">[INFO] Target usrp1_b100_fw_default is up to date.<br class="">[INFO] Target x3xx_x310_fpga_default is up to date.<br class="">[INFO] Target usrp2_n210_fpga_default is up to date.<br class="">[INFO] Target n230_n230_fpga_default is up to date.<br class="">[INFO] Target usrp1_b100_fpga_default is up to date.<br class="">[INFO] Target b2xx_b200_fpga_default is up to date.<br class="">[INFO] Target usrp2_n200_fpga_default is up to date.<br class="">[INFO] Target e3xx_e320_fpga_default is up to date.<br class="">[INFO] Target n3xx_n310_fpga_default is up to date.<br class="">[INFO] Target b2xx_b205mini_fpga_default is up to date.<br class="">[INFO] Target x3xx_x300_fpga_default is up to date.<br class="">[INFO] Target octoclock_octoclock_fw_default is up to date.<br class="">[INFO] Target usrp2_usrp2_fw_default is up to date.<br class="">[INFO] Target usrp2_n200_fw_default is up to date.<br class="">[INFO] Target usrp2_usrp2_fpga_default is up to date.<br class="">[INFO] Target b2xx_common_fw_default is up to date.<br class="">[INFO] Target b2xx_b200mini_fpga_default is up to date.<br class="">[INFO] Target usrp1_usrp1_fpga_default is up to date.<br class="">[INFO] Target usb_common_windrv_default is up to date.<br class="">[INFO] Target usrp2_n210_fw_default is up to date.<br class="">[INFO] Target n3xx_n300_fpga_default is up to date.<br class="">[INFO] Target e3xx_e310_fpga_default is up to date.<br class="">[INFO] Target b2xx_b210_fpga_default is up to date.<br class=""><br class=""></div></div></div><br class=""><div class="gmail_quote"><div dir="ltr" class="gmail_attr">Le sam. 9 mars 2019 à 19:58, Brian Padalino <<a href="mailto:bpadalino@gmail.com" class="">bpadalino@gmail.com</a>> a écrit :<br class=""></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div dir="ltr" class=""><div dir="ltr" class=""><div dir="ltr" class=""></div><div class="gmail_quote"><div dir="ltr" class="gmail_attr">On Sat, Mar 9, 2019 at 1:45 PM Thomas Lavarenne via USRP-users <<a href="mailto:usrp-users@lists.ettus.com" target="_blank" class="">usrp-users@lists.ettus.com</a>> wrote:<br class=""></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div dir="ltr" class=""><div class="">Hello,</div><div class="">I'm new here and pretty new with usrp. I'm trying to use usrp-2900 with GNU Radio and Ubuntu 18.04, but i have this problem (latest driver uhd from source):<br class=""></div><div class=""><br class=""></div><div class=""><div class="">'''<br class=""></div><div class="">linux; GNU C++ version 7.3.0; Boost_106501; UHD_003.010.003.000-0-unknown<br class=""><br class="">-- Loading firmware image: /usr/share/uhd/images/usrp_b200_fw.hex...<br class="">-- Detected Device: B200<br class="">-- Loading FPGA image: /usr/share/uhd/images/usrp_b200_fpga.bin... done<br class="">-- Operating over USB 3.<br class="">Traceback (most recent call last):<br class="">  File "/home/user/top_block.py", line 166, in <module><br class="">    main()<br class="">  File "/home/user/top_block.py", line 154, in main<br class="">    tb = top_block_cls()<br class="">  File "/home/user/top_block.py", line 78, in __init__<br class="">    channels=range(1),<br class="">  File "/usr/lib/python2.7/dist-packages/gnuradio/uhd/__init__.py", line 122, in constructor_interceptor<br class="">    return old_constructor(*args)<br class="">  File "/usr/lib/python2.7/dist-packages/gnuradio/uhd/uhd_swig.py", line 2683, in make<br class="">    return _uhd_swig.usrp_source_make(*args)<br class=""><b class="">RuntimeError: RuntimeError: Expected FPGA compatibility number 14, but got 16:<br class="">The FPGA build is not compatible with the host code build.</b><br class="">Please run:<br class=""><br class=""> "/usr/lib/x86_64-linux-gnu/uhd/utils/uhd_images_downloader.py"<br class=""><br class="">>>> Done</div><div class="">''''</div><div class="">Any ideas accepted!</div></div></div></blockquote><div class=""><br class=""></div><div class="">Have you tried running:</div><div class=""><br class=""></div><div class="">  $ sudo /usr/lib/x86_64-linux-gnu/uhd/utils/uhd_images_downloader.py</div><div class=""><br class=""></div><div class="">As the message suggests?</div><div class=""><br class=""></div><div class="">Brian</div></div></div></div>
</blockquote></div>
_______________________________________________<br class="">USRP-users mailing list<br class=""><a href="mailto:USRP-users@lists.ettus.com" class="">USRP-users@lists.ettus.com</a><br class="">http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com<br class=""></div></blockquote></div><br class=""></div></body></html>