<div dir="ltr"><div dir="ltr"><div dir="ltr"></div><div class="gmail_quote"><div dir="ltr" class="gmail_attr">On Sat, Mar 9, 2019 at 1:45 PM Thomas Lavarenne via USRP-users <<a href="mailto:usrp-users@lists.ettus.com">usrp-users@lists.ettus.com</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div dir="ltr"><div>Hello,</div><div>I'm new here and pretty new with usrp. I'm trying to use usrp-2900 with GNU Radio and Ubuntu 18.04, but i have this problem (latest driver uhd from source):<br></div><div><br></div><div><div>'''<br></div><div>linux; GNU C++ version 7.3.0; Boost_106501; UHD_003.010.003.000-0-unknown<br><br>-- Loading firmware image: /usr/share/uhd/images/usrp_b200_fw.hex...<br>-- Detected Device: B200<br>-- Loading FPGA image: /usr/share/uhd/images/usrp_b200_fpga.bin... done<br>-- Operating over USB 3.<br>Traceback (most recent call last):<br>  File "/home/user/top_block.py", line 166, in <module><br>    main()<br>  File "/home/user/top_block.py", line 154, in main<br>    tb = top_block_cls()<br>  File "/home/user/top_block.py", line 78, in __init__<br>    channels=range(1),<br>  File "/usr/lib/python2.7/dist-packages/gnuradio/uhd/__init__.py", line 122, in constructor_interceptor<br>    return old_constructor(*args)<br>  File "/usr/lib/python2.7/dist-packages/gnuradio/uhd/uhd_swig.py", line 2683, in make<br>    return _uhd_swig.usrp_source_make(*args)<br><b>RuntimeError: RuntimeError: Expected FPGA compatibility number 14, but got 16:<br>The FPGA build is not compatible with the host code build.</b><br>Please run:<br><br> "/usr/lib/x86_64-linux-gnu/uhd/utils/uhd_images_downloader.py"<br><br>>>> Done</div><div>''''</div><div>Any ideas accepted!</div></div></div></blockquote><div><br></div><div>Have you tried running:</div><div><br></div><div>  $ sudo /usr/lib/x86_64-linux-gnu/uhd/utils/uhd_images_downloader.py</div><div><br></div><div>As the message suggests?</div><div><br></div><div>Brian</div></div></div></div>