<div><span class="highlight" style="background-color:rgb(255, 255, 255)"><span class="colour" style="color:rgb(85, 85, 85)"><span class="font" style="font-family:Arial, "Helvetica Neue", Helvetica, sans-serif"><span class="size" style="font-size:14px">That does not work. Here is an excerpt from dmesg followed by the commands:</span></span></span></span><br></div><div><br></div><div><span class="highlight" style="background-color:rgb(255, 255, 255)"><span class="colour" style="color:rgb(85, 85, 85)"><span class="font" style="font-family:Arial, "Helvetica Neue", Helvetica, sans-serif"><span class="size" style="font-size:14px">[    2.591180] IPv6: ADDRCONF(NETDEV_UP): eno1: link is not ready</span></span></span></span><br></div><div><span class="highlight" style="background-color:rgb(255, 255, 255)"><span class="colour" style="color:rgb(85, 85, 85)"><span class="font" style="font-family:Arial, "Helvetica Neue", Helvetica, sans-serif"><span class="size" style="font-size:14px">[    2.633612] IPv6: ADDRCONF(NETDEV_UP): wlp58s0: link is not ready</span></span></span></span><br></div><div><span class="highlight" style="background-color:rgb(255, 255, 255)"><span class="colour" style="color:rgb(85, 85, 85)"><span class="font" style="font-family:Arial, "Helvetica Neue", Helvetica, sans-serif"><span class="size" style="font-size:14px">[    2.899173] Bluetooth: BNEP (Ethernet Emulation) ver 1.3</span></span></span></span><br></div><div><span class="highlight" style="background-color:rgb(255, 255, 255)"><span class="colour" style="color:rgb(85, 85, 85)"><span class="font" style="font-family:Arial, "Helvetica Neue", Helvetica, sans-serif"><span class="size" style="font-size:14px">[    2.899175] Bluetooth: BNEP filters: protocol multicast</span></span></span></span><br></div><div><span class="highlight" style="background-color:rgb(255, 255, 255)"><span class="colour" style="color:rgb(85, 85, 85)"><span class="font" style="font-family:Arial, "Helvetica Neue", Helvetica, sans-serif"><span class="size" style="font-size:14px">[    2.899177] Bluetooth: BNEP socket layer initialized</span></span></span></span><br></div><div><span class="highlight" style="background-color:rgb(255, 255, 255)"><span class="colour" style="color:rgb(85, 85, 85)"><span class="font" style="font-family:Arial, "Helvetica Neue", Helvetica, sans-serif"><span class="size" style="font-size:14px">[    6.267182] usb 1-2: device descriptor read/64, error -110</span></span></span></span><br></div><div><span class="highlight" style="background-color:rgb(255, 255, 255)"><span class="colour" style="color:rgb(85, 85, 85)"><span class="font" style="font-family:Arial, "Helvetica Neue", Helvetica, sans-serif"><span class="size" style="font-size:14px">[    7.338228] wlp58s0: authenticate with dc:ef:09:96:ad:2c</span></span></span></span><br></div><div><span class="highlight" style="background-color:rgb(255, 255, 255)"><span class="colour" style="color:rgb(85, 85, 85)"><span class="font" style="font-family:Arial, "Helvetica Neue", Helvetica, sans-serif"><span class="size" style="font-size:14px">[    7.341527] wlp58s0: send auth to dc:ef:09:96:ad:2c (try 1/3)</span></span></span></span><br></div><div><span class="highlight" style="background-color:rgb(255, 255, 255)"><span class="colour" style="color:rgb(85, 85, 85)"><span class="font" style="font-family:Arial, "Helvetica Neue", Helvetica, sans-serif"><span class="size" style="font-size:14px">[    7.347540] wlp58s0: authenticated</span></span></span></span><br></div><div><span class="highlight" style="background-color:rgb(255, 255, 255)"><span class="colour" style="color:rgb(85, 85, 85)"><span class="font" style="font-family:Arial, "Helvetica Neue", Helvetica, sans-serif"><span class="size" style="font-size:14px">[    7.348011] wlp58s0: associate with dc:ef:09:96:ad:2c (try 1/3)</span></span></span></span><br></div><div><span class="highlight" style="background-color:rgb(255, 255, 255)"><span class="colour" style="color:rgb(85, 85, 85)"><span class="font" style="font-family:Arial, "Helvetica Neue", Helvetica, sans-serif"><span class="size" style="font-size:14px">[    7.351852] wlp58s0: RX AssocResp from dc:ef:09:96:ad:2c (capab=0x1411 status=0 aid=1)</span></span></span></span><br></div><div><span class="highlight" style="background-color:rgb(255, 255, 255)"><span class="colour" style="color:rgb(85, 85, 85)"><span class="font" style="font-family:Arial, "Helvetica Neue", Helvetica, sans-serif"><span class="size" style="font-size:14px">[    7.354224] wlp58s0: associated</span></span></span></span><br></div><div><span class="highlight" style="background-color:rgb(255, 255, 255)"><span class="colour" style="color:rgb(85, 85, 85)"><span class="font" style="font-family:Arial, "Helvetica Neue", Helvetica, sans-serif"><span class="size" style="font-size:14px">[    7.354248] IPv6: ADDRCONF(NETDEV_CHANGE): wlp58s0: link becomes ready</span></span></span></span><br></div><div><span class="highlight" style="background-color:rgb(255, 255, 255)"><span class="colour" style="color:rgb(85, 85, 85)"><span class="font" style="font-family:Arial, "Helvetica Neue", Helvetica, sans-serif"><span class="size" style="font-size:14px">[   22.135877] usb 1-2: device descriptor read/64, error -110</span></span></span></span><br></div><div><span class="highlight" style="background-color:rgb(255, 255, 255)"><span class="colour" style="color:rgb(85, 85, 85)"><span class="font" style="font-family:Arial, "Helvetica Neue", Helvetica, sans-serif"><span class="size" style="font-size:14px">[   22.399721] usb 1-2: new high-speed USB device number 3 using xhci_hcd</span></span></span></span><br></div><div><span class="highlight" style="background-color:rgb(255, 255, 255)"><span class="colour" style="color:rgb(85, 85, 85)"><span class="font" style="font-family:Arial, "Helvetica Neue", Helvetica, sans-serif"><span class="size" style="font-size:14px">[   27.765003] usb 1-2: device descriptor read/64, error -110</span></span></span></span><br></div><div><br></div><div><span class="highlight" style="background-color:rgb(255, 255, 255)"><span class="colour" style="color:rgb(85, 85, 85)"><span class="font" style="font-family:Arial, "Helvetica Neue", Helvetica, sans-serif"><span class="size" style="font-size:14px">root@ju:/usr/local/lib/uhd/utils# uhd_find_devices<span> </span></span></span></span></span><br></div><div><span class="highlight" style="background-color:rgb(255, 255, 255)"><span class="colour" style="color:rgb(85, 85, 85)"><span class="font" style="font-family:Arial, "Helvetica Neue", Helvetica, sans-serif"><span class="size" style="font-size:14px">linux; GNU C++ version 5.4.0 20160609; Boost_105800; UHD_003.009.007-0-g50839059</span></span></span></span><br></div><div><br></div><div><span class="highlight" style="background-color:rgb(255, 255, 255)"><span class="colour" style="color:rgb(85, 85, 85)"><span class="font" style="font-family:Arial, "Helvetica Neue", Helvetica, sans-serif"><span class="size" style="font-size:14px">No UHD Devices Found</span></span></span></span><br></div><div><br></div><div><span class="highlight" style="background-color:rgb(255, 255, 255)"><span class="colour" style="color:rgb(85, 85, 85)"><span class="font" style="font-family:Arial, "Helvetica Neue", Helvetica, sans-serif"><span class="size" style="font-size:14px">root@ju:/usr/local/lib/uhd/utils# ./b2xx_fx3_utils --reset-device</span></span></span></span><br></div><div><span class="highlight" style="background-color:rgb(255, 255, 255)"><span class="colour" style="color:rgb(85, 85, 85)"><span class="font" style="font-family:Arial, "Helvetica Neue", Helvetica, sans-serif"><span class="size" style="font-size:14px">linux; GNU C++ version 5.4.0 20160609; Boost_105800; UHD_003.009.007-0-g50839059</span></span></span></span><br></div><div><br></div><div><span class="highlight" style="background-color:rgb(255, 255, 255)"><span class="colour" style="color:rgb(85, 85, 85)"><span class="font" style="font-family:Arial, "Helvetica Neue", Helvetica, sans-serif"><span class="size" style="font-size:14px">Cannot open device</span></span></span></span><br></div><div><span class="highlight" style="background-color:rgb(255, 255, 255)"><span class="colour" style="color:rgb(85, 85, 85)"><span class="font" style="font-family:Arial, "Helvetica Neue", Helvetica, sans-serif"><span class="size" style="font-size:14px">root@ju:/usr/local/lib/uhd/utils#<span> </span></span></span></span></span><br></div><div><br></div><div class="protonmail_signature_block"><div class="protonmail_signature_block-user"><div><div>Thanks<br></div><div>T<br></div></div></div><div class="protonmail_signature_block-proton protonmail_signature_block-empty"><br></div></div><div><br></div><blockquote class="protonmail_quote" type="cite"><div>-------- Original Message --------<br></div><div>Subject: Re: [USRP-users] Problems with Ettus B210 and Intel Nuk<br></div><div>Local Time: October 31, 2017 4:06 PM<br></div><div>UTC Time: October 31, 2017 8:06 PM<br></div><div>From: nate.temple@ettus.com<br></div><div>To: Neel Pandeya <neel.pandeya@ettus.com><br></div><div>"Humphries, James R." <humphriesjr@ornl.gov>, usrp-users@lists.ettus.com <usrp-users@lists.ettus.com>, tathagata@protonmail.ch<br></div><div><br></div><div><div>Hi Tathagata,<br></div><div> <br></div><div> After you boot, if you run: $UHD_INSTALL_PREFIX/utils/b2xx_fx3_utils --reset-device<br></div><div> <br></div><div> Are you able to then initialize the USRP by running uhd_usrp_probe?<br></div><div> <br></div><div> <br></div><div> Regards,<br></div><div> Nate Temple<br></div><div> <br></div><div> <br></div></div><blockquote><div>On Oct 31, 2017, at 11:11 AM, Neel Pandeya via USRP-users <a href="mailto:usrp-users@lists.ettus.com">usrp-users@lists.ettus.com</a> wrote:<br></div><div>Hello Tathagata:<br></div><div>If I recall from a separate conversation, after you upgraded the BIOS on this Intel NUC, the system would no longer recognize the B210, right?<br></div><div>Before the BIOS upgrade, the B210 would still be recognized, but only after a long 30- or 60-second delay, right?<br></div><div>--Neel Pandeya<br></div><div><div>On 31 October 2017 at 10:52, Humphries, James R. via USRP-users <a href="mailto:usrp-users@lists.ettus.com">usrp-users@lists.ettus.com</a> wrote:<br></div><div> Hey T,<br></div></div><div>I encountered a problem similar to this in the past with a Minnowboard Max. If you press the reset switch (S700 I believe), is the NUC able to see the B210 (instead of unplugging USB)? I had to do this if I had a B200 plugged into the Minnowboard while it booted.<br></div><div>The solution we came up with was to install a larger capacitor in parallel with C716/S700. I recall installing a 100uF capacitor. This allowed some extra time before the Cypress USB chip on the B200 powered up and it would work normally after a cold boot.<br></div><div>Obviously, if you want to try I assume it will void your warranty on the B210, so proceed at your own risk.<br></div><div>I think B200mini alleviated this ‘issue’ as it has a reset supervisor (TPS3801).<br></div><div>-Trip<br></div><div><div>From: USRP-users [<a href="mailto:usrp-users-bounces@lists.ettus.com">mailto:usrp-users-bounces@lists.ettus.com</a>] On Behalf Of "Tathagata (T)" via USRP-users<br></div><div> Sent: Tuesday, October 31, 2017 12:09 AM<br></div><div> To: <a href="mailto:usrp-users@lists.ettus.com">usrp-users@lists.ettus.com</a><br></div><div> Subject: [USRP-users] Problems with Ettus B210 and Intel Nuk<br></div></div><div>Hi,<br></div><div>We have a problem with Ettus B210 on an Intel Nuk. Briefly when we plug in the SDR into the USB port of the Intel Nuk, it is not recognized. The Nuk is running Ubuntu 16.04. The attached document details the debugging steps that we have taken and the errors that we are getting.  We never had this problem before and it suddenly started and we have no clue as to what is going wrong. Any help would be highly appreciated.<br></div><div>Thanks<br></div><div>T<br></div><div><hr><br></div><div><div>USRP-users mailing list<br></div><div> <a href="mailto:USRP-users@lists.ettus.com">USRP-users@lists.ettus.com</a><br></div><div> <a href="http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com">http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com</a><br></div></div><div><hr><br></div><div><div>USRP-users mailing list<br></div><div> <a href="mailto:USRP-users@lists.ettus.com">USRP-users@lists.ettus.com</a><br></div><div> <a href="http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com">http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com</a><br></div></div></blockquote></blockquote><div><br></div>