<html>
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
  </head>
  <body text="#000000" bgcolor="#FFFFFF">
    <div class="moz-cite-prefix">On 06/10/17 19:47, Piotr Krysik via
      USRP-users wrote:<br>
    </div>
    <blockquote type="cite"
      cite="mid:52ec7033-4b54-5486-96a4-cafad6302667@o2.pl">
      <pre wrap="">W dniu 06.10.2017 o 21:33, Piotr Krysik via USRP-users pisze:
</pre>
      <blockquote type="cite">
        <pre wrap="">Hello everyone,

I synchronized two USRPs B210 with use of Octoclock-G and the attached
gnuradio-companion flowgraph.

I've connected signal generator generating sinusoid to both devices (it
was on frequency 694.5MHz while USRPs were tuned to 694.3MHz, signal
power was about -40dBm). What I would expect is to see constant phase
offset between signals received by both USRPs (perhaps changing slightly
with temperature etc.). However what I see is constant changes of phase
that corresponds to frequency offset between two devices. Moreover this
frequency offset changes significantly from one execution of a flowgraph
to another (look at the image):

relative phase of two B210's

</pre>
      </blockquote>
      <pre wrap="">Missing image of phase offsets in the attachment.

Best Regards,
Piotr Krysik


</pre>
      <br>
      <fieldset class="mimeAttachmentHeader"></fieldset>
      <br>
      <pre wrap="">_______________________________________________
USRP-users mailing list
<a class="moz-txt-link-abbreviated" href="mailto:USRP-users@lists.ettus.com">USRP-users@lists.ettus.com</a>
<a class="moz-txt-link-freetext" href="http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com">http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com</a>
</pre>
    </blockquote>
    <p>Hi Piotr,</p>
    <p>            While I have a slightly different h/w configuration
      (2xN200, one GPSDO connected through MIMO cable (i.e. I use
      slightly different time/clock sources; and 2 SBXs) and while I
      have modified the Python code to use  timed_commands per the ettus
      sync page , I have not been able to get a consistent relative
      phase offset between the devices on successive GRC runs. I have
      been struggling for quite a while - hopefully, you will get a
      resolution quickly and I believe it might also fix my problem!</p>
    <p><br>
    </p>
    <p>                     Kind Regards,</p>
    <p><br>
    </p>
    <p>                                 John<br>
    </p>
  </body>
</html>