<HTML><HEAD></HEAD>
<BODY dir=ltr>
<DIV dir=ltr>
<DIV style="FONT-SIZE: 12pt; FONT-FAMILY: 'Calibri'; COLOR: #000000">
<DIV>I’m seeing a sample error rate of > 5e-7 (about 5 samples in 10 
million).  The test signal only toggles the lower 8 bits and the glitches 
show up when one of bits 11:8 is set.  </DIV>
<DIV> </DIV>
<DIV>What is the best way to send a data capture file?</DIV>
<DIV> </DIV>
<DIV>Mike</DIV>
<DIV 
style='FONT-SIZE: small; TEXT-DECORATION: none; FONT-FAMILY: "Calibri"; FONT-WEIGHT: normal; COLOR: #000000; FONT-STYLE: normal; DISPLAY: inline'>
<DIV style="FONT: 10pt tahoma">
<DIV> </DIV>
<DIV style="BACKGROUND: #f5f5f5">
<DIV style="font-color: black"><B>From:</B> <A title=usrp-users@lists.ettus.com 
href="mailto:usrp-users@lists.ettus.com">Michael West via USRP-users</A> </DIV>
<DIV><B>Sent:</B> Tuesday, March 08, 2016 6:30 PM</DIV>
<DIV><B>To:</B> <A title=marcus.mueller@ettus.com 
href="mailto:marcus.mueller@ettus.com">Marcus Müller</A> </DIV>
<DIV><B>Cc:</B> <A title=usrp-users@lists.ettus.com 
href="mailto:usrp-users@lists.ettus.com">USRP-users@lists.ettus.com</A> </DIV>
<DIV><B>Subject:</B> Re: [USRP-users] Data corruption with X3x0/UBX-160 receive 
at 200 Msps</DIV></DIV></DIV>
<DIV> </DIV></DIV>
<DIV 
style='FONT-SIZE: small; TEXT-DECORATION: none; FONT-FAMILY: "Calibri"; FONT-WEIGHT: normal; COLOR: #000000; FONT-STYLE: normal; DISPLAY: inline'>
<DIV dir=ltr>
<DIV>
<DIV>
<DIV>Hi Mike,<BR><BR></DIV>I spoke with some of my colleagues and was told that 
the X300/X310 ADC has a known issue on the 4 MSBs that results in a bit error 
rate of 1e-9.  I'm not sure whether or not it has anything to do with what 
you are experiencing, especially because your error rate is much higher, but I 
thought you should know.  If the majority of the bit errors you see are in 
the 4 MSBs, it may be a cause.<BR><BR></DIV>Regards,<BR></DIV>Michael <BR></DIV>
<DIV class=gmail_extra>
<DIV> </DIV>
<DIV class=gmail_quote>On Tue, Mar 8, 2016 at 12:57 PM, Marcus Müller <SPAN 
dir=ltr><<A href="mailto:marcus.mueller@ettus.com" 
target=_blank>marcus.mueller@ettus.com</A>></SPAN> wrote:<BR>
<BLOCKQUOTE class=gmail_quote 
style="PADDING-LEFT: 1ex; MARGIN: 0px 0px 0px 0.8ex; BORDER-LEFT: #ccc 1px solid">
  <DIV text="#000000" bgcolor="#FFFFFF">Hi Mike, <BR><BR>can you get us an 
  upload of the samples somewhere?<BR><BR>Short, rough calculation regarding 
  probability of the gaussian noise-induced bitflip:<BR><BR>At a thermal noise 
  floor of -174dBm/Hz, you'd end up with -174dBm/Hz*(80MHz)+NF[dB] noise power 
  per I and Q.<BR>According to our measurements[1, p 44], for 20 dB gain, 
  depending on frequency, NF is ca 10dB.<BR><BR>So, noise power becomes 
  (-174+79+10) dBm = -85dBm, which yields in total an SNR of 25 dB, i.e. the 
  noise variance is -25dB of the tone power:<BR><IMG 
  style="VERTICAL-ALIGN: middle" 
  alt="$\sigma^2       =10^{\frac{-25}{20}}\quad       \frac1{2\pi}\int\limits_{-\pi}^{\pi}\,A^2\sin^2(t)\,dt$" 
  src="cid:2B369AA3972E4EBBADECFFA17FF69773@OfficePC"><BR><IMG 
  style="VERTICAL-ALIGN: middle" 
  alt="$= 10^{-1.25}       \quad \frac12A^2 $" 
  src="cid:35A655B1BAB74E5A9FC2D71E44244C82@OfficePC"><BR><IMG 
  style="VERTICAL-ALIGN: middle" alt="$\approx       0.028\,A^2 $" 
  src="cid:3B754A3AEBF64257B3986A12ADE0D3DD@OfficePC">, i.e.<BR><IMG 
  style="VERTICAL-ALIGN: middle" alt="$\sigma \approx       0.168\, A$" 
  src="cid:E0FE2E89D1634181BE72D73720CFF779@OfficePC">. <BR>The Q-function at 
  <IMG style="VERTICAL-ALIGN: middle" alt="$\frac1{0.168}\approx 5.96$" 
  src="cid:3D545DCF07C941CC8225E378F5A7F91A@OfficePC"> is about <IMG 
  style="VERTICAL-ALIGN: middle" alt=$1.3407\cdot10^{−9}$ 
  src="cid:DAC3FCD593704BCE901312C1E571D492@OfficePC">, i.e. the probability 
  that noise is higher than signal amplitude is about 1 in 745 million, if we 
  only have thermal noise in the receiver, and not the transmitter. 745 Million 
  is not quite the probability you see, but it's in the same ball park, at 
  least! Notice that change in SNR can have quite a significant effect on the 
  "outlier" probability here.<BR><BR>Thus, looking at the samples would not only 
  be interesting from a debugging, but also from a SNR estimation point of view 
  :)<BR><BR>Cheers,<BR>Marcus<BR><BR>[1] <A 
  href="http://files.ettus.com/performance_data/ubx/UBX-without-UHD-corrections.pdf" 
  target=_blank>http://files.ettus.com/performance_data/ubx/UBX-without-UHD-corrections.pdf</A> 

  <DIV>
  <DIV class=h5><BR><BR>
  <DIV>On 03/08/2016 08:57 PM, Mike Williams via USRP-users wrote:<BR></DIV>
  <BLOCKQUOTE type="cite">
    <DIV style="FONT-SIZE: 12px; FONT-FAMILY: arial; COLOR: #000000">
    <DIV>Hi Michael,</DIV>
    <DIV>It's not clipping.  I'm testing with a -60 dBm tone from a signal 
    generator and a gain of 20.  The peak I/Q values out of the X3x0 are 
    < 256 except for when this data corruption occurs about every 1 to 10 
    million samples.   It looks like a bit flip in either the I or Q 
    samples.  </DIV>
    <DIV>For example, the I samples in one instance are:  0x0054, 0x00AB, 
    0x028C (bit 9 is a 1 but it should be 0) , 0x007B.</DIV>
    <DIV>Thanks,</DIV>
    <DIV>Mike</DIV>
    <DIV> </DIV><SPAN 
    style="FONT-SIZE: 12px; FONT-FAMILY: arial; COLOR: rgb(0,0,0)">On 03/07/16, 
    <SPAN>Michael West<A href="mailto:michael.west@ettus.com" 
    target=_blank>mailto:michael.west@ettus.com</A></SPAN> wrote:</SPAN> 
    <DIV> </DIV>
    <DIV style="FONT-SIZE: 12px; FONT-FAMILY: arial; COLOR: rgb(0,0,0)">
    <DIV dir=ltr>
    <DIV>
    <DIV>
    <DIV>Hi Mike,<BR><BR></DIV>The errors could also be due to clipping.  
    Your gain settings could be too 
    high.<BR><BR></DIV>Regards,<BR></DIV>Michael<BR></DIV>
    <DIV class=gmail_extra>
    <DIV> </DIV>
    <DIV class=gmail_quote>On Mon, Mar 7, 2016 at 7:42 AM, Mike Williams via 
    USRP-users <SPAN dir=ltr><<A href="mailto:usrp-users@lists.ettus.com" 
    target=_blank>usrp-users@lists.ettus.com</A>></SPAN> wrote:<BR>
    <BLOCKQUOTE class=gmail_quote 
    style="PADDING-LEFT: 1ex; MARGIN: 0px 0px 0px 0.8ex; BORDER-LEFT: rgb(204,204,204) 1px solid">
      <DIV style="FONT-SIZE: 12px; FONT-FAMILY: arial; COLOR: rgb(0,0,0)">
      <P>We are using an X300/UBX-160 programmed UHD-3.9.2 to record data at 200 
      Msps using the rx_samples_to_file example program.  We are seeing 
      data corruption that appears to be due to bit errors in some I or Q 
      samples.  The self cal of the adc capture and transfer delays works 
      fine so maybe this is a timing error elsewhere in the FPGA?  </P>
      <P>We've tried an X310 as well and have the same problem. </P><SPAN>
      <P>Mike</P></SPAN></DIV><BR>_______________________________________________<BR>USRP-users 
      mailing list<BR><A href="mailto:USRP-users@lists.ettus.com" 
      target=_blank>USRP-users@lists.ettus.com</A><BR><A 
      href="http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com" 
      rel=noreferrer 
      target=_blank>http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com</A><BR><BR></BLOCKQUOTE></DIV>
    <DIV> </DIV></DIV></DIV></DIV><BR>
    <FIELDSET></FIELDSET> <BR><PRE>_______________________________________________
USRP-users mailing list
<A href="mailto:USRP-users@lists.ettus.com" target=_blank>USRP-users@lists.ettus.com</A>
<A href="http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com" target=_blank>http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com</A>
</PRE></BLOCKQUOTE><BR></DIV></DIV></DIV></BLOCKQUOTE></DIV>
<DIV> </DIV></DIV>
<P>
<HR>
_______________________________________________<BR>USRP-users mailing 
list<BR>USRP-users@lists.ettus.com<BR>http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com<BR></DIV></DIV></DIV></BODY></HTML>