<div dir="ltr"><div><div><div>Hi Nathan,<br><br></div>Do you see the effect at lower sample rates?  Can you send me the data file and/or screen capture of the effect you are seeing?<br><br></div>Regards,<br></div>Michael<br></div><div class="gmail_extra"><br><div class="gmail_quote">On Tue, Oct 13, 2015 at 8:04 AM, Perelman, Nathan <span dir="ltr"><<a href="mailto:nperelman@lgsinnovations.com" target="_blank">nperelman@lgsinnovations.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div link="blue" vlink="purple" lang="EN-US"><div><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">Not that I can see. I pasted the full output from the command below. I tried with UHD 3.9.1 and still see the same results.<u></u><u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d"><u></u> <u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">$ /usr/lib64/uhd/examples/rx_samples_to_file --duration 2 --rate 25000000 --freq 1e9 --gain 38 --ref internal --setup 0<u></u><u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">linux; GNU C++ version 4.4.7 20120313 (Red Hat 4.4.7-16); Boost_105500; UHD_003.008.005-0-unknown<u></u><u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d"><u></u> <u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d"><u></u> <u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">Creating the usrp device with: ...<u></u><u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">-- Opening a USRP2/N-Series device...<u></u><u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">-- Current recv frame size: 1472 bytes<u></u><u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">-- Current send frame size: 1472 bytes<u></u><u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">Using Device: Single USRP:<u></u><u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">  Device: USRP2 / N-Series Device<u></u><u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">  Mboard 0: N210r4<u></u><u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">  RX Channel: 0<u></u><u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">    RX DSP: 0<u></u><u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">    RX Dboard: A<u></u><u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">    RX Subdev: UBX RX<u></u><u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">  TX Channel: 0<u></u><u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">    TX DSP: 0<u></u><u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">    TX Dboard: A<u></u><u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">    TX Subdev: UBX TX<u></u><u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d"><u></u> <u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">Setting RX Rate: 25.000000 Msps...<u></u><u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">Actual RX Rate: 25.000000 Msps...<u></u><u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d"><u></u> <u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">Setting RX Freq: 1000.000000 MHz...<u></u><u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">-- Successfully tuned to 1000.000000 MHz<u></u><u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">-- <u></u><u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">Actual RX Freq: 1000.000000 MHz...<u></u><u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d"><u></u> <u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">Setting RX Gain: 38.000000 dB...<u></u><u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">Actual RX Gain: 38.000000 dB...<u></u><u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d"><u></u> <u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">Waiting for "lo_locked": + locked.<u></u><u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d"><u></u> <u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">Press Ctrl + C to stop streaming...<u></u><u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d"><u></u> <u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">Done!<u></u><u></u></span></p><p class="MsoNormal"><a name="15061bb2075887f9__MailEndCompose"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d"><u></u> <u></u></span></a></p><p class="MsoNormal"><b><span style="font-size:10.0pt;font-family:"Tahoma","sans-serif"">From:</span></b><span style="font-size:10.0pt;font-family:"Tahoma","sans-serif""> Michael West [mailto:<a href="mailto:michael.west@ettus.com" target="_blank">michael.west@ettus.com</a>] <br><b>Sent:</b> Monday, October 12, 2015 7:07 PM</span></p><div><div class="h5"><br><b>To:</b> Perelman, Nathan<br><b>Cc:</b> Ben Hilburn via USRP-users<br><b>Subject:</b> Re: [USRP-users] Random long duration noise at the start of UBX captures<u></u><u></u></div></div><p></p><div><div class="h5"><p class="MsoNormal"><u></u> <u></u></p><div><div><div><div><p class="MsoNormal" style="margin-bottom:12.0pt">Hi Nathan,<u></u><u></u></p></div><p class="MsoNormal" style="margin-bottom:12.0pt">I am unable to reproduce what you are seeing.  I have an N210+GPSDO+UBX with a 3A power supply and I ran the rx_samples_to_file command you provided with RX2 terminated and all my data looks clean over multiple runs.  Are you getting any O's, errors, or warnings during your runs?<u></u><u></u></p></div><p class="MsoNormal">Regards,<u></u><u></u></p></div><p class="MsoNormal">Michael<u></u><u></u></p></div><div><p class="MsoNormal"><u></u> <u></u></p><div><p class="MsoNormal">On Mon, Oct 12, 2015 at 2:19 PM, Perelman, Nathan <<a href="mailto:nperelman@lgsinnovations.com" target="_blank">nperelman@lgsinnovations.com</a>> wrote:<u></u><u></u></p><div><div><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">Sorry, forgot to mention that, RX2 is terminated. I am also using a 3 amp power supply not the recommended 4 amp as I don’t have a 4 amp one.</span><u></u><u></u></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d"> </span><u></u><u></u></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">I tried setting the reference to internal without disconnecting the GPSDO and then again after disconnecting the GPSDO, and saw the same issue. In the second case, the noise lasted 1.6 seconds, although I don’t suspect the duration has anything to do with the test setup, it seems random.</span><u></u><u></u></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">-Nathan</span><u></u><u></u></p><p class="MsoNormal"><a name="15061bb2075887f9_1505decc063a49d3__MailEndCompose"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d"> </span></a><u></u><u></u></p><p class="MsoNormal"><b><span style="font-size:10.0pt;font-family:"Tahoma","sans-serif"">From:</span></b><span style="font-size:10.0pt;font-family:"Tahoma","sans-serif""> Michael West [mailto:<a href="mailto:michael.west@ettus.com" target="_blank">michael.west@ettus.com</a>] <br><b>Sent:</b> Monday, October 12, 2015 4:51 PM<br><b>To:</b> Perelman, Nathan<br><b>Cc:</b> Ben Hilburn via USRP-users<br><b>Subject:</b> Re: [USRP-users] Random long duration noise at the start of UBX captures</span><u></u><u></u></p><div><div><p class="MsoNormal"> <u></u><u></u></p><div><div><div><p class="MsoNormal" style="margin-bottom:12.0pt">To be clear, when I say disconnect the GPSDO, I mean disconnect the GPSDO power.  The data cables can be left in place.<u></u><u></u></p></div><p class="MsoNormal">Regards,<u></u><u></u></p></div><p class="MsoNormal">Michael<u></u><u></u></p></div><div><p class="MsoNormal"> <u></u><u></u></p><div><p class="MsoNormal">On Mon, Oct 12, 2015 at 1:43 PM, Michael West <<a href="mailto:michael.west@ettus.com" target="_blank">michael.west@ettus.com</a>> wrote:<u></u><u></u></p><div><div><div><div><p class="MsoNormal" style="margin-bottom:12.0pt">Hi Nathan,<u></u><u></u></p></div><p class="MsoNormal">The simple answer is no, that is not expected.  What do you have connected to the RX2 port?  Also, do you see the same effect if you disconnect the GPSDO?<u></u><u></u></p></div><div><p class="MsoNormal"> <u></u><u></u></p></div><p class="MsoNormal">Regards,<u></u><u></u></p></div><p class="MsoNormal">Michael<u></u><u></u></p></div><div><p class="MsoNormal"> <u></u><u></u></p><div><div><div><p class="MsoNormal">On Mon, Oct 12, 2015 at 1:26 PM, Perelman, Nathan via USRP-users <<a href="mailto:usrp-users@lists.ettus.com" target="_blank">usrp-users@lists.ettus.com</a>> wrote:<u></u><u></u></p></div></div><blockquote style="border:none;border-left:solid #cccccc 1.0pt;padding:0in 0in 0in 6.0pt;margin-left:4.8pt;margin-top:5.0pt;margin-right:0in;margin-bottom:5.0pt"><div><div><div><div><p class="MsoNormal">I’ve been having issues with UBX daughter-boards for a little while, and I finally traced them down to a reproducible issue. Running:<u></u><u></u></p><p class="MsoNormal">./rx_samples_to_file --duration 2 --rate 25000000 --freq 1e9 --gain 38 --ref gpsdo --setup 0<u></u><u></u></p><p class="MsoNormal"> <u></u><u></u></p><p class="MsoNormal">I frequently see large amounts of random noise (up to +/- 0.5 out of 1.0), for up to 0.5 seconds. I have tested with 2 different UBX daughter-boards and seen similar noise. Is this expected with the UBX? I do not see similar noise with the SBX.<u></u><u></u></p><p class="MsoNormal"> <u></u><u></u></p><p class="MsoNormal">I am using UHD 3.8.5 with an N210.<u></u><u></u></p><p class="MsoNormal"><span style="color:#888888">-Nathan</span><u></u><u></u></p></div></div><p class="MsoNormal"> <u></u><u></u></p></div></div><p class="MsoNormal" style="margin-bottom:12.0pt">_______________________________________________<br>USRP-users mailing list<br><a href="mailto:USRP-users@lists.ettus.com" target="_blank">USRP-users@lists.ettus.com</a><br><a href="http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com" target="_blank">http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com</a><u></u><u></u></p></blockquote></div><p class="MsoNormal"> <u></u><u></u></p></div></div><p class="MsoNormal"> <u></u><u></u></p></div></div></div></div></div></div><p class="MsoNormal"><u></u> <u></u></p></div></div></div></div></div></blockquote></div><br></div>