<div dir="ltr">Hi,<div><br></div><div>This issue is solved by removing a usrp->set_time_now(0.0) call in my program. It seems that for synchronized multiple channels, the safe way of resetting the time is via PPS. Don't explicitly reset it immediately via set_time_now()!</div><div><br></div><div>Cheers,</div><div>Hanwen</div></div><div class="gmail_extra"><br><div class="gmail_quote">2015-04-10 14:29 GMT+02:00 Sanjoy via USRP-users <span dir="ltr"><<a href="mailto:usrp-users@lists.ettus.com" target="_blank">usrp-users@lists.ettus.com</a>></span>:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Hi Hanwen Cao,<br>
I am using 2 x310s and for transmitting and receiving both I am using<br>
set_start_time(future_time); where future time is same for tx and rx; so<br>
theoritically I should get rx signal to be time synced with tx signal; but I<br>
am not getting that; there is always a shift.<br>
Can you tell me how did you fix your problem and one more thing can you tell<br>
me how to know the streaming time of tx and rx?<br>
<br>
thanks in advance.<br>
<br>
regads<br>
Sanjoy<br>
<div class="HOEnZb"><div class="h5"><br>
<br>
_______________________________________________<br>
USRP-users mailing list<br>
<a href="mailto:USRP-users@lists.ettus.com">USRP-users@lists.ettus.com</a><br>
<a href="http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com" target="_blank">http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com</a><br>
</div></div></blockquote></div><br></div>