<div dir="ltr">Hi Sreeraj,<div><br></div><div>Its seems like the OS is recognizing the device but the USRP RIO driver stack isn't. First, lets verify that all the necessary kernel modules are actually loaded. Can you please post the output of "/usr/local/bin/niusrprio_pcie status"? After you have run "sudo /usr/local/bin/niusrprio_pcie start" it should look like the following: </div><div><div><font face="courier new, monospace"><br></font></div><div><font face="courier new, monospace">$ /usr/local/bin/niusrprio_pcie status</font></div><div><font face="courier new, monospace">Modules Loaded: nikal nibds nistreamk NiRioSrv niusrpriok </font></div><div><font face="courier new, monospace">Server: niusrpriorpc</font></div></div><div><br></div><div>I should mention that the 3.17 kernel is newer than our officially supported kernel versions and we have not verified it. To figure out if this could be a kernel compatibility issue please run the following commands and post the output of the last command.</div><div><br></div><div><div><font face="courier new, monospace">$ sudo /usr/local/bin/niusrprio_pcie stop</font></div></div><div><font face="courier new, monospace">$ sudo rm /usr/local/natinst/nikal/src/client/*.o*</font></div><div><font face="courier new, monospace">$ sudo rm /usr/local/natinst/nikal/src/nikal/*.*o*</font></div><div><div><font face="courier new, monospace">$ sudo /usr/local/bin/updateNIDrivers --no-prompt</font></div></div><div><div><br></div><div>I should also mention that the USRP RIO devices are not hot-pluggable over PCIe. Even if the kernel has hot-plug support the USRP drivers don't and you can get into a situation where the OS detects the device and the driver stack does not. So (if you have not done this already) I would ask that you try your tests after rebooting your host (leaving the USRP powered on). </div></div><div><br></div><div><div>Thanks, </div></div><div class="gmail_extra"><br clear="all"><div><div dir="ltr"><div style="color:rgb(136,136,136)"><b>Ashish Chaudhari</b> | Senior Software Engineer | High Frequency Measurements - RF</div><div style="color:rgb(136,136,136)">Ettus Research, <i>A National Instruments Company</i></div><div style="color:rgb(136,136,136)"><a href="mailto:ashish.chaudhari@ettus.com" target="_blank">ashish.chaudhari@ettus.com</a></div></div></div>
<br><div class="gmail_quote">On Wed, Oct 29, 2014 at 10:41 AM, sreeraj r via USRP-users <span dir="ltr"><<a href="mailto:usrp-users@lists.ettus.com" target="_blank">usrp-users@lists.ettus.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><div>Hi,<br><br></div><div>I installed NI USRP RIO PCI driver from <a href="http://files.ettus.com/manual/page_ni_rio_kernel.html" target="_blank">http://files.ettus.com/manual/page_ni_rio_kernel.html</a>. But I am not able to probe my USRP using uhd_usrp_probe/uhd_find_devices. I recompiled uhd and is facing the same issue. Please find the logs given below.<br><br></div><div>OS: Archlinux 3.17.1-1-ARCH <br> <br></div><div>Some outuput logs<br></div><div><br>>> sudo /usr/local/bin/niusrprio_pcie start<br>Loading: NiRioSrv niusrpriok <br>Starting: niusrpriorp<br><br>>>lspci -k -d 1093:c4c4<br>04:00.0 Signal processing controller: National Instruments PXIe/PCIe Device<br>    Subsystem: National Instruments Device 7730<br>    Kernel modules: niusrpriok<br><br><br>>>sudo ls /dev/ni                                                            <br>nistreamk:0\nistreamk\<br><br><br>>>uhd_find_devices<br>linux; GNU C++ version 4.9.1 20140903 (prerelease); Boost_105600; UHD_003.008.000-0-unknown<br><br><br>UHD Error:<br>    Device discovery error: input stream error<br>No UHD Devices Found<br><br><br>>>uhd_usrp_probe <br>linux; GNU C++ version 4.9.1 20140903 (prerelease); Boost_105600; UHD_003.008.000-0-unknown<br><br>Error: input stream error<br><br><br></div><div>Thanks in advance<br></div><div>Sreeraj Rajendran<br></div><div><br></div></div>
<br>_______________________________________________<br>
USRP-users mailing list<br>
<a href="mailto:USRP-users@lists.ettus.com">USRP-users@lists.ettus.com</a><br>
<a href="http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com" target="_blank">http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com</a><br>
<br></blockquote></div><br></div></div>