<div dir="ltr"><div><div>Hi Louis,<br><br></div>Are you stopping GRC by closing the pop-up window or by the "Kill the flowgraph" button in the toolbar?  I ask because they operate differently.  Closing the pop-up window will exit the application cleanly and you should be able to run over and over again.  Using the "Kill the flowgraph" button in the toolbar is equivalent to using Ctrl-C and can leave the device in an undesirable state.  As you have observed, the device eventually returns to a usable state even if you kill the application but it could take a few seconds.<br></div><div><br></div>Regards,<br>Michael<br></div><div class="gmail_extra"><br><div class="gmail_quote">On Fri, Oct 24, 2014 at 9:16 AM, Louis Brown <span dir="ltr"><<a href="mailto:rfengr00@me.com" target="_blank">rfengr00@me.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div><div><br></div><div><pre style="font-family:'Helvetica Neue',Helvetica,sans-serif;font-size:15px;white-space:pre-wrap;word-wrap:break-word">Regarding my previous post, I have found if I wait until the X310 link light goes from red to off, about 10 seconds, I can re-establish communication.  If I try to run my GRC flow when the link light is red, it finds the incorrect MTU.  So I guess the rule is, always wait until the link light is off until you re-run your flow graph.</pre></div><div><span class="">Lou<br><br>On Oct 23, 2014, at 08:40 PM, Michael West <<a href="mailto:michael.west@ettus.com" target="_blank">michael.west@ettus.com</a>> wrote:<br><br></span><div><blockquote type="cite"><div><span class=""><div dir="ltr"><div><div><div>Hi Louis,<br><br></div>I noticed that for the benchmark_rate you are supplying the IP address and for GRC you are not.  Try supplying the same args ("addr=192.168.40.2") in the "Device Addr" field of the UHD USRP Source/Sink block you are using.<br><br></div>Regards,<br></div>Michael E. West<br></div></span><div class="gmail_extra"><br><div class="gmail_quote"><span class="">On Thu, Oct 23, 2014 at 6:31 PM, Louis Brown via USRP-users <span dir="ltr"><<a href="mailto:usrp-users@lists.ettus.com" target="_blank">usrp-users@lists.ettus.com</a>></span> wrote:<br></span><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div><div><span class="">Operating my X310 from a UHD source in GRC via 10GE yields a low MTU at startup:<br><br>-----------------------------------------------<br>linux; GNU C++ version 4.8.3 20140911 (Red Hat 4.8.3-7); Boost_105400; UHD_003.008.000-6-gbde8e9a3<br>-- X300 initialization sequence...<br>-- Determining maximum frame size... 2188 bytes.<br>UHD Warning:<br></span><pre style="font-family:'Helvetica Neue',Helvetica,sans-serif;font-size:15px;white-space:pre-wrap;word-wrap:break-word">Sent from iCloud</pre><span class="">    For this connection, UHD recommends a send frame size of at least 8000 for best<br>    performance, but your system's MTU will only allow 2188.<br>    This will negatively impact your maximum achievable sample rate.<br>-----------------------------------------------<br><br>My MTU for the 10GE interface is 9000 (verified with ifconfig), and when I run benchmark_rate it finds the correct MTU:<br><br>------------------------------------------------<br>./benchmark_rate --rx_rate 200E6 --args "addr=192.168.40.2"<br>linux; GNU C++ version 4.8.3 20140911 (Red Hat 4.8.3-7); Boost_105400; UHD_003.008.000-6-gbde8e9a3<br><br>Creating the usrp device with: addr=192.168.40.2...<br>-- X300 initialization sequence...<br>-- Determining maximum frame size... 8000 bytes.<br>-----------------------------------------------<br><br>So is this a GR issue or a UHD issue, or a combination?<br><br>Thanks,<br>Lou<br>KD4HSO<br><br></span></div></div><span class=""><br>_______________________________________________<br> USRP-users mailing list<br> <a href="mailto:USRP-users@lists.ettus.com" target="_blank">USRP-users@lists.ettus.com</a><br> <a href="http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com" target="_blank">http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com</a><br> <br></span></blockquote></div><br></div></div></blockquote></div></div></div></blockquote></div><br></div>