<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40"><head><meta http-equiv=Content-Type content="text/html; charset=utf-8"><meta name=Generator content="Microsoft Word 14 (filtered medium)"><!--[if !mso]><style>v\:* {behavior:url(#default#VML);}
o\:* {behavior:url(#default#VML);}
w\:* {behavior:url(#default#VML);}
.shape {behavior:url(#default#VML);}
</style><![endif]--><style><!--
/* Font Definitions */
@font-face
        {font-family:Helvetica;
        panose-1:2 11 6 4 2 2 2 2 2 4;}
@font-face
        {font-family:Helvetica;
        panose-1:2 11 6 4 2 2 2 2 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
@font-face
        {font-family:Tahoma;
        panose-1:2 11 6 4 3 5 4 4 2 4;}
@font-face
        {font-family:Consolas;
        panose-1:2 11 6 9 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0cm;
        margin-bottom:.0001pt;
        font-size:12.0pt;
        font-family:"Times New Roman","serif";
        color:black;}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
p
        {mso-style-priority:99;
        margin:0cm;
        margin-bottom:.0001pt;
        font-size:12.0pt;
        font-family:"Times New Roman","serif";
        color:black;}
pre
        {mso-style-priority:99;
        mso-style-link:"HTML Preformatted Char";
        margin:0cm;
        margin-bottom:.0001pt;
        font-size:10.0pt;
        font-family:"Courier New";
        color:black;}
p.MsoAcetate, li.MsoAcetate, div.MsoAcetate
        {mso-style-priority:99;
        mso-style-link:"Balloon Text Char";
        margin:0cm;
        margin-bottom:.0001pt;
        font-size:8.0pt;
        font-family:"Tahoma","sans-serif";
        color:black;}
span.HTMLPreformattedChar
        {mso-style-name:"HTML Preformatted Char";
        mso-style-priority:99;
        mso-style-link:"HTML Preformatted";
        font-family:"Consolas","serif";
        color:black;}
span.BalloonTextChar
        {mso-style-name:"Balloon Text Char";
        mso-style-priority:99;
        mso-style-link:"Balloon Text";
        font-family:"Tahoma","sans-serif";
        color:black;}
span.EmailStyle22
        {mso-style-type:personal-reply;
        font-family:"Calibri","sans-serif";
        color:#1F497D;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-size:10.0pt;}
@page WordSection1
        {size:612.0pt 792.0pt;
        margin:72.0pt 72.0pt 72.0pt 72.0pt;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]--></head><body bgcolor=white lang=EN-US link=blue vlink=purple><div class=WordSection1><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>OK, great. I went back to UHD 03.007.02, and the error seems gone, but only at my first tests, have to look deeper. Did however not yet try the different kernel.<o:p></o:p></span></p><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'><o:p> </o:p></span></p><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>Ralph.<o:p></o:p></span></p><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'><o:p> </o:p></span></p><p class=MsoNormal><a name="_MailEndCompose"><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'><o:p> </o:p></span></a></p><div style='border:none;border-left:solid blue 1.5pt;padding:0cm 0cm 0cm 4.0pt'><div><div style='border:none;border-top:solid #B5C4DF 1.0pt;padding:3.0pt 0cm 0cm 0cm'><p class=MsoNormal><b><span style='font-size:10.0pt;font-family:"Tahoma","sans-serif";color:windowtext'>From:</span></b><span style='font-size:10.0pt;font-family:"Tahoma","sans-serif";color:windowtext'> USRP-users [mailto:usrp-users-bounces@lists.ettus.com] <b>On Behalf Of </b>Marcus D. Leech via USRP-users<br><b>Sent:</b> Monday, 22 September, 2014 18:46<br><b>To:</b> Garver, Paul W<br><b>Cc:</b> usrp-users@lists.ettus.com<br><b>Subject:</b> Re: [USRP-users] B210 USB transfer error<o:p></o:p></span></p></div></div><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>On 09/22/2014 12:44 PM, Garver, Paul W wrote: <o:p></o:p></p><div><p class=MsoNormal>I've updated to UHD 3.7.2 with the 3.14.0 kernel.  I installed from source and downloaded the 3.7.2 images as well.  After writing ~130GB @ 25MSPS I received the same USB transfer status 5 error.  Also, you asked about sample rate  -- I tried a few different values and didn't notice any difference.  I haven't tried USB2.0 - I can do this for debugging purposes but it will not be a solution for me as I my application requires 25MSPS.  I really don't have a good idea if this is a hardware or software issue. <o:p></o:p></p><div><p class=MsoNormal><o:p> </o:p></p></div><div><p class=MsoNormal>Thanks, <o:p></o:p></p><div><p class=MsoNormal style='margin-bottom:12.0pt'>PWG<o:p></o:p></p></div></div></div><p class=MsoNormal>Thanks for the experiments, Paul.<br><br>Ettus R&D is currently working this issue.<br><br><br><br><o:p></o:p></p><div><div><div><div class=MsoNormal align=center style='text-align:center'><hr size=3 width="100%" align=center id=zwchr></div><div><p class=MsoNormal><b><span style='font-family:"Helvetica","sans-serif"'>From: </span></b><span style='font-family:"Helvetica","sans-serif"'>"Marcus D. Leech" <a href="mailto:mleech@ripnet.com"><mleech@ripnet.com></a><br><b>To: </b>"Paul W Garver" <a href="mailto:garverp@gatech.edu"><garverp@gatech.edu></a><br><b>Cc: </b>"Tony Arkles" <a href="mailto:t.arkles@gmail.com"><t.arkles@gmail.com></a>, <a href="mailto:usrp-users@lists.ettus.com">usrp-users@lists.ettus.com</a><br><b>Sent: </b>Friday, September 19, 2014 5:04:55 PM<br><b>Subject: </b>Re: [USRP-users] B210 USB transfer error<br><br><br><o:p></o:p></span></p><div><p class=MsoNormal>I tried the 3.14.0 kernel on Ubuntu 14.04 for the BRIX (UHD 3.7.1) and still continue to see the same error message as the OP. <o:p></o:p></p><div><p class=MsoNormal><o:p> </o:p></p></div><div><p class=MsoNormal>PWG<o:p></o:p></p></div></div><p class=MsoNormal><span style='font-family:"Helvetica","sans-serif"'>Could you also update to UHD 3.7.2 ?<br><br><br><br><o:p></o:p></span></p><div><div><p class=MsoNormal><o:p> </o:p></p><div class=MsoNormal align=center style='text-align:center'><hr size=3 width="100%" align=center id=zwchr></div><div><p class=MsoNormal style='margin-bottom:12.0pt'><b><span style='font-family:"Helvetica","sans-serif"'>From: </span></b><span style='font-family:"Helvetica","sans-serif"'>"Tony Arkles" <a href="mailto:t.arkles@gmail.com" target="_blank"><t.arkles@gmail.com></a><br><b>To: </b><a href="mailto:mleech@ripnet.com" target="_blank">mleech@ripnet.com</a><br><b>Cc: </b>"Paul W Garver" <a href="mailto:garverp@gatech.edu" target="_blank"><garverp@gatech.edu></a>, <a href="mailto:usrp-users@lists.ettus.com" target="_blank">usrp-users@lists.ettus.com</a><br><b>Sent: </b>Friday, September 19, 2014 2:43:30 PM<br><b>Subject: </b>Re: [USRP-users] B210 USB transfer error<o:p></o:p></span></p><div><p class=MsoNormal><span style='font-family:"Helvetica","sans-serif"'>I was having a similar problem on Ubuntu 14.04. Exact same error message. It wasn't really sample rate dependent, I was seeing it at 4MS/s, which worked fine over usb2. <o:p></o:p></span></p></div><div><p class=MsoNormal><span style='font-family:"Helvetica","sans-serif"'><o:p> </o:p></span></p></div><div><p class=MsoNormal><span style='font-family:"Helvetica","sans-serif"'>I ended up upgrading to a 3.14 kernel (using ubuntu .debs from a newer version) and it cleared up. There were notes in the change log for the kernel saying that there were fixes for the Intel USB3 chipset. <o:p></o:p></span></p></div><div><p class=MsoNormal><span style='font-family:"Helvetica","sans-serif"'><o:p> </o:p></span></p></div><div><p class=MsoNormal style='margin-bottom:12.0pt'><span style='font-family:"Helvetica","sans-serif"'><br>On Sep 19, 2014, at 11:45 AM, "Marcus D. Leech via USRP-users" <<a href="mailto:usrp-users@lists.ettus.com" target="_blank">usrp-users@lists.ettus.com</a>> wrote:<o:p></o:p></span></p></div><blockquote style='margin-top:5.0pt;margin-bottom:5.0pt'><div><p><span style='font-family:"Helvetica","sans-serif"'>I'd like to understand if this is sample-rate dependent.  Does it happen more frequently at higher samples rates, or is it just dependent on<o:p></o:p></span></p><p><span style='font-family:"Helvetica","sans-serif"'>  runtime?  What about when on USB-2.0?<o:p></o:p></span></p><p><span style='font-family:"Helvetica","sans-serif"'> <o:p></o:p></span></p><p><span style='font-family:"Helvetica","sans-serif"'> <o:p></o:p></span></p><p><span style='font-family:"Helvetica","sans-serif"'> <o:p></o:p></span></p><p><span style='font-family:"Helvetica","sans-serif"'>A goodly chunk of the R&D team at Ettus are on the road until Monday.<o:p></o:p></span></p><p><span style='font-family:"Helvetica","sans-serif"'> <o:p></o:p></span></p><div><p class=MsoNormal><span style='font-family:"Helvetica","sans-serif"'> <o:p></o:p></span></p></div><p><span style='font-family:"Helvetica","sans-serif"'>On 2014-09-19 13:29, Garver, Paul W via USRP-users wrote:<o:p></o:p></span></p><blockquote style='border:none;border-left:solid #1010FF 1.5pt;padding:0cm 0cm 0cm 4.0pt;margin-left:3.75pt;margin-top:5.0pt;margin-bottom:5.0pt'><pre>I can also report I have had this exact same issue with a B200, although I typically run rx_samples_to_file.  I've also tried external power to no avail.  I've also run the B200 on the haswell Intel NUC which also has the series 8/C210 USB 3.0 controller.  I haven't seen this issue yet on the NUC but I don't have a lot of runtime on it yet.<o:p></o:p></pre><pre><o:p> </o:p></pre><pre>Could you please post your results to the mailing list or can Ettus support contact me offline?  I'm very interested in the resolution to this issue.<o:p></o:p></pre><pre><o:p> </o:p></pre><pre>System Info:<o:p></o:p></pre><pre>Gigabyte Brix GB-BXi7-4770R<o:p></o:p></pre><pre>Ubuntu 14.04 64 bit<o:p></o:p></pre><pre>Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 05)<o:p></o:p></pre><pre><o:p> </o:p></pre><pre>PWG<o:p></o:p></pre><pre><o:p> </o:p></pre><pre>Date: Fri, 19 Sep 2014 02:08:04 +0000<o:p></o:p></pre><pre>From: "Nowlan, Sean" <<a href="mailto:Sean.Nowlan@gtri.gatech.edu" target="_blank">Sean.Nowlan@gtri.gatech.edu</a>><o:p></o:p></pre><pre>To: "<a href="mailto:USRP-users@lists.ettus.com" target="_blank">USRP-users@lists.ettus.com</a>" <<a href="mailto:USRP-users@lists.ettus.com" target="_blank">USRP-users@lists.ettus.com</a>><o:p></o:p></pre><pre>Subject: [USRP-users] B210 USB transfer error<o:p></o:p></pre><pre>Message-ID:<o:p></o:p></pre><pre>       <<a href="mailto:625d92335cfe4d91923faf730b3e2a97@apatlisdmail01.core.gtri.org" target="_blank">625d92335cfe4d91923faf730b3e2a97@apatlisdmail01.core.gtri.org</a>><o:p></o:p></pre><pre>Content-Type: text/plain; charset="us-ascii"<o:p></o:p></pre><pre><o:p> </o:p></pre><pre>Hi all -<o:p></o:p></pre><pre><o:p> </o:p></pre><pre><o:p> </o:p></pre><pre>I've seen this pop up now and again on this list. Basically while running an RX operation (osmocom_fft or uhd_fft) the B210 will sporadically disconnect from the USB 3.0 hub and then it will immediately reconnect. I can see this in dmesg and /var/log/syslog. It was suggested to me that this may be a power brown out issue since I have a TCXO GPSDO module mounted on board, but I observe the same error even while connected to wall power through the standard 6V, 3A power supply. Here is the console output I see.<o:p></o:p></pre><pre><o:p> </o:p></pre><pre><o:p> </o:p></pre><pre>UHD Error:<o:p></o:p></pre><pre>    The receive packet handler caught an exception.<o:p></o:p></pre><pre>    RuntimeError: usb rx6 transfer status: 5<o:p></o:p></pre><pre>UHD source block got error code 0xf<o:p></o:p></pre><pre>terminate called after throwing an instance of 'uhd::runtime_error'<o:p></o:p></pre><pre>  what():  RuntimeError: usb tx4 submit failed: LIBUSB_ERROR_NO_DEVICE<o:p></o:p></pre><pre>Aborted (core dumped)<o:p></o:p></pre><pre><o:p> </o:p></pre><pre>System info:<o:p></o:p></pre><pre>Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz<o:p></o:p></pre><pre>USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)<o:p></o:p></pre><pre>Ubuntu 14.04 LTS<o:p></o:p></pre><pre>linux; GNU C++ version 4.8.2; Boost_105400; UHD_003.007.002-94-ge56809a0?<o:p></o:p></pre><pre><o:p> </o:p></pre><pre>Sean<o:p></o:p></pre><pre><o:p> </o:p></pre><pre>_______________________________________________<o:p></o:p></pre><pre>USRP-users mailing list<o:p></o:p></pre><pre><a href="mailto:USRP-users@lists.ettus.com" target="_blank">USRP-users@lists.ettus.com</a><o:p></o:p></pre><pre><a href="http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com" target="_blank">http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com</a><o:p></o:p></pre></blockquote></div></blockquote><blockquote style='margin-top:5.0pt;margin-bottom:5.0pt'><div><p class=MsoNormal><span style='font-family:"Helvetica","sans-serif"'>_______________________________________________<br>USRP-users mailing list<br><a href="mailto:USRP-users@lists.ettus.com" target="_blank">USRP-users@lists.ettus.com</a><br><a href="http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com" target="_blank">http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com</a><o:p></o:p></span></p></div></blockquote></div><p class=MsoNormal><o:p> </o:p></p></div></div><p class=MsoNormal style='margin-bottom:12.0pt'><span style='font-family:"Helvetica","sans-serif"'><o:p> </o:p></span></p><pre>-- <o:p></o:p></pre><pre>Marcus Leech<o:p></o:p></pre><pre>Principal Investigator<o:p></o:p></pre><pre>Shirleys Bay Radio Astronomy Consortium<o:p></o:p></pre><pre><a href="http://www.sbrac.org" target="_blank">http://www.sbrac.org</a><o:p></o:p></pre></div><p class=MsoNormal><o:p> </o:p></p></div></div></div><p class=MsoNormal><br><br><br><o:p></o:p></p><pre>-- <o:p></o:p></pre><pre>Marcus Leech<o:p></o:p></pre><pre>Principal Investigator<o:p></o:p></pre><pre>Shirleys Bay Radio Astronomy Consortium<o:p></o:p></pre><pre><a href="http://www.sbrac.org">http://www.sbrac.org</a><o:p></o:p></pre></div></div></body></html>