<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
  <head>
    <meta content="text/html; charset=UTF-8" http-equiv="Content-Type">
  </head>
  <body bgcolor="#ffffff" text="#000000">
    <blockquote
cite="mid:1415841687.4347615.1411158998306.JavaMail.root@mail.gatech.edu"
      type="cite">
      <style type="text/css">p { margin: 0; }</style>
      <div style="font-family: times new roman,new york,times,serif;
        font-size: 12pt; color: rgb(0, 0, 0);">I tried the 3.14.0 kernel
        on Ubuntu 14.04 for the BRIX (UHD 3.7.1) and still continue to
        see the same error message as the OP.
        <div><br>
        </div>
        <div>PWG<br>
        </div>
      </div>
    </blockquote>
    Could you also update to UHD 3.7.2 ?<br>
    <br>
    <br>
    <blockquote
cite="mid:1415841687.4347615.1411158998306.JavaMail.root@mail.gatech.edu"
      type="cite">
      <div style="font-family: times new roman,new york,times,serif;
        font-size: 12pt; color: rgb(0, 0, 0);">
        <div><br>
          <hr id="zwchr">
          <div style="color: rgb(0, 0, 0); font-weight: normal;
            font-style: normal; text-decoration: none; font-family:
            Helvetica,Arial,sans-serif; font-size: 12pt;"><b>From: </b>"Tony
            Arkles" <a class="moz-txt-link-rfc2396E" href="mailto:t.arkles@gmail.com"><t.arkles@gmail.com></a><br>
            <b>To: </b><a class="moz-txt-link-abbreviated" href="mailto:mleech@ripnet.com">mleech@ripnet.com</a><br>
            <b>Cc: </b>"Paul W Garver" <a class="moz-txt-link-rfc2396E" href="mailto:garverp@gatech.edu"><garverp@gatech.edu></a>,
            <a class="moz-txt-link-abbreviated" href="mailto:usrp-users@lists.ettus.com">usrp-users@lists.ettus.com</a><br>
            <b>Sent: </b>Friday, September 19, 2014 2:43:30 PM<br>
            <b>Subject: </b>Re: [USRP-users] B210 USB transfer error<br>
            <br>
            <div>I was having a similar problem on Ubuntu 14.04. Exact
              same error message. It wasn't really sample rate
              dependent, I was seeing it at 4MS/s, which worked fine
              over usb2. </div>
            <div><br>
            </div>
            <div>I ended up upgrading to a 3.14 kernel (using ubuntu
              .debs from a newer version) and it cleared up. There were
              notes in the change log for the kernel saying that there
              were fixes for the Intel USB3 chipset. </div>
            <div><br>
            </div>
            <div><br>
              On Sep 19, 2014, at 11:45 AM, "Marcus D. Leech via
              USRP-users" <<a moz-do-not-send="true"
                href="mailto:usrp-users@lists.ettus.com" target="_blank">usrp-users@lists.ettus.com</a>>
              wrote:<br>
              <br>
            </div>
            <blockquote>
              <div>
                <p>I'd like to understand if this is sample-rate
                  dependent.  Does it happen more frequently at higher
                  samples rates, or is it just dependent on</p>
                <p>  runtime?  What about when on USB-2.0?</p>
                <p> </p>
                <p> </p>
                <p> </p>
                <p>A goodly chunk of the R&D team at Ettus are on
                  the road until Monday.</p>
                <p> </p>
                <div> </div>
                <p>On 2014-09-19 13:29, Garver, Paul W via USRP-users
                  wrote:</p>
                <blockquote style="padding-left: 5px; border-left: 2px
                  solid rgb(16, 16, 255); margin-left: 5px;">
                  <pre>I can also report I have had this exact same issue with a B200, although I typically run rx_samples_to_file.  I've also tried external power to no avail.  I've also run the B200 on the haswell Intel NUC which also has the series 8/C210 USB 3.0 controller.  I haven't seen this issue yet on the NUC but I don't have a lot of runtime on it yet.

Could you please post your results to the mailing list or can Ettus support contact me offline?  I'm very interested in the resolution to this issue.

System Info:
Gigabyte Brix GB-BXi7-4770R
Ubuntu 14.04 64 bit
Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 05)

PWG

Date: Fri, 19 Sep 2014 02:08:04 +0000
From: "Nowlan, Sean" <<a moz-do-not-send="true" href="mailto:Sean.Nowlan@gtri.gatech.edu" target="_blank">Sean.Nowlan@gtri.gatech.edu</a>>
To: "<a moz-do-not-send="true" href="mailto:USRP-users@lists.ettus.com" target="_blank">USRP-users@lists.ettus.com</a>" <<a moz-do-not-send="true" href="mailto:USRP-users@lists.ettus.com" target="_blank">USRP-users@lists.ettus.com</a>>
Subject: [USRP-users] B210 USB transfer error
Message-ID:
        <<a moz-do-not-send="true" href="mailto:625d92335cfe4d91923faf730b3e2a97@apatlisdmail01.core.gtri.org" target="_blank">625d92335cfe4d91923faf730b3e2a97@apatlisdmail01.core.gtri.org</a>>
Content-Type: text/plain; charset="us-ascii"

Hi all -


I've seen this pop up now and again on this list. Basically while running an RX operation (osmocom_fft or uhd_fft) the B210 will sporadically disconnect from the USB 3.0 hub and then it will immediately reconnect. I can see this in dmesg and /var/log/syslog. It was suggested to me that this may be a power brown out issue since I have a TCXO GPSDO module mounted on board, but I observe the same error even while connected to wall power through the standard 6V, 3A power supply. Here is the console output I see.


UHD Error:
    The receive packet handler caught an exception.
    RuntimeError: usb rx6 transfer status: 5
UHD source block got error code 0xf
terminate called after throwing an instance of 'uhd::runtime_error'
  what():  RuntimeError: usb tx4 submit failed: LIBUSB_ERROR_NO_DEVICE
Aborted (core dumped)

System info:
Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz
USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
Ubuntu 14.04 LTS
linux; GNU C++ version 4.8.2; Boost_105400; UHD_003.007.002-94-ge56809a0?

Sean

_______________________________________________
USRP-users mailing list
<a moz-do-not-send="true" href="mailto:USRP-users@lists.ettus.com" target="_blank">USRP-users@lists.ettus.com</a>
<a moz-do-not-send="true" href="http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com" target="_blank">http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com</a>
</pre>
                </blockquote>
              </div>
            </blockquote>
            <blockquote>
              <div><span>_______________________________________________</span><br>
                <span>USRP-users mailing list</span><br>
                <span><a moz-do-not-send="true"
                    href="mailto:USRP-users@lists.ettus.com"
                    target="_blank">USRP-users@lists.ettus.com</a></span><br>
                <span><a moz-do-not-send="true"
href="http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com"
                    target="_blank">http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com</a></span><br>
              </div>
            </blockquote>
          </div>
          <br>
        </div>
      </div>
    </blockquote>
    <br>
    <br>
    <pre class="moz-signature" cols="72">-- 
Marcus Leech
Principal Investigator
Shirleys Bay Radio Astronomy Consortium
<a class="moz-txt-link-freetext" href="http://www.sbrac.org">http://www.sbrac.org</a>
</pre>
  </body>
</html>