[USRP-users] tx_stream->get_max_num_samps() too low

Devin Kelly dwwkelly at gmail.com
Fri Jul 24 14:14:19 EDT 2020


Ahhhhhhhh I see.

Thank you very much, I'll bookmark this page.

Devin

On Fri, Jul 24, 2020 at 1:25 PM Marcus D. Leech via USRP-users <
usrp-users at lists.ettus.com> wrote:

> On 07/24/2020 01:04 PM, Devin Kelly via USRP-users wrote:
> > Well the documentation says RX stream only but it turned out to work
> > for TX streams too... so the documentation writer should be embarrassed!
> >
> > In my first message I verified that the HW actually sends 8100 byte
> > packets using ping, that is unless tcpdump is lying to me or
> > re-constructing IP packets in a way that's transparent to me.
> >
> > It seems that there's a frame size that's hard coded in
> > x300_eth_mgr.cpp and that's what was causing me trouble.  I got
> > get_max_num_samps up to 1996 and so far that's helped the actual
> > application I'm writing substantially.
> >
> > Devin
> >
> Ah, that's just establishing the *defaults* if you don't otherwise
> specify the send_frame_size, documented here:
>
> https://files.ettus.com/manual/page_transport.html
>
>
>
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20200724/b012ec43/attachment.html>


More information about the USRP-users mailing list