[USRP-users] X310 RFNoC Basic Transmit Signal Source Flowgraph Not Working

Nick Foster bistromath at gmail.com
Thu Jul 23 14:40:16 EDT 2020


RFNoC Radio runs at a constant 200Msps. Use DUC parameters: input rate
1Msps, output rate 200Msps. Use Radio parameter: Sampling Rate 200Msps.

I don't know why you're getting a gain error. What daughterboard are you
using?

In addition, you probably don't need the DMA FIFO for this FG.

Nick

On Thu, Jul 23, 2020 at 11:34 AM Hodges, Jeff via USRP-users <
usrp-users at lists.ettus.com> wrote:

> Has anyone been able to transmit with RFNoC Radio using the standard FPGA
> image from UHD.3.15.LTS?
>
>
> I have a clean installation and ran SigGen --> RFNoC: DmaFIFO --> RFNoC:
> DUC --> RFNoC: Radio
>
>
> Most basic flow graph ever. It does not work. I get a run-time error.
>
>
> Traceback (most recent call last):
>   File "/home/nvd/Documents/top_block.py", line 169, in <module>
>     main()
>   File "/home/nvd/Documents/top_block.py", line 157, in main
>     tb = top_block_cls()
>   File "/home/nvd/Documents/top_block.py", line 84, in __init__
>     self.uhd_rfnoc_streamer_radio_0.set_tx_gain(0, 0)
>   File "/usr/local/lib/python2.7/dist-packages/ettus/ettus_swig.py", line
> 3235, in set_tx_gain
>     return _ettus_swig.rfnoc_radio_sptr_set_tx_gain(self, gain, chan)
> RuntimeError: _Map_base::at
>
>
>
> Jeff
> ------------------------------
> *From:* USRP-users <usrp-users-bounces at lists.ettus.com> on behalf of
> Hodges, Jeff via USRP-users <usrp-users at lists.ettus.com>
> *Sent:* Wednesday, July 22, 2020 8:49:05 PM
> *To:* usrp-users at lists.ettus.com
> *Subject:* [USRP-users] X310 RFNoC Basic Transmit Signal Source Flowgraph
> Not Working
>
>
> I get a set_tx_gain error running a basic signal generator through RFNoC
> Radio:
>
> Signal Source -> DMA FIFO -> DUC -> Radio  (See image below)
>
>
> This is equivalent to:
> Signal Source --> USRP Sink    (Works fine)
>
>
> https://kb.ettus.com/File:dma_fifo_v02.png
>
>
> <https://kb.ettus.com/File:dma_fifo_v02.png>
>
> Traceback (most recent call last):
>   File "/home/nvd/Documents/top_block.py", line 169, in <module>
>     main()
>   File "/home/nvd/Documents/top_block.py", line 157, in main
>     tb = top_block_cls()
>   File "/home/nvd/Documents/top_block.py", line 84, in __init__
>     self.uhd_rfnoc_streamer_radio_0.set_tx_gain(0, 0)
>   File "/usr/local/lib/python2.7/dist-packages/ettus/ettus_swig.py", line
> 3235, in set_tx_gain
>     return _ettus_swig.rfnoc_radio_sptr_set_tx_gain(self, gain, chan)
> RuntimeError: _Map_base::at
>
>
> I am using 3.15.LTS.
>
>
> Any ideas?
>
>
> Thanks,
>
>
> Jeff
>
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20200723/91aab707/attachment.html>


More information about the USRP-users mailing list