[USRP-users] 1 Ts delay in USRP B210

Marcus D. Leech patchvonbraun at gmail.com
Tue Jul 21 12:19:13 EDT 2020


On 07/21/2020 12:13 PM, Prasad via USRP-users wrote:
>
> Soft reminder!
>
> Thanks,
>
> *From:*Prasad [mailto:kpras at trilcomm.com]
> *Sent:* Monday, July 20, 2020 7:58 PM
> *To:* 'usrp-users at lists.ettus.com'
> *Cc:* 'Rao Yenamandra'
> *Subject:* 1 Ts delay in USRP B210
>
> Dear Team.
>
> Hope you are doing well and safe.
>
> We are bringing up our NR-5G UE stack with USRP B210.
>
> If time permits, would you pls. reply to below concern with your 
> valuable information.
>
> During the synchronization procedure, we observe atleast 1  (Sampling 
> Time) drift in rx streamer in every  ~40ms time period.
>
> Are we missing any time_spec during /uhd_rx_streamer_recv/ api or in 
> /uhd_tx_streamer_send/ ?
>
> Master clock rate: 30.72e6
>
> Sampling rate: 30.72e6
>
> Carrier frequency: 3.8e9
>
> We use one B210 to transmit time domain samples back to back and 
> others to receive.
>
> Log snippet:
>
> Init PSS detected with lag: /4469/ (/PSS detection offset from the 
> slot boundary/ )
>
> sss has been detected
>
> Init PSS detected with lag: 4469
>
> sss has been detected
>
> Init PSS detected with lag: 4469
>
> sss has been detected
>
> Init PSS detected with lag: 4469
>
> sss has been detected
>
> Init PSS detected with lag: 4470 à1 Ts drift
>
> sss has been detected
>
> Init PSS detected with lag: 4470
>
> sss has been detected
>
> Init PSS detected with lag: 4470
>
> sss has been detected
>
> Init PSS detected with lag: 4471 à1 Ts drift.
>
> sss has been detected
>
> Init PSS detected with lag: 4472à1 Ts drift
>
> sss has been detected
>
> Init PSS detected with lag: 4472
>
> sss has been detected
>
> Init PSS detected with lag: 4472
>
> sss has been detected
>
> Init PSS detected with lag: 4484 à12 Ts drift
>
> sss has been detected
>
> Thanks! in advance.
>
> Regards,
>
> Prasad.
>
>
Are you just using the on-board reference clock, or using something like 
a GPS module?

The drift you show is roughly 0.8PPM (if I've done my math correctly), 
which is well within spec for this board without a better reference clock.



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20200721/7fd00427/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: image/png
Size: 550 bytes
Desc: not available
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20200721/7fd00427/attachment.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: image/png
Size: 676 bytes
Desc: not available
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20200721/7fd00427/attachment-0001.png>


More information about the USRP-users mailing list