[USRP-users] Persistent red LINK LED, streaming samples valued zero

Hai Nguyen hai.n.nguyen204 at gmail.com
Tue Jul 21 02:20:25 EDT 2020


Hi Marcus,

So with new UHD version, the LED behavior disappeared, but now the USRPs
cannot stream at all (0 samples received from streamer). I figured out that
this happens when I tried to create multiple threads for multiple
streamers, one streamer for one USRP. (I'm having 2 USRPs streaming 2 RX
channels simultaneously). I had to work around this by creating just one
extra thread for a USRP, while making the other USRP stream in the current
main thread. Another possible way would be using a single streamer...

I'm kinda confused (and curious!) why it is not possible to spawn multiple
threads for multiple streamers. This was not happening with B210s, but just
when I started to work with the X310s. I will be appreciate for further
info about this behavior.

-Hai

On Mon, Jul 20, 2020 at 12:32 PM Hai Nguyen <hai.n.nguyen204 at gmail.com>
wrote:

> Hello,
>
> - Are you getting any under-run indications?
> There is no under-run indication.
>
> - What sample rate are you using?
> I tried with different values ranging from 1 Msamps to 100 Msamps and the
> behaviors are the same.
>
> - Do you see this at the same sample rate with an example application like
> "rx_samples_to_file".   Are you using standard FPGA firmware or do
>    you have your own modules in the FPGA?
> No, I don't see this with rx_samples_to_file (with that example, orange
> LINK LED appeared). I am using a standard FPGA image.
>
> - What version of UHD are you using?
> I'm using UHD 3.9.7 (LTS)
>
> Best,
> Hai
>
>
>
>
> On Mon, Jul 20, 2020 at 1:52 AM Hai Nguyen <hai.n.nguyen204 at gmail.com>
> wrote:
>
>> Hello,
>>
>> I'm having an error where received samples from RX chains of a X310
>> (after calling recv from the streamer) have values of 0 (both I and Q), and
>> those values don't change over time. One abnormal thing is that the LINK
>> LED in the front panel is persistently red during streaming. I noticed that
>> when streaming samples is ok this LED is normally persistently orange
>> instead.
>>
>> Do you have any ideas what would be the cause of this?
>>
>> Thank you and best regards,
>> Hai
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20200721/9766b672/attachment.html>


More information about the USRP-users mailing list