[USRP-users] using 'replay' block with 'duc'

Rob Kossler rkossler at nd.edu
Mon Jul 6 17:36:30 EDT 2020


Hi Wade,
I am still not able to get the attached example to work.  As indicated in
my original email, I modified replay_samples_from_file to add a DUC block
in between the Replay and Radio blocks and also added a loop to provide
repeated start/stop of streaming.  It works fine the first time but then
produces lots of "L" the subsequent times.  I removed the call to
play_halt() as you suggested.  I noticed in UHD that there were some replay
block fixes but I'm not sure if all your intended fixes have made it or
not.  I am using the latest UHD (hash 5a9f9ed9).

Here is the exact command line I used (I also attached the data file that
is being replayed - 250 samples long), but the file is not important.
$ replay_samples_from_file --file
Documents/waveforms/mtone_100_0p8_0_le.bin --freq 2450e6
Rob

On Fri, May 1, 2020 at 11:37 AM Wade Fife <wade.fife at ettus.com> wrote:

> Hi Rob,
>
> I wanted to give you a quick update. I was able to reproduce the issue you
> found. There were two problems.
>
> First, the example you shared calls play_halt() for the replay block each
> time replay is stopped. This basically stops it as soon as possible, even
> if that means it can't send a final packet with EOB. The DUC needs the EOB
> to start/stop cleanly or else the timestamps the DUC generates aren't
> correct when the next set of data comes through.
>
> The second problem I found is part of some known issues that are already
> fixed in UHD 4.0. I'm going to add these fixes to 3.15 since I know there
> was a lot of interest in the Replay block in 3.15. So once these fixes
> appear, you should be able to remove the call the play_halt() and the
> example will work as expected.
>
> Thanks,
>
> Wade
>
> On Thu, Apr 23, 2020 at 9:34 PM Rob Kossler <rkossler at nd.edu> wrote:
>
>>
>> Great. I forgot to mention that I was using an n310.
>>
>> On Thu, Apr 23, 2020 at 10:18 PM Wade Fife <wade.fife at ettus.com> wrote:
>>
>>> Hi Rob,
>>>
>>> Thanks for the example! I'd take a look to see if I can reproduce the
>>> issue and figure out what's going on. I've been working recently on the
>>> Replay block, so I'm very interested to understand what's going on.
>>>
>>> Thanks,
>>>
>>> Wade
>>>
>>> On Thu, Apr 23, 2020 at 1:36 PM Rob Kossler via USRP-users <
>>> usrp-users at lists.ettus.com> wrote:
>>>
>>>> Hi,
>>>> I am having an issue with UHD 3.15.LTS using the replay block.  When I
>>>> play out my previously stored samples the first time, everything works
>>>> fine.  But after stopping the first time, if I try to start playing out
>>>> again, I get a whole bunch of 'Lates' and no RF output.
>>>>
>>>> In order to duplicate the problem with an Ettus example, I modified
>>>> 'replay_samples_from_file' to add a loop and command prompt so that the
>>>> user could hit <enter> to start playing out while still using <ctrl-c> to
>>>> stop.  Unfortunately for me, this worked fine and did not show the problem.
>>>>
>>>> Next, I further modified the example to place a DUC block in between
>>>> the Replay block and the Radio.  Now it duplicates the issue perfectly
>>>> (modified example attached).
>>>>
>>>> So, perhaps I need to clear the DUC in some way when stopping the
>>>> streaming??  But if so, I'm not really sure how to do so.
>>>>
>>>> Thanks.
>>>> Rob
>>>>
>>> _______________________________________________
>>>> USRP-users mailing list
>>>> USRP-users at lists.ettus.com
>>>> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>>>>
>>>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20200706/ead0a393/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: mtone_100_0p8_0_le.bin
Type: application/octet-stream
Size: 1000 bytes
Desc: not available
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20200706/ead0a393/attachment.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: replay_samples_from_file.cpp
Type: text/x-c++src
Size: 18548 bytes
Desc: not available
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20200706/ead0a393/attachment.cpp>


More information about the USRP-users mailing list