[USRP-users] Problems with "uhd::set_thread_priority_safe"

Marcus D. Leech patchvonbraun at gmail.com
Wed Jul 1 15:37:23 EDT 2020


On 07/01/2020 02:40 PM, Nando Pellegrini wrote:
> Marcus,
> sorry, i have to hold my horses.
> Let's forget all we said (or better i said) before , i have just done 
> some more deep testing and actually UHD and its priority function have 
> nothing to do with my problem.
> I had a suspect so made an application to write on a file the CPU 
> speed and the run the B200 streaming loop and then a presto folding cycle.
> What is happening is the cpu speed which drops suddenly to the minimum 
> (900Hz)  and sometimes starts again to increase while sometime does 
> not move anymore.
> I know that the cpu throttle is handled by Ubuntu and what came to my 
> mind is that my cpu is not covered bu the current version of ubuntu18 
> , if i start the B200 loop streaming at 40Mhz all goes ok with a CPU 
> load (shown on the system monitor) with no  threads over 10% so prone 
> to believe that there is still a big margin before saturating the cpu.
> What sounds strange to me, when everything works at 40Mhz , is looking 
> at  system monitor a see no more then 5 threads running, one as i said 
> at 10% while the others are very low but on the other side all the 8 
> cpus are running at frequencies higher than 3Ghz in average monitored 
> by running watch grep \"cpu MHz\" /proc/cpuinfo.
> Together with the frequency i have been monitoring also the cpu 
> temperatures never going over 50° with fans at minimum speed.
> What seems to me is that there is a sort of trigger above which the 
> activity is stopped and never recovered but far from the physical limits.
> The cpu on the laptop is an Intel 10th generation i7-10875H
> On W10 installed on the same PC with a dual boot and loading the cpu 
> with a benchmark application and 16 threads running i can, see without 
> time limitation, a continuous load close to 100% without overheating.
> At this point i will be happy if the problem is the cpu not covered by 
> ubuntu so i'll stay at 40Mhz waiting for the right version.
> Apologies for what i said but was really not easy to think of such a 
> problem. I tried to read the system log file but have no idea of what 
> and where to look i could only see that the 8 cpus were correctly 
> detected during the boot.
> One point of mine was still true, during my very first test of B200 on 
> the new PC and before the latest Ubuntu updates i tried to run it to 
> check if was affordable and since was able to run at 56Mhz and low cpu 
> load for minutes (i cannot remember how many) i was very confident of 
> the result, not it crashes in seconds.
> At this point any hints would be greatly appreciated.
> nando
>
What version of Ubuntu were you running on the new PC before upgrading 
to 18.04?   The libusb and kernel USB drivers have probably changed
   since pre-18.04.  Not sure.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20200701/29ebc55a/attachment.html>


More information about the USRP-users mailing list