[USRP-users] LFRX with X310 I/Q Sampling

David Reuss david.a.reuss at gmail.com
Fri Jan 31 13:42:08 EST 2020


Hi everyone,
I have analog I and Q baseband signals of two CW tones I want to sample
with the LFRX daughterboard into an X310 using a simple grc flowgraph that
has a USRP source block into a frequency and time sink. I have both RF
ports hooked up to the LFRX and have the subdev set to A:AB for the USRP
source block.

When I only connect my baseband I channel to antenna port A and configure
the USRP source block to look at antenna A I can see the sinusoids on the I
channel as I would expect (see One_Input_Result.jpeg).

I then change the USRP source block to look at antenna AB and connect both
my baseband I and Q channels. My understanding is that this configuration
should use antenna port A as the I and antenna port B as the Q. I expected
to see the sinusoids on both the I and Q channels, but I instead see higher
amplitude spikes on both channels (Two_Input_Result.jpeg).

Is there something wrong with my configuration or what I am trying to do? I
am using UHD version 3.15.

Thank you,
David
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20200131/4c26eb33/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: One_Input_Result.jpeg
Type: image/jpeg
Size: 87333 bytes
Desc: not available
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20200131/4c26eb33/attachment.jpeg>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Two_Input_Result.jpeg
Type: image/jpeg
Size: 97262 bytes
Desc: not available
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20200131/4c26eb33/attachment-0001.jpeg>


More information about the USRP-users mailing list