[USRP-users] USRP N310 Performance Issues

Austin Adam austinadam42 at gmail.com
Tue Jan 28 17:51:31 EST 2020


Hi everyone,
I have a very basic GNU script with just a USRP block and a time sink that
when I run, there are tons of streaming errors with the tx and rx. In GNU,
the console is being filled with 'D's and the console for the N210 is
getting filled with 'U's and 'S's.

My setup is just a USRP N210 connected to the RX LO ports of the N310. I am
sending the following command to the N210:

*"sudo '/home/austin/workarea-uhd/uhd/host/build/examples/tx_waveforms'
--args "addr=192.168.10.15,type=usrp2" --freq 3.90000e9 --ant "TX/RX"
--subdev "A:0" --channels 0 --rate 1.25e6 --gain 29.5"*

The USRPs are connected to a router via cat 5e cables, and then my laptop
is connected to the router via wifi. Something I noticed is that when I
connect to the router via ethernet to my laptop, I don't get any of the
performance issues. It seems to only happen over the wifi.

When I run ifconfig on my laptop, my MTU is set to 1500, and on the USRP
N310 the MTU on the sfp0 port that we are using is 8000. I wasn't able to
change the MTU on the N310 because it said the device was in use, but those
values seem to work fine over ethernet so I didn't look too much into it.

The sample rate on my GNU script is set to 5M for now, and lowering it does
seem to reduce the amount of 'D's that I get, but also negatively affects
our data.

Lastly, here is some output from the N210 that shows the error:

*austin at Austin-Blade:~$ sudo '/home/*austin































*/workarea-uhd/uhd/host/build/examples/tx_waveforms' --args
"addr=192.168.10.15,type=usrp2" --freq 3.90000e9 --ant "TX/RX" --subdev
"A:0" --channels 0 --rate 1.25e6 --gain 29.5Creating the usrp device with:
addr=192.168.10.15,type=usrp2...[INFO] [UHD] linux; GNU C++ version 8.3.0;
Boost_106700; UHD_3.14.0.HEAD-0-g6875d061[INFO] [USRP2] Opening a
USRP2/N-Series device...[INFO] [USRP2] Current recv frame size: 1472
bytes[INFO] [USRP2] Current send frame size: 1472 bytesUsing Device: Single
USRP:  Device: USRP2 / N-Series Device  Mboard 0: N210r4  RX Channel: 0
RX DSP: 0    RX Dboard: A    RX Subdev: SBXv3 RX  TX Channel: 0    TX DSP:
0    TX Dboard: A    TX Subdev: SBXv3 TXSetting TX Rate: 1.250000
Msps...Actual TX Rate: 1.250000 Msps...Setting TX Freq: 3900.000000
MHz...Setting TX LO Offset: 0.000000 MHz...Actual TX Freq: 3900.000000
MHz...Setting TX Gain: 29.500000 dB...Actual TX Gain: 29.500000
dB...Setting device timestamp to 0...Checking TX: LO: locked ...Press Ctrl
+ C to stop streaming...*UUUSUUUU[ERROR] [USRP2] Control packet attempt 0,
sequence number 470:
RuntimeError: no control response, possible packet loss
UUUSUUUUSUUUUUU^C
*      Done!*

I appreciate any help that anyone has to offer!

Best,
Austin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20200128/7adf162e/attachment.html>


More information about the USRP-users mailing list