[USRP-users] dpdk with x300

Minutolo, Lorenzo minutolo at caltech.edu
Fri Jan 10 18:14:23 EST 2020


As a side note: I tried running the program as "sudo su" with the same exact result.

Lorenzo
________________________________
From: USRP-users <usrp-users-bounces at lists.ettus.com> on behalf of Minutolo, Lorenzo via USRP-users <usrp-users at lists.ettus.com>
Sent: Friday, January 10, 2020 3:08 PM
To: Sam Reiter <sam.reiter at ettus.com>
Cc: usrp-users at lists.ettus.com <usrp-users at lists.ettus.com>
Subject: Re: [USRP-users] dpdk with x300

Changed the driver string but the problem persists. Is it problematic that the NIC is on the last PCIe slot of the motherboard (same NUMA socket)?

I attached the command I'm giving and the output.

Thanks,
Lorenzo
________________________________
From: Sam Reiter <sam.reiter at ettus.com>
Sent: Monday, January 6, 2020 2:05 PM
To: Minutolo, Lorenzo <minutolo at caltech.edu>
Cc: usrp-users at lists.ettus.com <usrp-users at lists.ettus.com>
Subject: Re: [USRP-users] dpdk with x300

That should be fine.

Looking over those screenshots again, you'll need to change your dpdk driver path in uhd.conf. Here's what the uncommented parts of uhd.conf should look like for 17.11:

[use_dpdk=1]
dpdk-mtu=9000
dpdk-driver=/usr/lib/x86_64-linux-gnu/dpdk-17.11-drivers/
dpdk-corelist=1,2,3
dpdk-num-mbufs=4095
dpdk-mbufs-cache-size=315
[dpdk-mac=aa:bb:cc:dd:ee:f1]
dpdk-io-cpu = 2
dpdk-ipv4 = 192.168.10.1/24<http://192.168.10.1/24>
[dpdk-mac=aa:bb:cc:dd:ee:f2]
dpdk-io-cpu = 3
dpdk-ipv4 = 192.168.20.1/24<http://192.168.20.1/24>

Note that the IP and MAC need to be changed for your machine.

Sam Reiter
Ettus Research

On Mon, Jan 6, 2020 at 3:29 PM Minutolo, Lorenzo <minutolo at caltech.edu<mailto:minutolo at caltech.edu>> wrote:
I' using:

dpdk-procinfo -v
EAL: Detected 16 lcore(s)
EAL: RTE Version: 'DPDK 17.11.9'

Thanks,
Lorenzo
________________________________
From: Sam Reiter <sam.reiter at ettus.com<mailto:sam.reiter at ettus.com>>
Sent: Monday, January 6, 2020 8:27 AM
To: Minutolo, Lorenzo <minutolo at caltech.edu<mailto:minutolo at caltech.edu>>
Cc: usrp-users at lists.ettus.com<mailto:usrp-users at lists.ettus.com> <usrp-users at lists.ettus.com<mailto:usrp-users at lists.ettus.com>>
Subject: Re: [USRP-users] dpdk with x300

Lorenzo,

What version of DPDK are you using?

Sam Reiter
Ettus Research

On Fri, Jan 3, 2020 at 8:20 PM Minutolo, Lorenzo via USRP-users <usrp-users at lists.ettus.com<mailto:usrp-users at lists.ettus.com>> wrote:
Hi All,
I'm using an x300 connected via a Intel X710 to a machine running Ubuntu 18.04. I'm using the recently released UHD 3.15 LTS.
I'm trying to follow the guide to connect via dpdk. Everything in the guide on the Ettus website works however when launching uhd_usrp_probe (as sudo uhd_usrp_probe --args "address = 192.168.30.2, use_dpdk=1") I get the output reported in the output.png attachment. My actual dpdk-devbind.py --status is reported in status.png attachment as well as the uhd.conf I'm using.

What am I doing wrong?

In the configuration file I tried altering the cores to see if that was an issue but nothing changed.

Thanks,
Lorenzo
_______________________________________________
USRP-users mailing list
USRP-users at lists.ettus.com<mailto:USRP-users at lists.ettus.com>
http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20200110/f4e207f6/attachment.html>


More information about the USRP-users mailing list