[USRP-users] GPIO Example Failure on N310

Sam Reiter sam.reiter at ettus.com
Thu Jan 9 15:25:54 EST 2020


Jeff,

I'd say it's worth trying. Do you currently have any cabling or external
connections to your GPIO port?

Sam Reiter
Ettus Research


On Mon, Jan 6, 2020 at 6:27 PM Jeff S <e070832 at hotmail.com> wrote:

> Sam,
>
> Everything was downloaded from the images_downloader. I have not modified
> the FPGA image or any of the UHD code. I have just been trying to learn how
> to use the N310, and compiling examples on it.
>
> I will be back in the lab tomorrow. Should I go ahead and try installing
> 3.15.0.0?
>
> Jeff
>
>
>
> -------- Original message --------
> From: Sam Reiter <sam.reiter at ettus.com>
> Date: 1/6/20 4:46 PM (GMT-06:00)
> To: Jeff S <e070832 at hotmail.com>
> Cc: usrp-users at lists.ettus.com
> Subject: Re: [USRP-users] GPIO Example Failure on N310
>
> Jeff,
>
> Follow-up on this. I ran the GPIO example on my N310 with 3.14.1.1
> (g0347a6d8) and all GPIO tests passed. Are your FPGA image and UHD release
> modified?
>
> Sam Reiter
> Ettus Research
>
> On Fri, Jan 3, 2020 at 2:01 PM Sam Reiter <sam.reiter at ettus.com> wrote:
>
>> Hey Jeff,
>>
>> Could you give this a shot on 3.15.0.0 and let me know the results? Based
>> on that output, the issue looks confined to ATR but it's not something I've
>> seen reported up to this point.
>>
>> If 3.15.0.0 shows this issue as well, I'll reproduce it on my end and get
>> a bug filed.
>>
>> Sam Reiter
>> Ettus Research
>>
>> On Fri, Dec 20, 2019 at 10:19 AM Jeff S via USRP-users <
>> usrp-users at lists.ettus.com> wrote:
>>
>>> I built the UHD example, gpio.cpp (no modifications), and ran it on my
>>> N310 to start experimenting with the GPIO.  It returned with two failures:
>>>
>>> Testing ATR TX output...fail:
>>> Bit 2 should be set, but is not
>>>        Bit  10  9  8  7  6  5  4  3  2  1  0
>>>       CTRL:  0  0  0  0  0  0  0  1  1  1  1
>>>        DDR:  0  0  0  0  0  0  1  1  1  1  1
>>>     ATR_0X:  0  0  0  0  0  0  0  0  0  0  1
>>>     ATR_RX:  0  0  0  0  0  0  0  0  0  1  0
>>>     ATR_TX:  0  0  0  0  0  0  0  0  1  0  0
>>>     ATR_XX:  0  0  0  0  0  0  0  1  0  0  0
>>>        OUT:  0  0  0  0  0  0  0  0  0  0  0
>>>   READBACK:  1  1  1  1  1  1  0  0  0  0  1
>>>
>>> Testing ATR full duplex output...fail:
>>> Bit 3 should be set, but is not
>>>        Bit  10  9  8  7  6  5  4  3  2  1  0
>>>       CTRL:  0  0  0  0  0  0  0  1  1  1  1
>>>        DDR:  0  0  0  0  0  0  1  1  1  1  1
>>>     ATR_0X:  0  0  0  0  0  0  0  0  0  0  1
>>>     ATR_RX:  0  0  0  0  0  0  0  0  0  1  0
>>>     ATR_TX:  0  0  0  0  0  0  0  0  1  0  0
>>>     ATR_XX:  0  0  0  0  0  0  0  1  0  0  0
>>>        OUT:  0  0  0  0  0  0  0  0  0  0  0
>>>   READBACK:  1  1  1  1  1  1  0  0  0  0  1
>>>
>>> 2 tests failed
>>>
>>> Done!
>>>
>>>
>>> Is this something that I should be concerned about?
>>>
>>> If I compile and run the same example with my X310, everything passes.
>>>
>>> Here's the uhd_config_info --print-all from my N310:
>>>
>>> UHD 3.14.1.1-0-g0347a6d8
>>> Build date: Thu, 26 Sep 2019 01:26:32
>>> C compiler: GNU 7.3.0
>>> C++ compiler: GNU 7.3.0
>>> C flags: -DHAVE_CONFIG_H -DUHD_LOG_MIN_LEVEL=1 -DUHD_LOG_CONSOLE_LEVEL=2
>>> -DUHD_LOG_FILE_LEVEL=2 -DUHD_LOG_CONSOLE_COLOR -DHAVE_LIBER
>>> IO -march=armv7-a -marm -mfpu=neon -mfloat-abi=hard -mcpu=cortex-a9
>>>  --sysroot=/home/oe-builder/build/tmp-glibc/work/cortexa9hf-neon
>>> -oe-linux-gnueabi/uhd/3.14.1.1-r1/recipe-sysroot  -O2 -pipe -g
>>> -feliminate-unused-debug-types -fdebug-prefix-map=/home/oe-builder/bu
>>> ild/tmp-glibc/work/cortexa9hf-neon-oe-linux-gnueabi/uhd/3.14.1.1-r1=/usr/src/debug/uhd/3.14.1.1-r1
>>> -fdebug-prefix-map=/home/oe-build
>>> er/build/tmp-glibc/work/cortexa9hf-neon-oe-linux-gnueabi/uhd/3.14.1.1-r1/recipe-sysroot=
>>> -fdebug-prefix-map=/home/oe-builder/build/t
>>> mp-glibc/work/cortexa9hf-neon-oe-linux-gnueabi/uhd/3.14.1.1-r1/recipe-sysroot-native=
>>>   -march=armv7-a -marm -mfpu=neon -mfloat-abi=
>>> hard -mcpu=cortex-a9
>>>  --sysroot=/home/oe-builder/build/tmp-glibc/work/cortexa9hf-neon-oe-linux-gnueabi/uhd/3.14.1.1-r1/recipe-sysroo
>>> t
>>> C++ flags: -DHAVE_CONFIG_H -DUHD_LOG_MIN_LEVEL=1
>>> -DUHD_LOG_CONSOLE_LEVEL=2 -DUHD_LOG_FILE_LEVEL=2 -DUHD_LOG_CONSOLE_COLOR
>>> -DHAVE_LIB
>>> ERIO -march=armv7-a -marm -mfpu=neon -mfloat-abi=hard -mcpu=cortex-a9
>>>  --sysroot=/home/oe-builder/build/tmp-glibc/work/cortexa9hf-ne
>>> on-oe-linux-gnueabi/uhd/3.14.1.1-r1/recipe-sysroot  -O2 -pipe -g
>>> -feliminate-unused-debug-types -fdebug-prefix-map=/home/oe-builder/
>>> build/tmp-glibc/work/cortexa9hf-neon-oe-linux-gnueabi/uhd/3.14.1.1-r1=/usr/src/debug/uhd/3.14.1.1-r1
>>> -fdebug-prefix-map=/home/oe-bui
>>> lder/build/tmp-glibc/work/cortexa9hf-neon-oe-linux-gnueabi/uhd/3.14.1.1-r1/recipe-sysroot=
>>> -fdebug-prefix-map=/home/oe-builder/build
>>> /tmp-glibc/work/cortexa9hf-neon-oe-linux-gnueabi/uhd/3.14.1.1-r1/recipe-sysroot-native=
>>>  -fvisibility-inlines-hidden  -march=armv7-a
>>>  -marm -mfpu=neon -mfloat-abi=hard -mcpu=cortex-a9
>>>  --sysroot=/home/oe-builder/build/tmp-glibc/work/cortexa9hf-neon-oe-linux-gnueabi
>>> /uhd/3.14.1.1-r1/recipe-sysroot -fvisibility=hidden
>>> -fvisibility-inlines-hidden
>>> Enabled components: LibUHD, LibUHD - C API, Examples, Utils, Tests,
>>> LIBERIO, USB, GPSD, MPMD, N300, N320, E320
>>> Install prefix: /usr
>>> Boost version: 1.66
>>> Libusb version: 1.0.23
>>> Package path: /usr
>>> Images directory: /usr/share/uhd/images
>>> ABI version string: 3.14.1
>>>
>>> Thanks,
>>> Jeff
>>>
>>> _______________________________________________
>>> USRP-users mailing list
>>> USRP-users at lists.ettus.com
>>> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>>>
>>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20200109/c26e562a/attachment.html>


More information about the USRP-users mailing list