[USRP-users] E312 - Migrating OOT Modules to the USRP

Jonathan Lockhart jlockhartrt at gmail.com
Thu Nov 21 15:16:11 EST 2019


Greetings,

I was able to get the ARM cross compile working. I removed the build
directory and re-sourced the dev environment and then the cross-compile
used the -mfloar=hard flag. Not sure what caused the issue earlier and why
it wasn't picking it up.

Now I have a different issue. So I have completed this guide:
https://kb.ettus.com/Getting_Started_with_RFNoC_Development

I modified the GNURadio just a bit so that the output from gain was placed
on a ZMQ push, and the graphics were on the host to graph the signal (seen
in the screenshots below).

[image: Screenshot from 2019-11-21 15-06-33.jpg]

[image: Screenshot from 2019-11-21 15-010-44.jpg]

However, when I run the top file for the USRP, I am running into this
error.

Traceback (most recent call last):
  File "rfnoc_myGain_usrp.py", line 223, in <module>
    main()
  File "rfnoc_myGain_usrp.py", line 212, in main
    tb = top_block_cls(fpga_path=options.fpga_path,
rx_gain=options.rx_gain, rx_digital_gain=options.rx_digital_gain,
rx_freq=options.rx_freq, host_ip_addr=options.host_ip_addr)
  File "rfnoc_myGain_usrp.py", line 117, in __init__
    self.tutorial_gain_0.set_arg("gain", rx_digital_gain)
  File
"/home/root/newinstall/usr/lib/python2.7/site-packages/tutorial/tutorial_swig.py",
line 315, in set_arg
    return _tutorial_swig.gain_sptr_set_arg(self, *args)
RuntimeError: LookupError: Path not found in tree:
/mboards/0/xbar/gain_0/args/0/gain/value

No where else in building GNURadio scripts and .bit files does this
"/mboards" arise, and I have looked through my verilog file for gain
(gain.v) and it is correct per the instructions in the linked guide, and I
built the python and gnuradio hook exactly as the instructions stated to.

Anyone have an troubleshooting ideas b/c I am currently at a loss. It did
past the test bench they have you build with no issues.

Regards,
Jon




On Wed, Nov 20, 2019 at 3:21 PM Jonathan Lockhart <jlockhartrt at gmail.com>
wrote:

> Greetings,
>
> I am having some issues completing the RFNOC build tutorial on the Ettus
> E312. The reference documentation is using an X3xx series radio, and from
> the final python script it appears to be running the GNR script natively on
> the host. I built the exact script from the KB but when running on the
> radio it fails stating it can't "import tutorial." I realized all the files
> that were installed were placed on the host but not cross compiled for the
> E3xx using the SDK and ARM cross compile tool. I tried to complete this
> task, but unfortunately the compilation dies here.
>
> /home/jon/rfnoc/oe/sysroots/armv7ahf-vfp-neon-oe-linux-gnueabi/usr/include/gnu/stubs.h:7:11:
> fatal error: gnu/stubs-soft.h: No such file or directory
>  # include <gnu/stubs-soft.h>
>            ^~~~~~~~~~~~~~~~~~
> compilation terminated.
>
> Now I did find the stubs-soft.h file in the libc6-dev-armel-cross in the
> apt repo. I installed it and tried to cp the file into the
> /home/jon/rfnoc/oe/sysroots/armv7ahf-vfp-neon-oe-linux-gnueabi/usr/include/gnu/
> location but it still doesn't like that. I verified that on my echo $CC
> that the -mfloat is set to hard as shown here.
>
> jon at jon-OptiPlex-9020:~/rfnoc/src/rfnoc-tutorial$ echo $CC
> arm-oe-linux-gnueabi-gcc -march=armv7-a -mfloat-abi=hard -mfpu=neon
> --sysroot=/home/jon/rfnoc/oe/sysroots/armv7ahf-vfp-neon-oe-linux-gnueabi
>
> So I am not sure why the gain module in the tutorial is looking for the
> soft file.
>
> If anyone has experience in porting their OOT modules over to the E-series
> of radios I would appreciate the help.
>
> Regards,
> Jon
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20191121/eda62849/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Screenshot from 2019-11-21 15-06-33.jpg
Type: image/jpeg
Size: 196974 bytes
Desc: not available
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20191121/eda62849/attachment.jpg>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Screenshot from 2019-11-21 15-010-44.jpg
Type: image/jpeg
Size: 75205 bytes
Desc: not available
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20191121/eda62849/attachment-0001.jpg>


More information about the USRP-users mailing list