[USRP-users] [EXT] Re: Question about the IMU (MPU-9150) on the E310

Samuel Prager sprager at usc.edu
Mon Nov 18 12:29:47 EST 2019


Hi Isaac,

I vaguely remember seeing this behavior on one of our e312s but it’s been a while. If I recall, the solution involved the RTIMULib.ini file (which should be created in /etc). Either the ini file was set to use the wrong SPI bus or the ini file was being saved in the wrong place or not at all. I would start there.

Sam
On Nov 18, 2019, 8:24 AM -0800, Beeman, Isaac L. , wrote:
> Hi Sam,
>
> Thanks for linking your simple example program for streaming IMU data. I finally got the RTIMULib built and installed on the E312, but when I run your program I get this output:
>
> root at ni-e31x-:~/usr/E312IMUTest/build# ./E312IMUTest
> Do something here with example option input: for example
> Settings file not found. Using defaults and creating settings file
> Failed to open I2C bus 1
> Failed to open SPI bus 0, select 0
> Failed to open SPI bus 0, select 1
> No IMU detected
> Using fusion algorithm RTQF
> No IMU found
> Error intializing IMU
>
> Was there any other setup I needed to do before running it (i.e. creating a settings file for the radio)? Do you think using a newer version of UHD and the E312 image might cause this issue?
>
> Isaac Beeman
>
> From: Samuel Prager <sprager at usc.edu>
> Sent: Tuesday, November 12, 2019 5:50 PM
> To: Beeman, Isaac L. <ilbeeman at wpi.edu>; Michael Dickens <michael.dickens at ettus.com>
> Cc: usrp-users at lists.ettus.com <usrp-users at lists.ettus.com>
> Subject: [EXT] Re: [USRP-users] Question about the IMU (MPU-9150) on the E310
>
> Hi Isaac,
>
> Here is a simple example program I wrote a while back for continuously streaming IMU data on the E310/E312.
>
> https://github.com/samprager/E312IMUTest
>
> See the README for RTIMULib installation instructions (the correct library is https://github.com/RPi-Distro/RTIMULib).
>
> Sam
> On Nov 12, 2019, 12:30 PM -0800, Michael Dickens via USRP-users <usrp-users at lists.ettus.com>, wrote:
> > Hi Isaac - UHD itself provides no API to the IMU; never has. The RTIMULib, possibly an older version than current and assuming it can be built and installed on the E310, should be able to access the IMU to provide information from it. Note "possibly", "assuming", "should" ... clearly this isn't a majorly supported feature of the E310! Good luck! - MLD
> >
> > On Tue, Nov 12, 2019 at 12:37 PM Beeman, Isaac L. via USRP-users <usrp-users at lists.ettus.com> wrote:
> > > Marcus and List,
> > >
> > > I was hoping someone knew the steps involved to get the RTIMULib setup on the USRP. I tried building and installing both the RTIMULib and Linux folders, but the Linux one fails:
> > >
> > >
> > > -- Found unsuitable Qt version "" from NOTFOUND
> > > Qt QTOPENGL library not found.
> > > Qt QTGUI library not found.
> > > Qt QTCORE library not found.
> > > CMake Error at RTIMULibGL/CMakeLists.txt:90 (QT4_ADD_RESOURCES):
> > >     Unknown CMake command "QT4_ADD_RESOURCES".
> > > -- Configuring incomplete, errors occurred!
> > >
> > >
> > > I figured that I can't install the RTIMULibDemo apps because they use a GUI, so I built and installed the RTIMULibDrive and RTIMULibCal individually. Only, when I try to run one of these apps I get the following error:
> > >
> > >
> > > RTIMULibDrive: error while loading shared libraries: libRTIMULib.so.7: cannot open shared object file: No such file or directory
> > >
> > >
> > > I don't get how to fix this. When I build and install the same apps on my host computer they run fine (but obviously can't find any IMU). Considering that any applications I write also use the same libraries, I feel like this is going to be an issue.
> > >
> > > There isn't any documentation that I can find on the usage of the C++ library for RTIMULib. Just reading the code in RTIMULibDrive.cpp as an example, it doesn't seem too complicated, but it obviously is a generic program that isn't using the settings needed to connect to the MPU-9150.
> > >
> > > If anyone knows how to get one of these apps (RTIMULibDrive or RTIMULibCal) working or how to use RTIMULib.h in connecting to the MPU-9150 over I2C, it would be much appreciated.
> > >
> > > -Isaac Beeman
> > >
> > >
> > >
> > > P.S. I also tried 'i2cdetect -y 0' to see if the MPU-9150 has the I2C address 0x69 like the schematics say, but I only get:
> > >
> > > Warning: Can't use SMBus Quick Write command, will skip some addresses
> > >      0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
> > > 00:
> > > 10:
> > > 20:
> > > 30: -- -- -- -- -- -- -- --
> > > 40:
> > > 50: UU UU -- -- -- -- -- -- -- -- -- -- -- -- -- --
> > > 60:
> > > 70:
> > >
> > > with nothing under 0x69. So that's weird.
> > >
> > >
> > > -----Original Message-----
> > > From: USRP-users <usrp-users-bounces at lists.ettus.com> On Behalf Of Marcus D. Leech via USRP-users
> > > Sent: Tuesday, November 12, 2019 10:35 AM
> > > To: usrp-users at lists.ettus.com
> > > Subject: [EXT] Re: [USRP-users] Question about the IMU (MPU-9150) on the E310
> > >
> > > On 11/12/2019 10:26 AM, Beeman, Isaac L. via USRP-users wrote:
> > > > Hi List,
> > > >
> > > > I have recently started working with the E310/E312 and have gotten multichannel RX/TX and GPS working, but I can't figure out how to grab data off of the internal IMU/MPU-9150. I found some website (http://gnuradio.cn/en/html/support/en/page_usrp_e3x0.html) that said that the USRP image should contain RTIMULib applications with allow the user to test the IMU, but, unless I am looking in the wrong place, the current image for the E310 does not have any RTIMULib applications on it.
> > > >
> > > > I want to know if there are any API calls or libraries that would allow me to do development with the IMU.
> > > >
> > > > -Isaac Beeman
> > > >
> > > > _______________________________________________
> > >
> > > You might start here:
> > >
> > > https://github.com/RTIMULib
> > >
> > > _______________________________________________
> > > USRP-users mailing list
> > > USRP-users at lists.ettus.com
> > > http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
> >
> >
> > --
> > Michael Dickens
> > Ettus Research Technical Support
> > Email: support at ettus.com
> > Web: https://ettus.com/
> > _______________________________________________
> > USRP-users mailing list
> > USRP-users at lists.ettus.com
> > https://urldefense.proofpoint.com/v2/url?u=http-3A__lists.ettus.com_mailman_listinfo_usrp-2Dusers-5Flists.ettus.com&d=DwICAg&c=clK7kQUTWtAVEOVIgvi0NU5BOUHhpN0H8p7CSfnc_gI&r=opIuWAKmywF059tAs2i3Pg&m=rGLxgINOMrS4sAfnjQ9mFF9r3gnmnGlRtI8Lfh1c_9g&s=8wPPngBEnPiaAxtUARbH1opcSV3Pgih5Konyr2kf9-c&e=
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20191118/0f4d4fcf/attachment.html>


More information about the USRP-users mailing list