[USRP-users] reinitializing N310 from MPM shell

Samuel Berhanu samberhanu at gmail.com
Fri Nov 8 09:23:22 EST 2019


Hello all,
I was trying to reissue a daughterboard reset/reinitilzation for the N310
from MPM (I know at the uhd software stack there is force_reinit=1 argument
that does this but can't use this right now).

I tried to use the "init_dboards" command but was not sure what the
argument that I need to pass into it. Maybe someone has tried to use the
function before?

I tried using the reset_mgr function and got error:

spidev spi0.2: SPI transfer timed out
spidev spi0.0: SPI transfer timed out

I also tried to restart the daemon (usrp-hwd.service) and got the same
error.
It looks like once a wrong bit file is loaded, I have now had to resort to
power-cycling the device to be able to get clocks up and running. I would
think the "init_dboards" function should do the trick but don't know  the
arguments to pass.
Any help is appreciated!
-sam
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20191108/0b853858/attachment.html>


More information about the USRP-users mailing list