[USRP-users] UHD and FPGA Image mismatch error

Bisma Amjad msee17016 at itu.edu.pk
Wed Nov 6 05:37:19 EST 2019


Hi there,


·         I have installed GNU Radio using PyBombs from
http://ecee.colorado.edu/~mathys/ecen4652/SDRsoftware/GNURadioInstall.html



·         UHD was installed from
https://kb.ettus.com/Building_and_Installing_the_USRP_Open-Source_Toolchain_(UHD_and_GNU_Radio)_on_Linux



·         GNU Radio works fine. I’ve created an FM Radio application on
it.  USRP E320 is also detected on the system. However, when the flowgraph
is executed on GNU Radio, following error shows up:



*RuntimeError: FPGA component ‘noc_shell’ is revision 2 and UHD supports
revision 3. Please either upgrade the FPGA image (Recommended) or downgrade
UHD.*

*Troubleshooting:*

·As indicated by few web sources, Pybombs could’ve created issues during
GNU Radio installation. So, I re-installed GNU radio and UHD without using
pybombs (from
https://kb.ettus.com/Building_and_Installing_the_USRP_Open-Source_Toolchain_(UHD_and_GNU_Radio)_on_Linux)
.

 But the error still persists.



*RuntimeError: FPGA component ‘noc_shell’ is revision 2 and UHD supports
revision 6. Please either upgrade the FPGA image (Recommended) or downgrade
UHD.*





·Moreover, the required installation libraries for UHD are supported for
Ubuntu version 18.10 or less. Whereas, our system has Ubuntu version 19.0.
Could this be the possible reason for this issue? Should I downgrade Ubuntu
to 18.10?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20191106/84558b3a/attachment.html>


More information about the USRP-users mailing list