[USRP-users] Problems when Running UHD_3.14.1 Examples on E310

Philip Balister philip at balister.org
Tue Nov 5 08:59:10 EST 2019


On 11/4/19 9:25 PM, zcao at c3commsystems.com wrote:
> Philip,
> 
> Thanks for the response. That’s what we did to get through the issue. 
> 
> But is it what we supposed to do, i.e., edit these UHD provided python scripts manually?

No, hopefully someone from Ettus entered this into the bug tracker.

Philip

> 
> Thanks,
> Zhongren
> 
>> On Nov 4, 2019, at 2:27 PM, Philip Balister <philip at balister.org> wrote:
>>
>> On 11/4/19 5:04 PM, zcao--- via USRP-users wrote:
>>> Hi, 
>>>
>>> We are trying to run UHD examples on E310. The process we took are as the following.
>>>
>>> 1. Flash a fresh SDcard using the dev image located at http://files.ettus.com/e3xx_images/e3xx-release-4/ettus-e3xx-sg3/ <http://files.ettus.com/e3xx_images/e3xx-release-4/ettus-e3xx-sg3/>
>>>
>>> 2. Cross-compile UHD source code on a development machine and install the build on to the E310 device using sshfs. Note that this is a different from what is proposed in AN-311. We installed UHD 3.14 onto the device directly.
>>>
>>> 3. Running /usr/bin/uhd_find_devices, we got the following output, looks normal.
>>>
>>> [INFO] [UHD] linux; GNU C++ version 4.9.2; Boost_105700; UHD_3.14.1.1-0-g0347a6d8
>>> --------------------------------------------------
>>> -- UHD Device 0
>>> --------------------------------------------------
>>> Device Address:
>>>    serial: 31819A1
>>>    name: 
>>>    node: /dev/axi_fpga
>>>    product: E3XX SG3
>>>    type: e3x0
>>>
>>>
>>> However, we ran into the following problems, which seem to be related.
>>>
>>> 1. We cannot run /usr/bin/uhd_usrp_probe, because of the FPGA compatibility. Specifically, the error messages are
>>>
>>> Error: RuntimeError: Expected FPGA compatibility number 255.x, but got 14.0:
>>> The FPGA build is not compatible with the host code build.
>>> Please run:
>>>
>>> "/usr/lib/uhd/utils/uhd_images_downloader.py"
>>>
>>>
>>> 2. But running the above python script gives us the following error messages.
>>>
>>> -sh: /usr/lib/uhd/utils/uhd_images_downloader.py: /usr/local/oecore-x86_64/sysroots/x86_64-oesdk-linux/usr/bin/python2: bad interpreter: No such file or directory/
>>
>> Look at the script /usr/lib/uhd/utils/uhd_images_downloader.py and edit
>> the #!/bin/fo/bar/python to something reasonable.
>>
>> Philip
>>
>>>
>>>
>>> Note that the python script is looking for the SDK, which should be on the development machine, instead of the device itself.
>>>
>>> Would really appreciate it if anyone knows how to handle above issues in E310 device itself?
>>>
>>> Thanks,
>>> Arnold
>>>
>>>
>>>
>>> _______________________________________________
>>> USRP-users mailing list
>>> USRP-users at lists.ettus.com
>>> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>>>
> 
> Arnold Z. Cao, Ph.D.
> 
> C-3 Comm Systems, LLC
> 3100 Clarendon Blvd., Suite 200
> Arlington, VA 22201
> Phone: (703) 829-0588
> Email : zcao at c3commsystems.com <mailto:zcao at c3commsystems.com>
> 



More information about the USRP-users mailing list