[USRP-users] UBX coherence between TX and RX

Nick Foster bistromath at gmail.com
Mon Mar 25 12:34:13 EDT 2019


Well, according to your description, you could transmit a carrier from TX
to RX (through an attenuator) with both sides set to the same frequency.
Your received signal should look like a sine wave at the frequency of the
offset.

On Mon, Mar 25, 2019 at 9:16 AM Michael R. Freedman via USRP-users <
usrp-users at lists.ettus.com> wrote:

> Hello,
>
> Do you have any suggestions as to how to measure the frequency delta
> between the transmit channel and the receive channel?
>
> As I sat down to do this, I realized I have no real way to do that.
>
>
> Mike
>
>
>
>
>
> On 03/24/2019 03:23 PM, Marcus D. Leech via USRP-users wrote:
>
> On 03/24/2019 02:39 PM, Freedman, Michael - 1008 - MITLL via USRP-users
> wrote:
>
> It is not just a phase offset. It is a frequency offset. The phase drifts between the two. I can tolerate a phase offset at startup. A freq offset however is causing problems.
>
> Mike
>
> Sent from my iPhone
>
> On Mar 24, 2019, at 4:28 AM, Marcus Müller <marcus.mueller at ettus.com> <marcus.mueller at ettus.com> wrote:
>
> Can you elaborate on what "not coherent" means to you – the relative
> phase should be constant after each tune, but if you don't tune
> simultaneously, i.e. with timed commands, random at each tune.
>
> Best regards,
> Marcus
>
> Also, what version of UHD?  What hardware rev of UBX cards?
>
>
> On Sat, 2019-03-23 at 17:06 -0400, Michael R. Freedman via USRP-users
> wrote:
>
> Hello,
>
>
> I have an issue where I tune both the TX and RX side of a UBX40 card
> in
> an X310 to the same frequency and find that the transmitted signal
> and
> what is received are not coherent.  I am using an external 10MHz
> reference and have tried the documented suggestions.
>
> at 150MHz it is coherent.
>
> at 155MHz it is NOT coherent.
>
>
> I have tried setting the dboard_clock_rate to 20MHz.  This made the
> problem appear at 150MHz as well.  I've tried integer_n tuning.
>
> I have verified that the ref_lock and lo_lock are both true.
>
>
> Any suggestions?
>
>
> Mike
>
>
> _______________________________________________
> USRP-users mailing listUSRP-users at lists.ettus.comhttp://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
>
>
> _______________________________________________
> USRP-users mailing listUSRP-users at lists.ettus.comhttp://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
>
>
>
> _______________________________________________
> USRP-users mailing listUSRP-users at lists.ettus.comhttp://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
>
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20190326/d2a00b07/attachment.html>


More information about the USRP-users mailing list