[USRP-users] N310 Initial Connection Issues

Robin Coxe robin.coxe at ettus.com
Tue Mar 12 13:52:18 EDT 2019


Hi Marc.

Are you trying to connect using 1 gigE or 10gigE?
The default N310 FPGA bitstream is the HG image, which expects 10gigE on
SFP port 1 (192.168.20.2) and/or 1 gigE on SFP port 0 (192.168.10.2).

-Robin


On Tue, Mar 12, 2019 at 10:43 AM Nate Temple via USRP-users <
usrp-users at lists.ettus.com> wrote:

> Hi Marc,
>
> What version of UHD are you using? If you're not running with any
> 3.14.0.0-rcX release, can you please try v3.14.0.0-rc3 ?
>
> Regards,
> Nate Temple
>
> On Tue, Mar 12, 2019 at 10:37 AM Marc Lichtman via USRP-users <
> usrp-users at lists.ettus.com> wrote:
>
>> Hey,
>>
>> I'm having issues connecting to a N310 with stock firmware.  Its eth0
>> port works fine; it can get an IP address and I can even SSH into it from a
>> different (host) computer, but when I set up a second ethernet port on my
>> host with a static IP of 192.168.10.1 and mask 255.255.255.0, and connect
>> it to SFP0 on the N310, pinging 192.168.10.2 fails with destination
>> unreachable.  I'm using the transceiver that came with it, and the lights
>> above the SFP0 port on the USRP are on (one is solid, one flashes on
>> occasion).  I verified my host was using 192.168.10.1 on the port connected
>> to SFP0.
>>
>> Some possible clues- When I run uhd_find_devices on the host, the N310
>> shows up, but said "Reachable: No" (which is a new field to me).  When I
>> SSH into the N310 and do ifconfig, it shows the eth0 with its assigned IP
>> address, and it shows sfp1 but with no IP address, and no sfp0/sfp2 (not
>> sure how its suppose to be labeled).  I was expected to do ifconfig and see
>> sfp0 showing 192.168.10.2 and sfp1 with 192.168.20.2 since it's static.
>>
>> Any help would be greatly appreciated!  Thanks!
>>
>> -Marc
>> _______________________________________________
>> USRP-users mailing list
>> USRP-users at lists.ettus.com
>> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>>
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20190312/7391514f/attachment.html>


More information about the USRP-users mailing list