[USRP-users] Ettus recovery process not working

Nicolas GALLAND nicolas.galland at obspm.fr
Mon Mar 11 09:24:21 EDT 2019


Hello everyone,

I am facing big problem with my USRP X310.

First problem is that some day, a gnuradio flowgraph that was working 
fine since almost 1 year suddenly stopped working, and it turned out the 
problem was coming from the ettus, because when I tried to do a 
uhd_usrp_probe, I had a

UHD Error:
     x300 fw communication failure #1
     EnvironmentError: IOError: x300 fw poke32 - reply timed out
UHD Error:
     x300 fw communication failure #1
     EnvironmentError: IOError: x300 fw poke32 - reply timed out
UHD Error:
     x300 fw communication failure #1
     EnvironmentError: IOError: x300 fw poke32 - reply timed out
UHD Error:
     An unexpected exception was caught in a task loop.
     The task loop will now exit, things may not work.
     EnvironmentError: IOError: x300 fw communication failure #3
     EnvironmentError: IOError: x300 fw poke32 - reply timed out

I then tried to update my version of UHD, which worked well, and then I 
had to update the FPGA image. This worked weel too, however after it was 
finnished, i did the poser cycle as recomanded, but the USRP never 
showed up again on the network. It tried to find it on the 192.168.10.1, 
but network was unreachable.

I decided to use the https://kb.ettus.com/X300/X310_Device_Recovery 
process to re-upload the fpga image from another computer with a 
different version of the UHD library. the full process worked well, but 
in the end, when I tried to ping the Ettus, I get an error saying host 
is unreachable. The error changed for the ping, but when I run 
uhd_find_device, there is no device found.

I do not know what else I can try to recover the device, or could it be 
some hardware problem ?

Thanks in advance,

     Kind regards,

         Nicolas





More information about the USRP-users mailing list