[USRP-users] Problem with usrp-2900 and GNU Radio

Joe Martin k5so at k5so.com
Sat Mar 9 14:35:46 EST 2019


Hi Thomas, 

I also am new to USRP so if I tell you something that is not correct perhaps someone more knowledgeable will weigh in and correct me for both our benefits.  

The error you received indicates (I think) that the FPGA firmware version and the UHD version you have installed are incompatible.  I obtained this same type of error when first bringing up my x310.  To cure it, I had to find a pair of versions of firmware and software that are compatible.  In my case I found that X300 firmware version 36.0 works with UHD version 3.14.0 so that’s what I am currently using.  

It wasn’t clear to me (and still isn’t) how one determines which firmware and software versions are compatible.  If there is a way to do that I’ll be interested in learning about how to do it.  I simply used a trial and error method until I found a pair that worked together.  Basically, I installed the latest UHD version of software and found that X300 XG FPGA v36.0 firmware worked with it on my USRP.  

Good luck, I know it can be frustrating when you don’t know all that you need to know to make things work smoothly, but things do get better in terms of your understanding if you hammer on the issues long enough.  

Maybe this is enough of a hint to allow you to make progress on it for your USRP?  

Joe

> On Mar 9, 2019, at 12:00 PM, Thomas Lavarenne via USRP-users <usrp-users at lists.ettus.com> wrote:
> 
> Yes, it worked, but the script were on /usr/lib/uhd/utils/ and same error...
> 
> sudo /usr/lib/uhd/utils/uhd_images_downloader.py
> [sudo] Mot de passe de user :         
> [INFO] Images destination: /usr/share/uhd/images
> [INFO] Target usrp1_b100_fw_default is up to date.
> [INFO] Target x3xx_x310_fpga_default is up to date.
> [INFO] Target usrp2_n210_fpga_default is up to date.
> [INFO] Target n230_n230_fpga_default is up to date.
> [INFO] Target usrp1_b100_fpga_default is up to date.
> [INFO] Target b2xx_b200_fpga_default is up to date.
> [INFO] Target usrp2_n200_fpga_default is up to date.
> [INFO] Target e3xx_e320_fpga_default is up to date.
> [INFO] Target n3xx_n310_fpga_default is up to date.
> [INFO] Target b2xx_b205mini_fpga_default is up to date.
> [INFO] Target x3xx_x300_fpga_default is up to date.
> [INFO] Target octoclock_octoclock_fw_default is up to date.
> [INFO] Target usrp2_usrp2_fw_default is up to date.
> [INFO] Target usrp2_n200_fw_default is up to date.
> [INFO] Target usrp2_usrp2_fpga_default is up to date.
> [INFO] Target b2xx_common_fw_default is up to date.
> [INFO] Target b2xx_b200mini_fpga_default is up to date.
> [INFO] Target usrp1_usrp1_fpga_default is up to date.
> [INFO] Target usb_common_windrv_default is up to date.
> [INFO] Target usrp2_n210_fw_default is up to date.
> [INFO] Target n3xx_n300_fpga_default is up to date.
> [INFO] Target e3xx_e310_fpga_default is up to date.
> [INFO] Target b2xx_b210_fpga_default is up to date.
> 
> 
> Le sam. 9 mars 2019 à 19:58, Brian Padalino <bpadalino at gmail.com <mailto:bpadalino at gmail.com>> a écrit :
> On Sat, Mar 9, 2019 at 1:45 PM Thomas Lavarenne via USRP-users <usrp-users at lists.ettus.com <mailto:usrp-users at lists.ettus.com>> wrote:
> Hello,
> I'm new here and pretty new with usrp. I'm trying to use usrp-2900 with GNU Radio and Ubuntu 18.04, but i have this problem (latest driver uhd from source):
> 
> '''
> linux; GNU C++ version 7.3.0; Boost_106501; UHD_003.010.003.000-0-unknown
> 
> -- Loading firmware image: /usr/share/uhd/images/usrp_b200_fw.hex...
> -- Detected Device: B200
> -- Loading FPGA image: /usr/share/uhd/images/usrp_b200_fpga.bin... done
> -- Operating over USB 3.
> Traceback (most recent call last):
>   File "/home/user/top_block.py", line 166, in <module>
>     main()
>   File "/home/user/top_block.py", line 154, in main
>     tb = top_block_cls()
>   File "/home/user/top_block.py", line 78, in __init__
>     channels=range(1),
>   File "/usr/lib/python2.7/dist-packages/gnuradio/uhd/__init__.py", line 122, in constructor_interceptor
>     return old_constructor(*args)
>   File "/usr/lib/python2.7/dist-packages/gnuradio/uhd/uhd_swig.py", line 2683, in make
>     return _uhd_swig.usrp_source_make(*args)
> RuntimeError: RuntimeError: Expected FPGA compatibility number 14, but got 16:
> The FPGA build is not compatible with the host code build.
> Please run:
> 
>  "/usr/lib/x86_64-linux-gnu/uhd/utils/uhd_images_downloader.py"
> 
> >>> Done
> ''''
> Any ideas accepted!
> 
> Have you tried running:
> 
>   $ sudo /usr/lib/x86_64-linux-gnu/uhd/utils/uhd_images_downloader.py
> 
> As the message suggests?
> 
> Brian
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20190309/300e2d51/attachment.html>


More information about the USRP-users mailing list