[USRP-users] Problem with usrp-2900 and GNU Radio

Thomas Lavarenne thomas.lavarenne at gmail.com
Sat Mar 9 14:34:22 EST 2019


uhd_probe seems good, but same error in GNU Radio.. (RuntimeError:
RuntimeError: Expected FPGA compatibility number 14, but got 16:)

$ uhd_usrp_probe
[INFO] [UHD] linux; GNU C++ version 7.3.0; Boost_106501;
UHD_3.15.0.git-60-g98d2572a
[INFO] [B200] Loading firmware image:
/usr/local/share/uhd/images/usrp_b200_fw.hex...
[INFO] [B200] Detected Device: B200
[INFO] [B200] Loading FPGA image:
/usr/local/share/uhd/images/usrp_b200_fpga.bin...
[INFO] [B200] Operating over USB 2.
[INFO] [B200] Detecting internal GPSDO....
[INFO] [GPS] No GPSDO found
[INFO] [B200] Initialize CODEC control...
[INFO] [B200] Initialize Radio control...
[INFO] [B200] Performing register loopback test...
[INFO] [B200] Register loopback test passed
[INFO] [B200] Setting master clock rate selection to 'automatic'.
[INFO] [B200] Asking for clock rate 16.000000 MHz...
[INFO] [B200] Actually got clock rate 16.000000 MHz.
  _____________________________________________________
 /
|       Device: B-Series Device
|     _____________________________________________________
|    /
|   |       Mboard: B200
|   |   revision: 5
|   |   product: 30739
|   |   serial: 3141FB6
|   |   name: NI2900
|   |   FW Version: 8.0
|   |   FPGA Version: 16.0
|   |
|   |   Time sources:  none, internal, external, gpsdo
|   |   Clock sources: internal, external, gpsdo
|   |   Sensors: ref_locked
|   |     _____________________________________________________
|   |    /
|   |   |       RX DSP: 0
|   |   |
|   |   |   Freq range: -8.000 to 8.000 MHz
|   |     _____________________________________________________
|   |    /
|   |   |       RX Dboard: A
|   |   |     _____________________________________________________
|   |   |    /
|   |   |   |       RX Frontend: A
|   |   |   |   Name: FE-RX1
|   |   |   |   Antennas: TX/RX, RX2
|   |   |   |   Sensors: temp, rssi, lo_locked
|   |   |   |   Freq range: 50.000 to 6000.000 MHz
|   |   |   |   Gain range PGA: 0.0 to 76.0 step 1.0 dB
|   |   |   |   Bandwidth range: 200000.0 to 56000000.0 step 0.0 Hz
|   |   |   |   Connection Type: IQ
|   |   |   |   Uses LO offset: No
|   |   |     _____________________________________________________
|   |   |    /
|   |   |   |       RX Codec: A
|   |   |   |   Name: B200 RX dual ADC
|   |   |   |   Gain Elements: None
|   |     _____________________________________________________
|   |    /
|   |   |       TX DSP: 0
|   |   |
|   |   |   Freq range: -8.000 to 8.000 MHz
|   |     _____________________________________________________
|   |    /
|   |   |       TX Dboard: A
|   |   |     _____________________________________________________
|   |   |    /
|   |   |   |       TX Frontend: A
|   |   |   |   Name: FE-TX1
|   |   |   |   Antennas: TX/RX
|   |   |   |   Sensors: temp, lo_locked
|   |   |   |   Freq range: 50.000 to 6000.000 MHz
|   |   |   |   Gain range PGA: 0.0 to 89.8 step 0.2 dB
|   |   |   |   Bandwidth range: 200000.0 to 56000000.0 step 0.0 Hz
|   |   |   |   Connection Type: IQ
|   |   |   |   Uses LO offset: No
|   |   |     _____________________________________________________
|   |   |    /
|   |   |   |       TX Codec: A
|   |   |   |   Name: B200 TX dual DAC
|   |   |   |   Gain Elements: None


Le sam. 9 mars 2019 à 20:24, Marcus D. Leech via USRP-users <
usrp-users at lists.ettus.com> a écrit :

> On 03/09/2019 02:00 PM, Thomas Lavarenne via USRP-users wrote:
>
> Yes, it worked, but the script were on /usr/lib/uhd/utils/ and same
> error...
>
> sudo /usr/lib/uhd/utils/uhd_images_downloader.py
> [sudo] Mot de passe de user :
> [INFO] Images destination: /usr/share/uhd/images
> [INFO] Target usrp1_b100_fw_default is up to date.
> [INFO] Target x3xx_x310_fpga_default is up to date.
> [INFO] Target usrp2_n210_fpga_default is up to date.
> [INFO] Target n230_n230_fpga_default is up to date.
> [INFO] Target usrp1_b100_fpga_default is up to date.
> [INFO] Target b2xx_b200_fpga_default is up to date.
> [INFO] Target usrp2_n200_fpga_default is up to date.
> [INFO] Target e3xx_e320_fpga_default is up to date.
> [INFO] Target n3xx_n310_fpga_default is up to date.
> [INFO] Target b2xx_b205mini_fpga_default is up to date.
> [INFO] Target x3xx_x300_fpga_default is up to date.
> [INFO] Target octoclock_octoclock_fw_default is up to date.
> [INFO] Target usrp2_usrp2_fw_default is up to date.
> [INFO] Target usrp2_n200_fw_default is up to date.
> [INFO] Target usrp2_usrp2_fpga_default is up to date.
> [INFO] Target b2xx_common_fw_default is up to date.
> [INFO] Target b2xx_b200mini_fpga_default is up to date.
> [INFO] Target usrp1_usrp1_fpga_default is up to date.
> [INFO] Target usb_common_windrv_default is up to date.
> [INFO] Target usrp2_n210_fw_default is up to date.
> [INFO] Target n3xx_n300_fpga_default is up to date.
> [INFO] Target e3xx_e310_fpga_default is up to date.
> [INFO] Target b2xx_b210_fpga_default is up to date.
>
>
> Your 2900 has an image that is newer than your host-side firmware.
> Power-cycle it, and try the uhd_usrp_probe again.
>
>
> Le sam. 9 mars 2019 à 19:58, Brian Padalino <bpadalino at gmail.com> a
> écrit :
>
>> On Sat, Mar 9, 2019 at 1:45 PM Thomas Lavarenne via USRP-users <
>> usrp-users at lists.ettus.com> wrote:
>>
>>> Hello,
>>> I'm new here and pretty new with usrp. I'm trying to use usrp-2900 with
>>> GNU Radio and Ubuntu 18.04, but i have this problem (latest driver uhd from
>>> source):
>>>
>>> '''
>>> linux; GNU C++ version 7.3.0; Boost_106501; UHD_003.010.003.000-0-unknown
>>>
>>> -- Loading firmware image: /usr/share/uhd/images/usrp_b200_fw.hex...
>>> -- Detected Device: B200
>>> -- Loading FPGA image: /usr/share/uhd/images/usrp_b200_fpga.bin... done
>>> -- Operating over USB 3.
>>> Traceback (most recent call last):
>>>   File "/home/user/top_block.py", line 166, in <module>
>>>     main()
>>>   File "/home/user/top_block.py", line 154, in main
>>>     tb = top_block_cls()
>>>   File "/home/user/top_block.py", line 78, in __init__
>>>     channels=range(1),
>>>   File "/usr/lib/python2.7/dist-packages/gnuradio/uhd/__init__.py", line
>>> 122, in constructor_interceptor
>>>     return old_constructor(*args)
>>>   File "/usr/lib/python2.7/dist-packages/gnuradio/uhd/uhd_swig.py", line
>>> 2683, in make
>>>     return _uhd_swig.usrp_source_make(*args)
>>>
>>> *RuntimeError: RuntimeError: Expected FPGA compatibility number 14, but
>>> got 16: The FPGA build is not compatible with the host code build.*
>>> Please run:
>>>
>>>  "/usr/lib/x86_64-linux-gnu/uhd/utils/uhd_images_downloader.py"
>>>
>>> >>> Done
>>> ''''
>>> Any ideas accepted!
>>>
>>
>> Have you tried running:
>>
>>   $ sudo /usr/lib/x86_64-linux-gnu/uhd/utils/uhd_images_downloader.py
>>
>> As the message suggests?
>>
>> Brian
>>
>
>
> _______________________________________________
> USRP-users mailing listUSRP-users at lists.ettus.comhttp://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
>
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20190309/dc1480c0/attachment.html>


More information about the USRP-users mailing list