[USRP-users] USRP X310 PCIe connection Driver Problem

akin soysal akinsoysal at gmail.com
Tue Mar 5 06:42:32 EST 2019


OK, so I did manage to debug it further by setting the
ENABLE_EXTENDED_ERROR_INFO flag to true. It seems like the
nirio_driver_iface::rio_ioctl function is returning 52003 error.

uhd_usrp_probe --args "type=x300,resource=RIO0,fpga=HG"
[INFO] [UHD] linux; GNU C++ version 5.4.0 20160609; Boost_105800;
UHD_3.13.1.HEAD-0-gbbce3e45
[INFO] [NIRIO] rpc_client stopping...
[INFO] [NIRIO] rpc_client stopped.
ERROR: The following function call returned status code -52003
nirio_driver_iface::rio_ioctl(_device_handle, NIRIO_IOCTL_POST_OPEN, NULL,
0, NULL, 0)
/home/ulak/uhd/uhd/host/lib/transport/nirio/niriok_proxy_impl_v1.cpp:438
[INFO] [NIRIO] rpc_client stopping...
[INFO] [NIRIO] rpc_client stopped.
ERROR: The following function call returned status code -52003
nirio_driver_iface::rio_ioctl(_device_handle, NIRIO_IOCTL_POST_OPEN, NULL,
0, NULL, 0)
/home/ulak/uhd/uhd/host/lib/transport/nirio/niriok_proxy_impl_v1.cpp:438
[INFO] [X300] X300 initialization sequence...
[INFO] [X300] Connecting to niusrpriorpc at localhost:5444...
ERROR: The following function call returned status code -52003
nirio_driver_iface::rio_ioctl(_device_handle, NIRIO_IOCTL_POST_OPEN, NULL,
0, NULL, 0)
/home/ulak/uhd/uhd/host/lib/transport/nirio/niriok_proxy_impl_v1.cpp:438
[INFO] [NIRIO] rpc_client stopping...
[INFO] [NIRIO] rpc_client stopped.
[INFO] [X300] Using LVBITX bitfile /home/ulak/usrp_x310_fpga_HG.lvbitx...
ERROR: The following function call returned status code -52003
nirio_driver_iface::rio_ioctl(_device_handle, NIRIO_IOCTL_POST_OPEN, NULL,
0, NULL, 0)
/home/ulak/uhd/uhd/host/lib/transport/nirio/niriok_proxy_impl_v1.cpp:438
[INFO] [NIRIO] rpc_client stopping...
[INFO] [NIRIO] rpc_client stopped.
ERROR: The following function call returned status code -63150
_rpc_client.niusrprio_open_session( _resource_name, bitfile_path,
signature, download_fpga)
/home/ulak/uhd/uhd/host/lib/transport/nirio/niusrprio_session.cpp:80
ERROR: The following function call returned status code -63150
mb.rio_fpga_interface->open(lvbitx, dev_addr.has_key("download-fpga"))
/home/ulak/uhd/uhd/host/lib/usrp/x300/x300_impl.cpp:609
[INFO] [NIRIO] rpc_client stopping...
[INFO] [NIRIO] rpc_client stopped.
Error: RuntimeError: x300_impl: Could not initialize RIO session. Unknown
error. (Error code -63150)





On Tue, Mar 5, 2019 at 1:32 PM akin soysal <akinsoysal at gmail.com> wrote:

> Dear all,
>
> I am trying to connect over PCIe to my USRP X310. I have installed the
> latest drivers niusrprio-installer-18.0.0.tar.gz and I am starting the PCIe
> connection with the following command:
>
> sudo /usr/local/bin/niusrprio_pcie start
> Making sure drivers are up to date...
> Module nikal is up-to-date
> Module nibds is up-to-date
> Module nistreamk is up-to-date
> Module NiRioSrv is up-to-date
> Module niusrpriok is up-to-date
> Loading: NiRioSrv niusrpriok
> Starting: niusrpriorpc
>
> Then I try the uhd_usrp_probe:
>
> uhd_usrp_probe --args "type=x300,resource=RIO0"
> [INFO] [UHD] linux; GNU C++ version 5.4.0 20160609; Boost_105800;
> UHD_3.13.1.HEAD-0-gbbce3e45
> [INFO] [NIRIO] rpc_client stopping...
> [INFO] [NIRIO] rpc_client stopped.
> [INFO] [NIRIO] rpc_client stopping...
> [INFO] [NIRIO] rpc_client stopped.
> [INFO] [X300] X300 initialization sequence...
> [INFO] [X300] Connecting to niusrpriorpc at localhost:5444...
> [INFO] [NIRIO] rpc_client stopping...
> [INFO] [NIRIO] rpc_client stopped.
> [INFO] [X300] Using LVBITX bitfile
> /usr/local/share/uhd/images/usrp_x310_fpga_HG.lvbitx...
> [INFO] [NIRIO] rpc_client stopping...
> [INFO] [NIRIO] rpc_client stopped.
> [INFO] [NIRIO] rpc_client stopping...
> [INFO] [NIRIO] rpc_client stopped.
> Error: RuntimeError: x300_impl: Could not initialize RIO session. Unknown
> error. (Error code -63150)
>
> I have another PC and USRP x310 and this is working fine. I have followed
> the exact same steps and there isn't any issue. What could be the problem
> and how can I debug this further?
>
> Regards,
> Akın
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20190305/0063af9e/attachment.html>


More information about the USRP-users mailing list