[USRP-users] X310 Power before Transmit

Alexander Olihovik ano9cn at virginia.edu
Mon Feb 25 11:31:23 EST 2019


My mistake, I'm using a UBX daughterboard with the X310 and was checking
the DAC_ENABLE pin in the FPGA. I figured DAC_ENABLE might toggle whenever
there is data to transmit, but it wasn't the case.

On Mon, Feb 25, 2019 at 10:44 AM Marcus D Leech <patchvonbraun at gmail.com>
wrote:

> I’m confused. There is no AD9361 on the X310.
>
> Sent from my iPhone
>
> > On Feb 25, 2019, at 10:02 AM, Alexander Olihovik via USRP-users <
> usrp-users at lists.ettus.com> wrote:
> >
> > Hi all,
> >
> > I modified the X310's FPGA to toggle a GPIO pin immediately once it sees
> TX data, and delay the TX data by a fixed number of samples. Using an
> oscilloscope, I found that everything works as expected, but there is an
> initial spike of RF power that precedes the GPIO trigger and the RF signal.
> Has anyone else experienced this? Is there anything I can set my GPIO
> trigger on to start before the power spike? I also tried triggering the
> GPIO pin on DAC_ENABLE, but it seems this signal goes high and stays high
> once the AD9361 is initialized, and not only when the DAC is about to push
> out data.
> >
> > Best regards,
> > Alex
> > _______________________________________________
> > USRP-users mailing list
> > USRP-users at lists.ettus.com
> > http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>


-- 




*Alex OlihovikUniversity of Virginia 2013BS Electrical EngineeringBS
Computer Engineeringano9cn at virginia.edu <ano9cn at virginia.edu>*
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20190225/bcfea6cc/attachment.html>


More information about the USRP-users mailing list