[USRP-users] Solved: AW: thunderbolt to sfp+

Emanuel.Staudinger at dlr.de Emanuel.Staudinger at dlr.de
Thu Feb 14 07:27:54 EST 2019


Dear Ali, dear all,

We solved the problem with the MTU size:
For everybody trying to use an SFP+ to RJ45 transceiver for 10Gig: Do not use a Mikrotik S+RJ10, as Jumbo frames are not supported.
We now use a Ubiquiti UF-RJ45-10G which is in a similar price range: that one works well ☺

We can now also confirm that the Sonnet Solo10G 10Gig-Ethernet to Thunderbolt 3 adapter works well in Ubuntu 18.10 with the default Atlantic driver shipped with the distro. Streaming with the required large MTUs works. For network configuration we used a manual netplan setting to match the setting to the MAC address of the Solo10G adapter.

Cheers,
Emanuel

Von: USRP-users [mailto:usrp-users-bounces at lists.ettus.com] Im Auftrag von Emanuel via USRP-users
Gesendet: Monday, February 11, 2019 8:00 AM
An: sdormian at eng.ucsd.edu
Cc: usrp-users at lists.ettus.com
Betreff: Re: [USRP-users] thunderbolt to sfp+

Dear Ali,

Thank you for your help.
I guess we found the source of our problem:
We also tried our setup now with a Thunderbolt 3 to RJ45 10Gbit Adapter from Sonnet which has an Intel network chip inside. Guess what… it did not work --> still got the warning that the MTU size is too low. My colleague then raised the question about the specific SFP+ to 10G RJ45 transceiver we plugged into the X310. And it seems that this one is the source of all troubles: it does not support Jumbo frames.

The transceiver we are using is the one from Mikrotik: S+RJ10. After some search in the Internet we discovered that this transceiver indeed does not support Jumbo frames. Some people complained about it in some forums. Mikrotik does not state this in their specifications though. I tried to ping the X310 with larger packet sizes and every packet size above 1500 results in a ping drop.

We are switching to another SFP+ transceiver now. Personally, I don’t get it why one would design and manufacture a 10Gbit SFP+ adapter not supporting packet sizes above 1500.

Cheers,
Emanuel

Von: USRP-users [mailto:usrp-users-bounces at lists.ettus.com] Im Auftrag von Ali Dormiani via USRP-users
Gesendet: Friday, February 08, 2019 7:36 PM
An: usrp-users
Betreff: Re: [USRP-users] thunderbolt to sfp+

Well you mentioned your set up works with the Intel chip so it cant be a configuration issue....

My only idea is to try adding the driver name to the main config file /etc/modules

atlantic

https://www.cyberciti.biz/faq/linux-how-to-load-a-kernel-module-automatically-at-boot-time/




On Thu, Feb 7, 2019 at 10:54 PM <Emanuel.Staudinger at dlr.de<mailto:Emanuel.Staudinger at dlr.de>> wrote:
Well, the newest driver is loaded. If I check with “ethtool –i “myInterfaceName”” I can see that the latest driver is really used (the one I compiled and inserted).
Also, checking with ifconfig tells me that the MTU is is, e.g., 8000 or 9000. However, UHD only reads the 1500 size regardless of what is set.
Any ideas?

Cheers,
Emanuel

Von: USRP-users [mailto:usrp-users-bounces at lists.ettus.com<mailto:usrp-users-bounces at lists.ettus.com>] Im Auftrag von Ali Dormiani via USRP-users
Gesendet: Thursday, February 07, 2019 6:49 PM
An: usrp-users
Betreff: Re: [USRP-users] thunderbolt to sfp+

Maybe the old driver is getting loaded by the kernel on boot?

I had problems when first using ixgbe (Intel 10 Gbe) driver because I was lazy about unloading the stock (outdated) driver that came with the Linux distro.

rmmod <driver>

modprobe <driver>

Can't think of what the issue could be with your Sonnet Solo if the driver you compiled is loaded as intended.

Regardless for people looking at this thread, I have not had any problems with Intel x520-DA2 or x550 based products. Intel is also very good at keeping their open source drivers up to date (cough BROADCOM cough).



On Wed, Feb 6, 2019 at 11:59 PM <Emanuel.Staudinger at dlr.de<mailto:Emanuel.Staudinger at dlr.de>> wrote:
Dear Ali,

I recently tried the Sonnet Solo 10G Ethernet to Thunderbolt 3 Adapter under Linux 18.04LTS and 18.10. This adapter has the AQC107S chip.
In principle they work out of the box.
You can set an MTU size larger than 1500 in Ubuntu (either via netplan or the old configuration).
However, this MTU size is not honored in my case: UHD complains that the MTU size is too small. I compiled the latest AQC107 driver and applied it --> no change in MTU. Personally I don’t know yet, where the actual problem lies.

We had to change our setup and are now using a card with the Intel chip again.

Best regards,
Emanuel


Von: USRP-users [mailto:usrp-users-bounces at lists.ettus.com<mailto:usrp-users-bounces at lists.ettus.com>] Im Auftrag von Ali Dormiani via USRP-users
Gesendet: Wednesday, February 06, 2019 7:35 PM
An: usrp-users
Betreff: Re: [USRP-users] thunderbolt to sfp+

It seems that Linux kernel 4.11 added support for the AQC107.

https://www.phoronix.com/scan.php?page=news_item&px=Linux-4.11-Networking

Ubuntu 18.04 and higher has kernel 4.15 so you should be fine.

Our lab has been using this converter.

https://www.sonnettech.com/product/twin10g.html

Even though they don't list Linux support it works fine after I compiled the Intel driver manually.

TLDR; It should work. Use Ubuntu 18+. If it does not work then please update this thread and I can maybe help troubleshoot.

On Wed, Feb 6, 2019 at 10:10 AM Rob Kossler via USRP-users <usrp-users at lists.ettus.com<mailto:usrp-users at lists.ettus.com>> wrote:
I am interested in purchasing a Thunderbolt to SFP adapter and I found this QNAP QNA-T310G1S<https://www.qnap.com/en-us/product/qna-tb-10gbe> available from B&H for $169<https://www.bhphotovideo.com/c/product/1452479-REG/qnap_qna_t310g1s_single_port_thunderbolt3_to.html>. Does anyone know if this works under Ubuntu? I found that there is a Linux driver available for the AQC107 part, so I think that is likely that it will work, but wanted to see if anyone had tried it.

Rob
_______________________________________________
USRP-users mailing list
USRP-users at lists.ettus.com<mailto:USRP-users at lists.ettus.com>
http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20190214/66bd17c8/attachment.html>


More information about the USRP-users mailing list