[USRP-users] Old USRP2 - Network Link Issues

Marcus D. Leech patchvonbraun at gmail.com
Thu Feb 7 12:40:55 EST 2019


On 02/07/2019 12:33 PM, Iain Young via USRP-users wrote:
> Hi Folks,
>
> I have an old USRP2, which I recently acquired sans top/sides. It powers
> up and loads both the CPLD and firmware (LEDS D+F lit) just fine. LED B
> lights if I connect a MIMO cable. I have also placed the latest firmware
> on the SD card.
>
> However, the gigabit ethernet won't come up. It attempts to, but goes
> down after a couple of seconds. It then continues to flap. I've tried
> four different LAN cables (including the one that my N200 happily talks
> to), two switches, and the dedicated PC port the N200 is usually
> connected to.
>
> Connecting to the serial interface, I do see it changing the ethernet
> speed to 1000 and then 0 continually.
>
>
> While I know it's old and 'not recommended for new installations', does
> anyone have any ideas on how I might proceed, or what to check or try
> next ?
>
> The eventual use for this particular USRP2 is a slave via the MIMO
> cable to the N200 in Shared Ethernet Mode, so maybe there's a way
> to get the IP address etc, and set time&clock sources to MIMO without
> needing the ethernet up ? Or am I going to need it up to setup the
> Shared Ethernet Mode ?
>
>
> Thanks in advance, and Best Regards
>
> Iain
>
There was a problem with the National Semiconductor PHY chips used on 
these.  Some worked indefinitely, some suicided.  They got
   really hot, too.

I don't know if the PHY chip is still made, but you might be able to 
find "new old stock".

http://files.ettus.com/schematics/usrp2/


Good luck





More information about the USRP-users mailing list