[USRP-users] thunderbolt to sfp+

Emanuel.Staudinger at dlr.de Emanuel.Staudinger at dlr.de
Thu Feb 7 02:59:33 EST 2019


Dear Ali,

I recently tried the Sonnet Solo 10G Ethernet to Thunderbolt 3 Adapter under Linux 18.04LTS and 18.10. This adapter has the AQC107S chip.
In principle they work out of the box.
You can set an MTU size larger than 1500 in Ubuntu (either via netplan or the old configuration).
However, this MTU size is not honored in my case: UHD complains that the MTU size is too small. I compiled the latest AQC107 driver and applied it --> no change in MTU. Personally I don’t know yet, where the actual problem lies.

We had to change our setup and are now using a card with the Intel chip again.

Best regards,
Emanuel


Von: USRP-users [mailto:usrp-users-bounces at lists.ettus.com] Im Auftrag von Ali Dormiani via USRP-users
Gesendet: Wednesday, February 06, 2019 7:35 PM
An: usrp-users
Betreff: Re: [USRP-users] thunderbolt to sfp+

It seems that Linux kernel 4.11 added support for the AQC107.

https://www.phoronix.com/scan.php?page=news_item&px=Linux-4.11-Networking

Ubuntu 18.04 and higher has kernel 4.15 so you should be fine.

Our lab has been using this converter.

https://www.sonnettech.com/product/twin10g.html

Even though they don't list Linux support it works fine after I compiled the Intel driver manually.

TLDR; It should work. Use Ubuntu 18+. If it does not work then please update this thread and I can maybe help troubleshoot.

On Wed, Feb 6, 2019 at 10:10 AM Rob Kossler via USRP-users <usrp-users at lists.ettus.com<mailto:usrp-users at lists.ettus.com>> wrote:
I am interested in purchasing a Thunderbolt to SFP adapter and I found this QNAP QNA-T310G1S<https://www.qnap.com/en-us/product/qna-tb-10gbe> available from B&H for $169<https://www.bhphotovideo.com/c/product/1452479-REG/qnap_qna_t310g1s_single_port_thunderbolt3_to.html>. Does anyone know if this works under Ubuntu? I found that there is a Linux driver available for the AQC107 part, so I think that is likely that it will work, but wanted to see if anyone had tried it.

Rob
_______________________________________________
USRP-users mailing list
USRP-users at lists.ettus.com<mailto:USRP-users at lists.ettus.com>
http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20190207/0d3d22ab/attachment.html>


More information about the USRP-users mailing list