[USRP-users] X310 LookupError CORDIC_FREQ

Alexander Olihovik ano9cn at virginia.edu
Wed Feb 6 14:05:14 EST 2019


Hi Jonathan,

Thanks for the response. I tried as you suggested and found the same result
as before. I haven't yet modified the UHD code, except for doing a
"submodule init" and "submodule update". Do you have any other suggestions?

git status
HEAD detached at release_003_010_003_000
Changes not staged for commit:
  (use "git add <file>..." to update what will be committed)
  (use "git checkout -- <file>..." to discard changes in working directory)
  (commit or discard the untracked or modified content in submodules)

    modified:   ../../fpga-src (modified content)

no changes added to commit (use "git add" and/or "git commit -a")


On Wed, Feb 6, 2019 at 3:11 AM Jonathon Pendlum <jonathon.pendlum at ettus.com>
wrote:

> Hi Alex,
>
> It looks like your DDC / DUC block controller XML file is from a newer
> version of UHD. I would suggest checking that your UHD source does not have
> any changes, especially ddc.xml and duc.xml. You should also uninstall UHD
> and do a new build: (from the build dir) 'make uninstall; make clean; make
> install'.
>
> Jonathon
>
> On Wed, Feb 6, 2019 at 6:46 AM Alexander Olihovik via USRP-users <
> usrp-users at lists.ettus.com> wrote:
>
>> Hi all,
>>
>> I'm getting the following LookupError after making/installing
>> UHD_003.010.003 and building/writing the bitstream for the X310_HG project:
>> ---------------------------------
>> linux; GNU C++ version 7.3.0; Boost_106501;
>> UHD_003.010.003.HEAD-0-gef157678
>>
>> -- X300 initialization sequence...
>> -- Determining maximum frame size... 1472 bytes.
>> -- Setup basic communication...
>> -- Loading values from EEPROM...
>> -- Setup RF frontend clocking...
>> -- Radio 1x clock:200
>> -- Detecting internal GPSDO.... Found an internal GPSDO: LC_XO, Firmware
>> Rev 0.929a
>> -- [DMA FIFO] Running BIST for FIFO 0... pass (Throughput: 1305.3MB/s)
>> -- [DMA FIFO] Running BIST for FIFO 1... pass (Throughput: 1305.2MB/s)
>> -- [RFNoC Radio] Performing register loopback test... pass
>> -- [RFNoC Radio] Performing register loopback test... pass
>> -- [RFNoC Radio] Performing register loopback test... pass
>> -- [RFNoC Radio] Performing register loopback test... pass
>> Error: LookupError: KeyError: Unknown settings register name: CORDIC_FREQ
>> ---------------------------------
>>
>> I also get the same results when attempting the following:
>> uhd_images_downloader
>> uhd_image_loader --args type=x300,add=192.168.10.2
>> Powercycled the X310
>> uhd_usrp_probe
>>
>>
>> Is there a solution to this? Did I miss something when building UHD or
>> the bitstream?
>>
>>
>> Best,
>> Alex
>> _______________________________________________
>> USRP-users mailing list
>> USRP-users at lists.ettus.com
>> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>>
>

-- 




*Alex OlihovikUniversity of Virginia 2013BS Electrical EngineeringBS
Computer Engineeringano9cn at virginia.edu <ano9cn at virginia.edu>*
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20190206/f3d88b04/attachment.html>


More information about the USRP-users mailing list