[USRP-users] X310 LookupError CORDIC_FREQ

Alexander Olihovik ano9cn at virginia.edu
Tue Feb 5 16:45:36 EST 2019


Hi all,

I'm getting the following LookupError after making/installing
UHD_003.010.003 and building/writing the bitstream for the X310_HG project:
---------------------------------
linux; GNU C++ version 7.3.0; Boost_106501; UHD_003.010.003.HEAD-0-gef157678

-- X300 initialization sequence...
-- Determining maximum frame size... 1472 bytes.
-- Setup basic communication...
-- Loading values from EEPROM...
-- Setup RF frontend clocking...
-- Radio 1x clock:200
-- Detecting internal GPSDO.... Found an internal GPSDO: LC_XO, Firmware
Rev 0.929a
-- [DMA FIFO] Running BIST for FIFO 0... pass (Throughput: 1305.3MB/s)
-- [DMA FIFO] Running BIST for FIFO 1... pass (Throughput: 1305.2MB/s)
-- [RFNoC Radio] Performing register loopback test... pass
-- [RFNoC Radio] Performing register loopback test... pass
-- [RFNoC Radio] Performing register loopback test... pass
-- [RFNoC Radio] Performing register loopback test... pass
Error: LookupError: KeyError: Unknown settings register name: CORDIC_FREQ
---------------------------------

I also get the same results when attempting the following:
uhd_images_downloader
uhd_image_loader --args type=x300,add=192.168.10.2
Powercycled the X310
uhd_usrp_probe


Is there a solution to this? Did I miss something when building UHD or the
bitstream?


Best,
Alex
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20190205/ebe54760/attachment.html>


More information about the USRP-users mailing list