[USRP-users] RFNOC GPIO Remapping

Chatterjee, Pratik chatte29 at msu.edu
Fri Feb 1 13:09:16 EST 2019


Hello,

I am using an X310 and I need to monitor a signal out of GPIO from my custom block. Going through the archives I prefer the option to disconnect the fp_gpio lines from the radio core to my custom block. So I snapped the fp_gpio lines going in gpio_attr to a custom module in db_control to observe the signal. The image compiled fine. But when I probe the device, I get the following error

[INFO] [UHD] linux; GNU C++ version 5.4.0 20160609; Boost_105800; UHD_3.14.0.HEAD-110-g6af6ac32
[INFO] [X300] X300 initialization sequence...
[INFO] [X300] Maximum frame size: 8000 bytes.
[INFO] [X300] Radio 1x clock: 200 MHz
[INFO] [GPS] No GPSDO found
[INFO] [0/DmaFIFO_0] Initializing block control (NOC ID: 0xF1F0D00000000000)
[INFO] [0/DmaFIFO_0] BIST passed (Throughput: 1315 MB/s)
[INFO] [0/DmaFIFO_0] BIST passed (Throughput: 1309 MB/s)
[INFO] [0/Radio_0] Initializing block control (NOC ID: 0x12AD100000000001)
terminate called after throwing an instance of 'uhd::io_error'
  what():  EnvironmentError: IOError: [0/Radio_0] sr_write() failed: EnvironmentError: IOError: Block ctrl (CE_01_Port_40) no response packet - AssertionError: bool(buff)
  in uint64_t ctrl_iface_impl<_endianness>::wait_for_ack(bool, double) [with uhd::endianness_t _endianness = (uhd::endianness_t)0u; uint64_t = long unsigned int]
  at /home/delta3/rfnoc3/src/uhd/host/lib/rfnoc/ctrl_iface.cpp:155

Is there something more than just disconnecting the lines. Any help will be appreciated. Thank you,

Pratik

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20190201/182988ee/attachment.html>


More information about the USRP-users mailing list