[USRP-users] UHD Freezing after Underruns/Late Samples and Freezing

Marcus D. Leech mleech at ripnet.com
Fri Oct 20 20:28:41 EDT 2017


On 10/20/2017 07:25 PM, Richard Mcallister via USRP-users wrote:
> Hi all,
>
> I'm currently using 4 X310's with LFTXs to transmit. The flowgraph 
> hasn't changed from last semester when I made it, but its attached. 
> When I run it with more than one USRP, it will eventually crash and 
> freeze. UHD will output a single U (underrun) and then continuously 
> print L (late sample?). With 4 USRPs, this will happen almost immediately.
>
>  I've tried running it on a different computer after system monitor 
> showed that (roughly) for each USRP being used, one of the 16 cores 
> would go to around 100% while the others stayed low. I also tried 
> changing the Ethernet cable, with no success. No success. I've also 
> tried using ethtool to add more TX/RX descriptors, and I've raised the 
> sysctl rmem/wmem buffers as UHD indicates. Does anyone else have any 
> good suggestions on what to try?
>
> Thanks,
>
> Rich McAllister
>
>
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
What version of UHD?

You're using a 1GiGe interface to your X310s?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20171020/ffec716e/attachment-0002.html>


More information about the USRP-users mailing list