[USRP-users] UHD Freezing after Underruns/Late Samples and Freezing

Richard Mcallister rjm96 at bu.edu
Fri Oct 20 19:25:25 EDT 2017


Hi all,

I'm currently using 4 X310's with LFTXs to transmit. The flowgraph hasn't
changed from last semester when I made it, but its attached. When I run it
with more than one USRP, it will eventually crash and freeze. UHD will
output a single U (underrun) and then continuously print L (late sample?).
With 4 USRPs, this will happen almost immediately.

 I've tried running it on a different computer after system monitor showed
that (roughly) for each USRP being used, one of the 16 cores would go to
around 100% while the others stayed low. I also tried changing the Ethernet
cable, with no success. No success. I've also tried using ethtool to add
more TX/RX descriptors, and I've raised the sysctl rmem/wmem buffers as UHD
indicates. Does anyone else have any good suggestions on what to try?

Thanks,

Rich McAllister
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20171020/b57b9360/attachment-0002.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: MultiCell_Sine.grc
Type: application/octet-stream
Size: 135007 bytes
Desc: not available
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20171020/b57b9360/attachment.grc>


More information about the USRP-users mailing list