[USRP-users] Still having problems receiving multiple channels

Janos Buttgereit janos.buttgereit at fh-muenster.de
Tue Oct 17 06:32:24 EDT 2017


Hello everybody,

I wrote to the mailing list some month ago as I had problems setting up a multi_usrp from four USRP N210 with the help of the C++ API. As there are other projects with higher priority, I’m just working on the USRP-based stuff from time to time, that explains why there is a problem unsolved for months now. In the end some specifications changed, so I dropped the N210 and I’m now working with a pair of X300 devices. 

The problem I still have after having solved a lot of other things with your help, is that there’s always only valid data from the first channel. To make sure that there is no bug in my fairly big code, I created a simple command line application, that just records four channels to four .bin files. These files are then loaded in gnu octave In this scenario, both X300 devices are clocked and time synced by an external OctoClock and fed with the same sine-wave, generated by a Signal Generator and split by a power splitter.

I pasted my code and a plot of what the received data looks like here:
https://gist.github.com/JanosGit/af51ae66c3a5c8a90119ec5f98e01162 <https://gist.github.com/JanosGit/af51ae66c3a5c8a90119ec5f98e01162>

By the way, a modified version of the rx_multi_samples example which I modified to output the samples to a file instead of dropping them showed the exactly same result.

For your Information: I’m working on a fresh Ubuntu installation with the X300 devices connected over SFP Cables to a dual 10GBit Ethernet PCIe Card. Receiving valid data on all four channels works with the same hardware but a slightly older Ubuntu installation on a second computer when using gnu radio (never change a running system), so I don’t think there is any hardware defect. I just need to up- or downgrade the FPGA Image when switching between both systems. While executing the application linked above, all four green LEDs underneath the RX2 Ports are lit.

I’m really looking forward to finding a solution with your help!

Regards
Janos Buttgereit
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20171017/a02a34e5/attachment-0002.html>


More information about the USRP-users mailing list