[USRP-users] Trouble Connecting to N210 in VMWare

Marcus Müller marcus.mueller at ettus.com
Sat Oct 14 13:17:31 EDT 2017


Hi Tellrell,

I'm sorry, I don't know – to be honest, I haven't worked with exactly
your virtualization platform, and as said, I wouldn't recommend it,
either, so I'm afraid you'll have to figure this one out yourself :(

Best regards,
Marcus


On 10.10.2017 20:58, Tellrell White via USRP-users wrote:
> Hello Marcus
> Okay. I gave your suggestions a try. Using Network manager, I edited
> the existing connection settings, to manual, changed the  the IP4
> address to 192.168.10.3 and the netmask to 255.255.255.0 and left the
> gateway address blank. After making these changes I restarted the VM
> and proceeded to try to ping the N210 only to get the same result as
> before, host unreachable. You mentioned before  to pick a virtualized
> network card that is gigabit capable. How exactly could I ensure that
> I've done this??
>
> Tellrell
>
>
> On Sunday, October 8, 2017 11:38 AM, Marcus Müller via USRP-users
> <usrp-users at lists.ettus.com> wrote:
>
>
> Hi Tellrell,
> we should probably change the manual to say "If you're not using
> NetworkManager, do …".
> If you're actually using NetworkManager inside that VM (chances are
> high!), instead of trxing to "sudo ifconfig…", just set up your
> network interface to a static IP Address with the right subnet through
> the graphical networking dialogue of the Linux Distro inside the VM.
> Note that it's also crucial that you pick a virtualized network card
> to be "emulated" inside the VM that is gigabit capable.
> Also note that unless you really know what you're doing,
> performance-wise, it's not recommended to do SDR hardware interfacing
> inside a VM; the additional layer of hardware virtualization (as you
> notice) doesn't make things easier, nor faster. But in general, with a
> good virtualized network card and bridged ethernet, yes, things should
> work.
> Best regards,
> Marcus
>
> On 10/08/2017 08:05 AM, Tellrell White via USRP-users wrote:
>> Ken
>> I tried your first suggestion. I went into the configuration options
>> and changed the network adapter to "bridged". Now there's a checkbox
>> underneath the bridged option which says "Replicate Physical
>> Connection Network State", I'm totally sure what this options, but I
>> left it unchecked. After changing the network adapter to bridged i
>> restarted the virtual machine and then followed the instructions on
>> the UHD & USRP manual stating to set up a static ip on the host use
>> the following command , sudo ifconfig <interface> 192.168.10.1. For
>> interface, I used eth0 for my configuration. Then i ran ifconfig to
>> see if this changed my ip address. The results are attached below.
>> Then, I proceeded to try to ping the device. This resulted in me
>> getting the same results as before, "host unreacheable", as shown in
>> the other attachment below. Do I need to go into the /interfaces file
>> and change the ip that way? And is there anything else I may be
>> neglecting to do to fix this issue?
>>
>> Tellrell
>>
>>
>> On Saturday, October 7, 2017 11:36 AM, Ken M Erney
>> <gsmmobiledev at gmail.com> <mailto:gsmmobiledev at gmail.com> wrote:
>>
>>
>> Hi Tellrell,
>>
>> I am using virtual box but I have used VMWare Fusion as well and both
>> have the option to specify that the network adapter should be
>> bridged.  I am not a network guy, so I cant offer any advice
>> regarding the alias approach you mention.  What I do know regarding
>> my setup is that when its configured in bridged mode, the adapter on
>> the VM will show up on your network as another machine and not be
>> NAT’d behind the VMWare client.  So for VMWare Fusion (OSX) and
>> virtual box, there is a setting in the guest configuration that
>> allows you to specify if the adapter is NAT’d, bridged, host only,
>> etc.  In that config, specify bridged.  Once the OS boots, you can
>> then go into the Ubuntu network config and configure the adapter with
>> a manually assigned IP (i.e. not DHCP). In my case, I modified the
>> interfaces file in ubuntu to use a static IP (192.168.10.5) and
>> subnet (255.255.255.1).  No gateway.  It then worked without issue.
>>
>> Another option is to change the IP of the N210 to a fixed address on
>> your real network.  The N210 won’t do DHCP but you can usually
>> reserve and IP on your network and then just burn it into the N210.
>>  Then on the guest OS config side, also specify bridged mode and let
>> your network DHCP assign an IP to the guest.  It should work that way
>> as well.
>>
>> Give that you are using an alias, it would seem that this would do
>> the same thing as what I am describing.  What we need is somebody
>> with network experience to chime in here.  Oh one thing… when you say
>> “alias” are you referring to setting this in the hosts file on
>> ubuntu?  That may not work the same way, but I don’t know.  One other
>> thing is to make sure that IP tables or the ubuntu firewall is turned
>> off.  You CAN run a firewall on Ubuntu and still support the N210,
>> but turning it off for right now would make sure that it is not
>> interfering with the comms.
>>
>> Also, when running the uhd_find_devices… try calling it and passing
>> it the ip address of your N210… just in case.
>>
>> - ken
>>
>>
>>> On Oct 6, 2017, at 11:31 PM, Tellrell White via USRP-users
>>> <usrp-users at lists.ettus.com <mailto:usrp-users at lists.ettus.com>> wrote:
>>>
>>> Ken
>>> I'm using vmware. Not sure if you used the same client but how
>>> exactly did you configure your vm to bridged. Also, I used the
>>> command to set an alias ip to 192.168.10.1 which is in the same
>>> subnet as the N210, not sure if thats different from the manual
>>> approach you're suggesting.
>>>
>>> Tellrell
>>>
>>>
>>> On Friday, October 6, 2017 10:32 PM, Ken M Erney
>>> <gsmmobiledev at gmail.com <mailto:gsmmobiledev at gmail.com>> wrote:
>>>
>>>
>>> What are you using as the VM software client (e.g. VMware, virtual
>>> box, etc.). I was able to get mine to work but I had to configure my
>>> VM eth as "bridged". I also set it with a manually configured ip in
>>> the same subnet as the N210.
>>>
>>> - ken
>>>
>>> On Oct 6, 2017 10:23 PM, "Tellrell White via USRP-users"
>>> <usrp-users at lists.ettus.com <mailto:usrp-users at lists.ettus.com>> wrote:
>>>
>>>     Hello Guys.
>>>     I'm currently trying to connect to the N210 using an ubuntu
>>>     14.04 virtual machine. I've tried the commands uhd_find_devices
>>>     and also uhd_usrp_probe and they both indicate "no devices
>>>     found". Pinging 192.168.2 comes up empty as well. I used the
>>>     command sudo ip address add 192.168.10.1/255.255.255.0
>>>     <http://192.168.10.1/255.255.255.0> dev eth0 to set the ip of
>>>     the virtual machine. I'm connected to the internet via wi-fi.
>>>     The version of UHD i'm using is 3.10.2. Any help is greatly
>>>     appreciated.
>>>
>>>     Regards
>>>     Tellrell
>>>
>>>     ______________________________ _________________
>>>     USRP-users mailing list
>>>     USRP-users at lists.ettus.com <mailto:USRP-users at lists.ettus.com>
>>>     http://lists.ettus.com/ mailman/listinfo/usrp-users_
>>>     lists.ettus.com
>>>     <http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com>
>>>
>>>
>>>
>>>
>>> _______________________________________________
>>> USRP-users mailing list
>>> USRP-users at lists.ettus.com <mailto:USRP-users at lists.ettus.com>
>>> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>>
>>
>>
>>
>>
>> _______________________________________________
>> USRP-users mailing list
>> USRP-users at lists.ettus.com <mailto:USRP-users at lists.ettus.com>
>> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com <mailto:USRP-users at lists.ettus.com>
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
>
>
>
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20171014/ce2a2e8c/attachment-0002.html>


More information about the USRP-users mailing list