[USRP-users] No output from OOT RFNOC Module

Dario Pennisi dario at iptronix.com
Thu Oct 12 00:48:10 EDT 2017


Hi,
If your block is sending small amounts of bursty data the timeout being printed is irrelevant as it just indicates no data has been sent for a given time lapse not that no data has been received at all.

Dario Pennisi








On Wed, Oct 11, 2017 at 10:10 PM +0200, "John Medrano via USRP-users" <usrp-users at lists.ettus.com<mailto:usrp-users at lists.ettus.com>> wrote:

We are in process of debugging an out of tree module that we created. It is a source object that generates a given sequence.

We have compiled and loaded in our X310 device and all looks good. But when we run it, we get no output.

Below is some of the output from the device.

Two questions:

1. Why do we receive the following debug message:
[INFO] [RFNOC] Assuming max packet size for 0/memory_0

2. What is meant by RFNOC blocks with streaming port, and creating rx_streamer messages?

Please advise,

Thanks,
John

[INFO] [CORES] Performing timer loopback test...
[INFO] [CORES] Timer loopback test passed
INFO: Setting args on 0/FIFO_0 (gr_vlen=256,spp=256)
DEBUG: output item size: 2048
INFO: Setting args on 0/memory_0 (gr_vlen=256,spp=256)
DEBUG: output item size: 2048
[INFO] [RFNOC] Assuming max packet size for 0/memory_0
DEBUG: check_topology()
DEBUG: RFNoC blocks with streaming ports: 1
DEBUG: start(): ninputs == 0 noutputs == 1
DEBUG: creating rx streamer with: gr_vlen=256,spp=256,block_id=0/FIFO_0,block_port=0
timeout on chan 0

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20171012/e770eed6/attachment-0002.html>


More information about the USRP-users mailing list