[USRP-users] rfnoc blocks with multiple inputs/outputs

Dario Pennisi dario at iptronix.com
Thu Oct 5 02:57:59 EDT 2017


Hi,
I am still struggling with a block which should have 2 inputs and 1 output. Apparently everything is fine with both FPGA and software but the second input is not fed with data.
I could not find any example of an asymmetric block with different number of inputs/outputs so I am starting to suspect this is not supported. Can anyone tell me if this is the case and I need to add a dummy output?

Also, when defining block I see that in the xml there is the possibility to specify nports parameter so that a single port definition provides more than one port. If i set nports=2 for the input I am not sure how to define the gnuradio xml descriptor and If I just describe two ports as usual block will not initialize properly.

Finally, I understand that system clock rate on AXI bus is 166 MHz and since NOC ports are 64 bits, on X310 a single block should not be able to process two input streams at 200 MSPS.
Even raising AXI bus clock to 200 MHz would fail as but would still not provide sufficient overhead for packet headers.
Is there any suggested trick to handle this situation? Is it eventually possible to have a single rfnoc block connect to two AXI ports rather than just one?

Thanks,

Dario Pennisi

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20171005/9bfcdbdb/attachment-0002.html>


More information about the USRP-users mailing list