[USRP-users] warning on UDP buffer size when using Python API

Osvaldo Alcala (Ozzie) oalcala at qti.qualcomm.com
Tue Oct 3 11:11:39 EDT 2017


Will try it. Thank you!

O

From: Derek Kozel [mailto:derek.kozel at ettus.com]
Sent: Tuesday, October 03, 2017 4:48 AM
To: Osvaldo Alcala (Ozzie) <oalcala at qti.qualcomm.com>
Cc: Andrej Rode <mail at andrejro.de>; usrp-users at lists.ettus.com
Subject: Re: [USRP-users] warning on UDP buffer size when using Python API

Hello,
The requested sizes do change a little during the initialization. Also the settings are not persistent across reboots of your host computer so need to be re-appled each time you restart or changes made to other configuration files to make them persistent.
Can you confirm which sizes you are using in your commands at the moment? For each of the read and write settings you should use the largest size listed, no warnings should be displayed after that. You can try running benchmark_rate which is a C++ program to test if this is a Python specific issue or just a settings problem.
Derek

On Mon, Sep 25, 2017 at 6:41 PM, Osvaldo Alcala (Ozzie) via USRP-users <usrp-users at lists.ettus.com<mailto:usrp-users at lists.ettus.com>> wrote:
Im just running the sample python API script to capture samples from the receiver. Im using an X310.

I tried running the script directly from command line to make sure nothing was changed and I still got the same warning. It’s a bit strange that when I change the buffer size to what is requested, it still asks for different buffer size. Something changes, but not sure why, as I try to keep everything exactly the same in the system.

Any other ideas would be useful

Thank yoU!

O

-----Original Message-----
From: Andrej Rode [mailto:mail at andrejro.de<mailto:mail at andrejro.de>]
Sent: Friday, September 22, 2017 1:56 PM
To: Osvaldo Alcala (Ozzie) <oalcala at qti.qualcomm.com<mailto:oalcala at qti.qualcomm.com>>
Cc: usrp-users at lists.ettus.com<mailto:usrp-users at lists.ettus.com>
Subject: Re: [USRP-users] warning on UDP buffer size when using Python API
Hi,

On Fri, Sep 22, 2017 at 08:38:32PM +0000, Osvaldo Alcala (Ozzie) wrote:
> Thank you. I should have said that I did try the command that shows in the screenshot, but the required buffer size keeps changing: thus I get the same error every time.

So maybe in your script/application you have increasing buffer sizes and thus the uhd send()/recv() calls try to send bigger buffers?

But that's just guessing. An explanation what you are trying to do with the Python API would be helpful, so the root cause (either in UHD or your application can be identified)

Cheers,
Andrej

--
Andrej Rode
GPG Key: 750B CBBB 4A75 811A 4D5F 03ED 5C23 7FB8 9A7D A2AA
_______________________________________________
USRP-users mailing list
USRP-users at lists.ettus.com<mailto:USRP-users at lists.ettus.com>
http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20171003/dbf348b1/attachment-0002.html>


More information about the USRP-users mailing list